System settings shows wrong General font by default

Bug #649509 reported by Alessandro Ghersi on 2010-09-28
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kubuntu-default-settings (Ubuntu)
High
Unassigned

Bug Description

System settings shows wrong general font by default (Bitstream Charter 9) BUT the font is right (San Serif 9)

Binary package hint: kdebase-workspace

Running Live CD 2010 09 27 i386

  QFont f0("Sans Serif", 9); // general/menu/desktop
  QFont f1("Monospace", 9);
  QFont f2("Sans Serif", 8); // toolbar
  QFont f3("Sans Serif", 8); // window title
  QFont f4("Sans Serif", 9); // taskbar
  QFont f5("Sans Serif", 8); // smallestReadableFont

See the screenshot

tags: added: kubuntu
tags: added: iso-testing
Changed in kdebase-workspace (Ubuntu):
milestone: none → ubuntu-10.10
importance: Undecided → High

It still present in the current iso today

I discovered that we have the right font (San Serif) but system settings shows Bitstream Charter instead.

summary: - Wrong General font by default
+ System settings shows wrong General font by default
description: updated
Felix Geyer (debfx) wrote :

This is caused by this entry in kdeglobals:
font=Sans,8.-1,5,50,0,0,0,0,0

affects: kdebase-workspace (Ubuntu) → kubuntu-default-settings (Ubuntu)
Felix Geyer (debfx) on 2010-09-29
Changed in kubuntu-default-settings (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-default-settings - 1:10.10ubuntu9

---------------
kubuntu-default-settings (1:10.10ubuntu9) maverick; urgency=low

  * Remove General font setting from kdeglobals. It's not necessary anymore
    and causes problems as the font "Sans" doesn't exist. (LP: #649509)
 -- Felix Geyer <email address hidden> Thu, 30 Sep 2010 01:02:45 +0200

Changed in kubuntu-default-settings (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments