Desktop displays root directory (/) after upgrade from Gutsy to Hardy

Bug #174532 reported by Veresses Anastasios on 2007-12-06
14
Affects Status Importance Assigned to Milestone
kubuntu-default-settings (Ubuntu)
Medium
Unassigned

Bug Description

I have upgrade my Kubuntu Gutsy to Hardy with apt-get dist-upgrade

After the upgrade my user desktop at kde changed to root directory ( / ) and it was read only.

I fixed it with this procedure:

Kmenu -> System Settings -> About me -> Paths -> Desktop Path

I change my user path /home/user/Desktop to /

then i click apply

after that i changed back to my user home directory /home/user/Desktop
apply and now i have back my Desktop

Daniel Hahler (blueyed) wrote :

Confirmed.
The workaround worked for me, too.
Please note that there has been the correct path already been displayed before and that you should say "no" when being asked for moving the files. Maybe just changing the some dialog element back and forth and then clicking Apply would have helped already.
I'm guessing that it comes from kubuntu-default-settings. Please re-assign the package, if you know it better.

Alexia Death (alexiade) wrote :

Confirmed. Any small change to enable the apply button is enough to trigger correction.

Additionally, When applying the bogus change a diaog comes up asking if I want to move my files in my desktop at "/" to my new desktop path. Nothing wrong with that except it has two buttons, "Move" and "Cancel". I believe it should be Yes and No, otherwise its rather counterintuitive what one should do.

trtl (pdersjant) wrote :

Bug confirmed, but workaround does not work. If I use it, nothing changes.

Markus Straub (markus-straub2) wrote :

The same thing happened to me after I upgraded KDE to 3.5.9 while still using Kubuntu 7.10
(deb http://ppa.launchpad.net/kubuntu-kde-3.5.9/ubuntu gutsy main)

The above solution doesn't seem to work for me though:
If I use "System Settings > About Me > Paths" to update the path, it is written into ~/.config/user-dirs.dirs correctly. After restarting KDE the path is still present in user-dirs.dirs, but "kde-config --userpath desktop" reveals that my Desktop still points to /. Also of course my Desktop shows me icons for my root-directory.

My next approach, namely to put the line "Desktop=$HOME/Desktop" into the [Paths]-section of ~/.kde/share/config/kdeglobals doesn't solve the problem either.

Markus Straub (markus-straub2) wrote :

Further research finally led to a solution:
(found on: http://ubuntuforums.org/showthread.php?t=609005&page=2)

I deleted the XDG_DESKTOP_DIR-line from ~/.config/user-dirs.dirs, installed xdg-user-dirs, ran xdg-user-dirs-update, logged out and in again and everything was nice and dandy - again. My Desktop is no longer / but ~/Desktop.

Peter (pdrakeweb) wrote :

The workaround posted by Markus Straub worked perfectly for me.

Daniel Hahler (blueyed) wrote :

Markus, what was the contents of XDG_DESKTOP_DIR in that file, when you removed it, and what is it now?
Wasn't xdg-user-dirs installed? (it should get pulled in by kubuntu-desktop). Something maybe is misconfiguring this file in the absence of xdg-user-dirs?

Markus Straub (markus-straub2) wrote :

Daniel, I can't exactly remember the contents of ~/.config/user-dirs.dirs, but I tried to correct the information there and it had no influence. xdg-user-dirs was not installed by default. it rewrote user-dirs.dirs to this:

XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_DOWNLOAD_DIR="$HOME/Desktop"
XDG_TEMPLATES_DIR="$HOME/Templates"
XDG_PUBLICSHARE_DIR="$HOME/Public"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Music"
XDG_PICTURES_DIR="$HOME/Pictures"
XDG_VIDEOS_DIR="$HOME/Videos"

Maybe the tool also changes data in other places?

trtl (pdersjant) wrote :

OK, running xdg-user-dirs didn't fix it for me at first, came back with an error ('Can't write'). Turned out that somehow ~/.config was owned by root. chown fixed that, then running xdg-user-dirs and log-out/log-in, and everything works now.

Olaf Lenz (olenz) wrote :

I want to point you to bug #208253, which seems to be closely related to this one.

Jonathan Thomas (echidnaman) wrote :

Shouldn't be an issue with Intrepid/KDE4.

Changed in kubuntu-default-settings:
status: Confirmed → Fix Released
tuxo (beat-fasel) wrote :

> Shouldn't be an issue with Intrepid/KDE4.

How can this bug be closed if it concerns the gutsy -> hardy upgrade where it still not fixed? Nobody was talking about Intredpid.

Jonathan Thomas (echidnaman) wrote :

Bugs are fixed in Intrepid. (Or the development series in general.)
If they qualify for an SRU, they will be backported to whatever series needs a fix. (See https://wiki.ubuntu.com/StableReleaseUpdates)

Since the fix in this case is using KDE4 which doesn't have this problem, the fix for this bug doesn't qualify for an SRU.

trtl (pdersjant) wrote :

Using KDE4 isn't an option in the specified case, as it's not possible to upgrade to it during a gutsy->hardy upgrade.

Therefor, the bug shouldn't be marked fixed, but marked WONTFIX, as all efforts seem to go to intrepid instead. In which case it's a known error that should be included in the release notes.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers