no default search engine set

Bug #1028551 reported by Jonathan Riddell on 2012-07-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Kubuntu Default Settings
Invalid
Medium
kubuntu-default-settings (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

rekonq complains that no default search engine is set, one should be

Chakra Linux, KDE SC 4.8.97, rekonq 1.0

I have DuckDuckGo as my default search engine. If I try to search using the address bar, either I go to a page from my history or I get that "Opps Rekonq cannot load..." page. I also seen that error a few days ago when I built rekonq from git (but right now I'm using rekonq from Chakra's repos)

Congrats on rekonq's 1.0 release!

Reproducible: Always

Steps to Reproduce:
1. Make sure default search engine is set.
2. Enter key words in address bar and press enter.
Actual Results:
Either I get sent to a page from my history or I get the rekonq cannot load page.

Expected Results:
A DuckDuckGo search being done with the keywords I entered.

I did clear rekonq's private data before trying again.

Created attachment 72656
Rekonq asks to set default search engine.

Sorry I forgot to include:
Sometimes rekonq will ask me if I want to set a default search engine. After clicking that I do want to set a default search engine, I get sent to Configure rekonq-> Search Engines and find DuckDuckGo is alread set (as seen in the pic)...

Jonathan Riddell (jr) on 2012-07-24
Changed in kubuntu-default-settings (Ubuntu):
milestone: none → ubuntu-12.10-beta-1
tags: added: kubuntu
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1028551

tags: added: iso-testing

Rekonq just updated on the distro I'm using (to rekonq-1.0-2) and now when I start typing in the address bar I get a list of my perferred search engines in the right-hand corner. Searching in the adress bar without using web shortcuts is working again.

It seems to be working now!

Git commit 1ca437fa5c27c54b8a4f193e04cdc4ea9cc68ce1 by Andrea Diamantini.
Committed on 27/07/2012 at 17:37.
Pushed by adjam into branch 'master'.

Fix search engine(s) for KDE 4.9

This is basically Johannes patch with checks added for kde version and
with code duplicated for kwebapp.

PS: I tried using KUriFilterData API to do it, without positive results.
Postponing a code review here for KDE 5, hoping variables won't change
another time name...
CCMAIL: <email address hidden>
REVIEW: 303872

M +15 -5 kwebapp/searchengine.cpp
M +16 -6 src/opensearch/searchengine.cpp

http://commits.kde.org/rekonq/1ca437fa5c27c54b8a4f193e04cdc4ea9cc68ce1

Marco Parillo (marco-parillo) wrote :
Changed in kubuntu-default-settings:
importance: Unknown → Medium
status: Unknown → Invalid

*** Bug 304537 has been marked as a duplicate of this bug. ***

Jonathan Riddell (jr) on 2012-08-10
Changed in kubuntu-default-settings (Ubuntu Quantal):
status: New → Fix Released

I have rekonq 1.0+git2012081411-1~precise~ppa1 from http://ppa.launchpad.net/yoann-laissus/rekonq-ppa/ubuntu/, which I believe should contain the above mentioned patch, but the default search engine is asked every time rekonq is started. In addition, url bar search does not use any search engine, no matter what is selected in the web shortcuts configuration. This results also the middle click search not to work (middle click loads the clipboard url for me, and if it is not a valid url, rekonq should submit the content to a search engine).

Like you Jari, i have the same pb with rekonq from Yoyann Laissus PPA with Kubuntu Precise + PPA Backports and I think it's a packaging bug. A workaround is to use Sumski PPA : https://launchpad.net/~schumski/+archive/backports-kde-goodies
Remove rekonq and install rekonq-git

Kubuntu Precise + PPA Backports (KDE 4.9) + Rekonq from Yohann PPA = PB :
rekonq logs in ~/.xsession-errors :
rekonq(20458)/kdecore (services) KServiceFactory::findServiceByDesktopPath: "searchproviders/.desktop" not found

Kubuntu Precise + PPA Backports (KDE 4.9) + rekonq-git from Sumski PPA = OK
rekonq logs in ~/.xsession-errors :
rekonq(19651)/kdecore (services) KServiceFactory::findServiceByDesktopPath: "searchproviders/wikit.desktop" not found

Packages versions :
rekonq 1.0+git2012082601-1~precise~ppa1
rekonq-git 1.0.0git201208052257~2148~precise1

Test with Kubuntu Precise (KDE 4.8.4) + Rekonq from Yohann PPA = OK
rekonq logs in ~/.xsession-errors :
rekonq(22696)/kdecore (services) KServiceFactory::findServiceByDesktopPath: "searchproviders/wikit.desktop" not found

Thanks Anthony. I have indeed kubuntu 12.04 with kde 4.9.00 from kubuntu-ppa/backports, and the problem goes away, if I use the package from šumski's repository.

I investigated this issue a bit deeper yesterday.
It seems that building rekonq on top of KDE 4.8 triggers this issue when the package is used with KDE 4.9.
Probably a kind of binary incompatibility.
But before making kubuntu-ppa/backports as a dependencie of the daily build, I want to make sure it has no side effects on KDE 4.8 users.

Can you try this build of rekonq (built with KDE 4.9) : https://launchpad.net/~yoann-laissus/+archive/testing2

Yoann,

The version built with KDE 4.9 from testing2 works as intended in my KDE 4.9.00 system (no questions about the default engine, url bar search works fine, middle click search also). Thanks!

$ apt-cache policy rekonq
rekonq:
  Installed: 1.0+git2012082711-1~precise~ppa1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.