ktp-text-ui crashed with SIGSEGV in ~SharedPtr()

Bug #1556653 reported by Jacob Taylor on 2016-03-13
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Telepathy KDE
Unknown
Unknown
ktp-text-ui (Ubuntu)
Medium
Rafael David Tinoco
Xenial
Undecided
Brian Murray

Bug Description

[Impact]

 * Users of KDE telepathy will experience this problem (always) when opening first conversation window from the contact list.

[Test Case]

 * Install KDE Telepathy, configure a Hangout account, double click a user from contact list and experience the error "org.freedesktop.Telepathy.Error.NotAvailable: Handler no longer available" coming from notification popup.

[Regression Potential]

 * Could make KDE Telepathy to stop working (unlikely).
 * Tested in my own Xenial installation.
 * Fix already released upstream (KDE).

[Other Info]

 * Original bug description:

The bug reporter popped up while uploading the report on a different bug. I have no idea what happened. I did not write down the error message (hopefully the auto-uploader takes care of that for me), but it seemed to indicate some portion of the log viewer crashed (perhaps the log viewer for my other bug's crash report ui).

 lsb_release -rd
Description: Ubuntu Xenial Xerus (development branch)
Release: 16.04

ktp-text-ui isn't a package apt-cache policy can find, so I do not know what the relevant version information is.

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: kde-telepathy-text-ui 4:15.12.1-1ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-12.28-generic 4.4.4
Uname: Linux 4.4.0-12-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: KDE
Date: Sun Mar 13 11:23:46 2016
Disassembly: => 0x0: Cannot access memory at address 0x0
ExecutablePath: /usr/lib/x86_64-linux-gnu/libexec/ktp-text-ui
InstallationDate: Installed on 2015-05-19 (299 days ago)
InstallationMedia: Kubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150219.1)
ProcCmdline: /usr/lib/x86_64-linux-gnu/libexec/ktp-text-ui
ProcEnviron:
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
 PATH=(custom, user)
 LANGUAGE=en_US
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: ktp-text-ui
StacktraceTop:
 ?? ()
 ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/kcm_ktp_chat_otr.so
 ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/kcm_ktp_chat_otr.so
 KCModuleProxy::deleteClient() () from /usr/lib/x86_64-linux-gnu/libKF5KCMUtils.so.5
 KCModuleProxy::~KCModuleProxy() () from /usr/lib/x86_64-linux-gnu/libKF5KCMUtils.so.5
Title: ktp-text-ui crashed with SIGSEGV in KCModuleProxy::deleteClient()
UpgradeStatus: Upgraded to xenial on 2015-12-23 (80 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Jacob Taylor (orangewinds) wrote :

StacktraceTop:
 ?? ()
 ~SharedPtr (this=0x210cdc8, __in_chrg=<optimized out>) at /usr/include/telepathy-qt5/TelepathyQt/shared-ptr.h:139
 OTRConfig::~OTRConfig (this=0x210cd70, __in_chrg=<optimized out>) at ../../../config/otr/otr-config.cpp:75
 OTRConfig::~OTRConfig (this=0x210cd70, __in_chrg=<optimized out>) at ../../../config/otr/otr-config.cpp:78
 KCModuleProxy::deleteClient() () from /tmp/apport_sandbox_urbzIB/usr/lib/x86_64-linux-gnu/libKF5KCMUtils.so.5

Changed in ktp-text-ui (Ubuntu):
importance: Undecided → Medium
summary: - ktp-text-ui crashed with SIGSEGV in KCModuleProxy::deleteClient()
+ ktp-text-ui crashed with SIGSEGV in ~SharedPtr()
tags: removed: need-amd64-retrace
Jacob Taylor (orangewinds) wrote :

I'll reproduce my other bug's comment here, since it seems to be more directly relate to this one:

The error reporter popped up on me. I assume (perhaps wrongly) that it's associated with the chat application being closed, as that's the last action I took. I ended an otr session, hit X on IM (kde telepathy?) window. "Instant Messaging Settings" window was open at the time, and was closed along with the IM window (weird behavior).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ktp-text-ui (Ubuntu):
status: New → Confirmed
Rafael David Tinoco (inaddy) wrote :

This is probably the same as

https://bugs.kde.org/show_bug.cgi?id=361459

Most likely fixed by

https://quickgit.kde.org/?p=ktp-text-ui.git&a=commit&h=5015460c6fbd9696bf482e53e7cb94b64097db12

I'm checking if this patch fixes the issue.

Changed in ktp-text-ui (Ubuntu):
status: Confirmed → In Progress
Rafael David Tinoco (inaddy) wrote :

Yes, it solved the issue for me. Telepathy now can open a new conversation window without the error:

"org.freedesktop.Telepathy.Error.NotAvailable: Handler no longer available"

Coming from the notification popup (possibly the cause for this crash).

Attaching the debdiff for SRU.

Rafael David Tinoco (inaddy) wrote :
description: updated
tags: added: sts
Changed in ktp-text-ui (Ubuntu):
assignee: nobody → Rafael David Tinoco (inaddy)
information type: Private → Public
tags: added: patch
Brian Murray (brian-murray) wrote :

This seems to be fixed (the patch from the debdiff already exists in the source code) in Zesty.

Brian Murray (brian-murray) wrote :

I sponsored this to the xenial SRU queue after unfixing the white space changes to debian/changelog which seemed unnecessary.

Changed in ktp-text-ui (Ubuntu Xenial):
assignee: nobody → Brian Murray (brian-murray)
status: New → In Progress
Changed in ktp-text-ui (Ubuntu):
status: In Progress → Fix Released

Hello Jacob, or anyone else affected,

Accepted ktp-text-ui into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ktp-text-ui/4:15.12.3-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ktp-text-ui (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Chris J Arges (arges) wrote :

Yakkety looks fixed as well.

The fix for this bug has been awaiting testing feedback in the -proposed repository for xenial for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate

As part of a recent change in the Stable Release Update verification policy we would like to inform that for a bug to be considered verified for a given release a verification-done-$RELEASE tag needs to be added to the bug where $RELEASE is the name of the series the package that was tested (e.g. verification-done-xenial). Please note that the global 'verification-done' tag can no longer be used for this purpose.

Thank you!

The version of ktp-text-ui in the proposed pocket of Xenial that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

Changed in ktp-text-ui (Ubuntu Xenial):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.