Merge ktorrent 4.0.5-3 (main) from Debian unstable (main)

Bug #716639 reported by Artur Rona on 2011-02-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ktorrent (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ktorrent

ktorrent (4.0.5-3) unstable; urgency=low

  * Release to unstable.

 -- Modestas Vainius <email address hidden> Tue, 01 Feb 2011 00:40:46 +0200

ktorrent (4.0.5-2) experimental; urgency=low

  * Reupload because previous upload was screwed.

 -- Modestas Vainius <email address hidden> Thu, 30 Dec 2010 12:32:26 +0200

ktorrent (4.0.5-1) experimental; urgency=low

  * New upstream release.
  * Require libktorrent 1.0.5.

 -- Modestas Vainius <email address hidden> Thu, 30 Dec 2010 12:16:35 +0200

ktorrent (4.0.4-1) experimental; urgency=low

  * New upstream release.
  * Bump libktorrent-dev build dependency to 1.0.4.

 -- Modestas Vainius <email address hidden> Wed, 20 Oct 2010 14:52:03 +0300

Related branches

Artur Rona (ari-tczew) wrote :

I reduced changes in d/changelog. There is no point to keep a large entries. If someone want to get more informations, it's possible by Bazaar.

Artur Rona (ari-tczew) wrote :

Want to be sponsored by Jonathan Riddel!

Changed in ktorrent (Ubuntu):
status: New → Confirmed
Jonathan Riddell (jr) wrote :

Uploaded thanks.

Having a diff of the current Ubuntu packaging to the proposed merged packaging would be handy.

In Kubuntu we always keep the history in changelogs except for syncs. It's just a copy and paste to do and it saves problems later. I've added that to the upload.

I'm not convinced the different versions in the build-dependencies are needed.

You didn't mention which patch was dropped. In Kubuntu we always put the name of dropped patches into changelogs for easy reference.

"Want to be sponsored by Jonathan Riddel!" Your English here is a bit unclear, probably "Jonathan Riddell has offered to sponsor this" would read better, setting me as the bug Assigned to would do the same thing.

Thanks again

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ktorrent - 4.0.5-3ubuntu1

---------------
ktorrent (4.0.5-3ubuntu1) natty; urgency=low

  * Merge from debian unstable. Remaining changes: (LP: #716639)
    - debian/control:
      + ktorrent recommends krosspython
      + Build against libboost1.42-dev
      + Bump Build-Depends on kdebase-workspace-dev (>= 4:4.5.2-0ubuntu3)
        for transition libtaskmanager4a -> libtaskmanager4b
      + Update other Build-Depends
    - debian/rules:
      + Add export KUBUNTU_DESKTOP_POT=extragear-network_ktorrent
  * Drop debian-changes-4.0.4-0ubuntu3, merged upstream

ktorrent (4.0.5-3) unstable; urgency=low

  * Release to unstable.

ktorrent (4.0.5-2) experimental; urgency=low

  * Reupload because previous upload was screwed.

ktorrent (4.0.5-1) experimental; urgency=low

  * New upstream release.
  * Require libktorrent 1.0.5.

ktorrent (4.0.4-1) experimental; urgency=low

  * New upstream release.
  * Bump libktorrent-dev build dependency to 1.0.4.
 -- Artur Rona <email address hidden> Sat, 05 Feb 2011 22:15:18 +0100

Changed in ktorrent (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers