[gutsy] ktorrent 2.2.1-0ubuntu1 crash when I quit the program when uPnP plugin is loaded

Bug #130300 reported by berg on 2007-08-04
16
Affects Status Importance Assigned to Milestone
Dapper Backports
Undecided
Unassigned
Edgy Backports
Undecided
Unassigned
Feisty Backports
Undecided
Unassigned
ktorrent (Ubuntu)
Undecided
John Dong

Bug Description

Binary package hint: ktorrent

I tested with a torrent file seeding and when quit the program and the upnp plugin is load there is a crash. I tested with scanfolder and ipblocking dont ha problem with them.

The apport dont work :( . the backtrace was generated by kde.

backtrace

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1234897216 (LWP 6087)]
0xffffe410 in ?? ()
#0 0xffffe410 in ?? ()
#1 0xbfb3d3d8 in ?? ()
#2 0xb67c4ff4 in ?? () from /lib/tls/i686/cmov/libc.so.6
#3 0xbfb3d3c4 in ?? ()
#4 0xb6712ea6 in nanosleep () from /lib/tls/i686/cmov/libc.so.6
#5 0xb6712cb7 in BÊf9ñ„³ () from /lib/tls/i686/cmov/libc.so.6
#6 0xb7564ad9 in KCrash::startDrKonqi (argv=0xbfb3f5dc, argc=17)
    at /build/buildd/kdelibs-3.5.7/./kdecore/kcrash.cpp:312
#7 0xb757b4de in KCrash::defaultCrashHandler (sig=11)
    at /build/buildd/kdelibs-3.5.7/./kdecore/kcrash.cpp:229
#8 0xffffe420 in ?? ()
#9 0x0000000b in ?? ()
#10 0x08076e93 in KTorrentCore::onExit (this=0xbfb3fb5c)
    at /build/buildd/ktorrent-2.2.1/./apps/ktorrent/ktorrentcore.cpp:603
#11 0x08070102 in KTorrent::queryExit (this=0x8115608)
    at /build/buildd/ktorrent-2.2.1/./apps/ktorrent/ktorrent.cpp:587
#12 0xb781f110 in KMainWindow::shuttingDown (this=0xb67c4ff4)
    at /build/buildd/kdelibs-3.5.7/./kdeui/kmainwindow.cpp:1104
#13 0xb797e3a1 in KMainWindow::qt_invoke (this=0x8115608, _id=72, _o=0x2)
    at ./kmainwindow.moc:139
#14 0xb7d73933 in KParts::MainWindow::qt_invoke (this=0x8115608, _id=72,
    _o=0xbfb3fb5c) at ./mainwindow.moc:98
#15 0x080c20c3 in DMainWindow::qt_invoke (this=0x8115608, _id=72,
    _o=0xbfb3fb5c) at ./dmainwindow.moc:138
#16 0x08071fa0 in KTorrent::qt_invoke (this=0x8115608, _id=72, _o=0xbfb3fb5c)
    at ./ktorrent.moc:220
#17 0xb6ef7893 in QObject::activate_signal (this=0xbfb3fd94, clist=0x81a20f8,
    o=0xbfb3fb5c) at kernel/qobject.cpp:2356
#18 0xb6ef8338 in QObject::activate_signal (this=0xbfb3fd94, signal=15)
    at kernel/qobject.cpp:2325
#19 0xb7569a3c in KApplication::shutDown (this=0xbfb3fd94)
    at ./kapplication.moc:234
#20 0xb757d2db in KApplication::qt_emit (this=0xbfb3fd94, _id=15,
    _o=0xbfb3fc8c) at ./kapplication.moc:278
#21 0xb757d32b in KUniqueApplication::qt_emit (this=0xbfb3fd94, _id=15,
    _o=0xbfb3fc8c) at ./kuniqueapplication.moc:96
#22 0x08075e7f in KTorrentApp::qt_emit (this=0xbfb3fd94, _id=15,
    _o=0xbfb3fc8c) at ./ktorrentapp.moc:82
#23 0xb6ef7994 in QObject::activate_signal (this=0xbfb3fd94, clist=0x818a760,
    o=0xbfb3fc8c) at kernel/qobject.cpp:2378
#24 0xb6ef8338 in QObject::activate_signal (this=0xbfb3fd94, signal=3)
    at kernel/qobject.cpp:2325
#25 0xb727bf4b in QApplication::aboutToQuit (this=0xbfb3fd94)
    at .moc/debug-shared-mt/moc_qapplication.cpp:106
#26 0xb6ea92aa in QEventLoop::enterLoop (this=0x8142398)
    at kernel/qeventloop.cpp:210
#27 0xb6ea8fde in QEventLoop::exec (this=0x8142398)
    at kernel/qeventloop.cpp:145
#28 0xb6e90699 in QApplication::exec (this=0xbfb3fd94)
    at kernel/qapplication.cpp:2758
#29 0x0808cb01 in main (argc=4, argv=0x60e5c72)
    at /build/buildd/ktorrent-2.2.1/./apps/ktorrent/main.cpp:179
#30 0xb6696040 in àƒø„| () from /lib/tls/i686/cmov/libc.so.6
#31 0x0806a491 in _start ()

myloginz@berg-desktop:~/bugs/korrent$ uname -a
Linux berg-desktop 2.6.22-9-generic #1 SMP Wed Aug 1 17:31:10 GMT 2007 i686 GNU/Linux
myloginz@berg-desktop:~/bugs/korrent$ ktorrent --version
Qt: 3.3.7
KDE: 3.5.7
KTorrent: 2.2.1
myloginz@berg-desktop:~/bugs/korrent$ dpkg -l ktorrent
Desejado=U=Desconhecido/Instalar/Remover/aPagar/H=Manter
| status=Não/Instalado/arquiv.-Config./U=Descomp./Falhou-config/H=semi-inst.
|/ Erro?=(nenhum)/H=Mantido/precisa-Reinst./X=os dois problemas (status,Erro: maiúsculas=ruim)
||/ Nome Versão Descrição
+++-=====================-=====================-==========================================================
ii ktorrent 2.2.1-0ubuntu1 BitTorrent client for KDE
myloginz@berg-desktop:~/bugs/korrent$ dpkg -l ktorrent-dbgsym
Desejado=U=Desconhecido/Instalar/Remover/aPagar/H=Manter
| status=Não/Instalado/arquiv.-Config./U=Descomp./Falhou-config/H=semi-inst.
|/ Erro?=(nenhum)/H=Mantido/precisa-Reinst./X=os dois problemas (status,Erro: maiúsculas=ruim)
||/ Nome Versão Descrição
+++-=====================-=====================-==========================================================
ii ktorrent-dbgsym 2.2.1-0ubuntu1 debug symbols for package ktorrent
myloginz@berg-desktop:~/bugs/korrent$
myloginz@berg-desktop:~/bugs/korrent$ dpkg -l apport*
Desejado=U=Desconhecido/Instalar/Remover/aPagar/H=Manter
| status=Não/Instalado/arquiv.-Config./U=Descomp./Falhou-config/H=semi-inst.
|/ Erro?=(nenhum)/H=Mantido/precisa-Reinst./X=os dois problemas (status,Erro: maiúsculas=ruim)
||/ Nome Versão Descrição
+++-=====================-=====================-==========================================================
ii apport 0.94 automatically generate crash reports for debugging
un apport-cli <nenhuma> (nenhuma descrição disponível)
ii apport-gtk 0.94 GTK frontend for the apport crash report system
ii apport-qt 0.94 Qt4 frontend for the apport crash report system
myloginz@berg-desktop:~/bugs/korrent$

Related branches

berg (berg-foss) wrote :

strace from a running ktorrent where I activate uPnP plugin and quit from ktorrrent and get a crash.

was displayed kde crash handler with this message:

This backtrace appears to be of no use.
This is probably because your packages are built in a way which prevents creation of proper backtraces, or the stack frame was seriously corrupted in the crash.

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".

unable to create a valid backtrace.

berg (berg-foss) wrote :

GDB from a running ktorrent where I activate uPnP plugin and quit from ktorrrent and get a crash.

using commands from
https://wiki.ubuntu.com/Backtrace

berg (berg-foss) wrote :
Download full text (19.4 KiB)

myloginz@berg-desktop:~/bugs/korrent$ G_SLICE=always-malloc G_DEBUG=gc-friendly valgrind -v --tool=memcheck --leak-check=full --num-callers=40 --log-file=valgrind.log ktorrent --icon=ktorrent -caption KTorrent
*** glibc detected *** ktorrent: free(): invalid pointer: 0x0598a798 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0x582dd75]
/lib/tls/i686/cmov/libc.so.6(cfree+0x90)[0x5831810]
/usr/lib/libDCOP.so.4(_kde_IceTransFreeConnInfo+0x4f)[0x4b29f1f]
/usr/lib/libDCOP.so.4(_kde_IceTransClose+0x2f)[0x4b29f9f]
/usr/lib/libDCOP.so.4(KDE_IceOpenConnection+0x566)[0x4b205f6]
/usr/lib/libDCOP.so.4(_ZN10DCOPClient14attachInternalEb+0xfb)[0x4b1a82b]
/usr/lib/libDCOP.so.4(_ZN10DCOPClient10registerAsERK8QCStringb+0x366)[0x4b1a586]
/usr/lib/libkdecore.so.4(_ZN18KUniqueApplication5startEv+0x231)[0x4a67051]
ktorrent[0x808cadb]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0)[0x57da050]
ktorrent(_ZN7QWidget17setUpdatesEnabledEb+0x41)[0x806a491]
======= Memory map: ========
04000000-0401a000 r-xp 00000000 08:01 124545 /lib/ld-2.6.1.so
0401a000-0401c000 rw-p 00019000 08:01 124545 /lib/ld-2.6.1.so
0401c000-0401d000 rw-p 0401c000 00:00 0
0401d000-0401e000 r-xp 00000000 08:01 169774 /usr/lib/valgrind/x86-linux/vgpreload_core.so
0401e000-0401f000 rw-p 00000000 08:01 169774 /usr/lib/valgrind/x86-linux/vgpreload_core.so
0401f000-04024000 r-xp 00000000 08:01 169779 /usr/lib/valgrind/x86-linux/vgpreload_memcheck.so
04024000-04025000 rw-p 00004000 08:01 169779 /usr/lib/valgrind/x86-linux/vgpreload_memcheck.so
04035000-04036000 rw-p 04035000 00:00 0
04036000-04199000 r-xp 00000000 08:01 148185 /usr/lib/libktorrent-2.2.1.so
04199000-041a2000 rw-p 00162000 08:01 148185 /usr/lib/libktorrent-2.2.1.so
041a2000-041c6000 rw-p 041a2000 00:00 0
041c6000-0420a000 r-xp 00000000 08:01 50429 /usr/lib/libgmp.so.3.4.1
0420a000-0420b000 rw-p 00044000 08:01 50429 /usr/lib/libgmp.so.3.4.1
0420b000-0424c000 r-xp 00000000 08:01 121736 /usr/lib/libkparts.so.2.1.0
0424c000-04251000 rw-p 00040000 08:01 121736 /usr/lib/libkparts.so.2.1.0
04251000-04582000 r-xp 00000000 08:01 121727 /usr/lib/libkio.so.4.2.0
04582000-045a1000 rw-p 00331000 08:01 121727 /usr/lib/libkio.so.4.2.0
045a1000-04861000 r-xp 00000000 08:01 121723 /usr/lib/libkdeui.so.4.2.0
04861000-0488c000 rw-p 002bf000 08:01 121723 /usr/lib/libkdeui.so.4.2.0
0488c000-0488d000 rw-p 0488c000 00:00 0
0488d000-048a2000 r-xp 00000000 08:01 121722 /usr/lib/libkdesu.so.4.2.0
048a2000-048a3000 rw-p 00015000 08:01 121722 /usr/lib/libkdesu.so.4.2.0
048a3000-048a4000 rw-p 048a3000 00:00 0
048a4000-048b4000 r-xp 00000000 08:01 121746 /usr/lib/libkwalletclient.so.1.0.1
048b4000-048b5000 rw-p 00010000 08:01 121746 /usr/lib/libkwalletclient.so.1.0.1
048b5000-04aeb000 r-xp 00000000 08:01 121705 /usr/lib/libkdecore.so.4.2.0
04aeb000-04afb000 rw-p 00236000 08:01 121705 /usr/lib/libkdecore.so.4.2.0
04afb000-04afe000 rw-p 04afb000 00:00 0
04afe000-04b2f000 r-xp 00000000 08:01 121699 /usr/lib/libDCOP.so.4.2.0
04b2f000-04b30000 rw-p 00031000 08:01 121699 /usr/lib/libDCOP.so.4.2.0
04b30000-04b32000 rw-p 04b30000 00:00 0
04b32000-04b4100...

berg (berg-foss) on 2007-08-08
Changed in ktorrent:
assignee: nobody → kubuntu-team
berg (berg-foss) wrote :

I put a bug report in kde bugzilla and was marked duplicated of this bug
http://bugs.kde.org/show_bug.cgi?id=148155

the solution was released 25/07 but seems that ubuntu package dont have that patch yet or maybe this is another bug or a specific ubuntu bug.

where do I link the lauchpad bug with other projects's bugzilla ?? is this feature removed ?? early was so easy .

berg (berg-foss) on 2007-08-10
Changed in ktorrent:
status: New → Confirmed
John Dong (jdong) wrote :

I will prepare that SVN patch for Gutsy KTorrent.

Changed in ktorrent:
assignee: kubuntu-team → jdong
John Dong (jdong) wrote :

Attached is a proposed debdiff against gutsy.

Changed in ktorrent:
assignee: jdong → nobody
John Dong (jdong) wrote :

ktorrent (2.2.1-0ubuntu2) gutsy; urgency=low

  * Backport SVN rev 692284
    - Fixes LP: #130300

 -- John Dong <email address hidden> Fri, 10 Aug 2007 11:27:51 -0400

Changed in ktorrent:
status: Confirmed → Fix Released
John Dong (jdong) wrote :

FTBFS on all archs, looks like spacing got mangled in my debdiff because I decided to copy-paste into a text editor. I will redo it later today and prepare another debdiff and use shell redirect :)

Changed in ktorrent:
assignee: nobody → jdong
status: Fix Released → In Progress
John Dong (jdong) wrote :

Alright, fresh from shell redirect; apply against -0ubuntu2.

John Dong (jdong) wrote :

ktorrent (2.2.1-0ubuntu3) gutsy; urgency=low

  * Fix debdiff spacing that I screwed up.
   - Fixes LP: #130300

 -- John Dong <email address hidden> Sat, 11 Aug 2007 14:59:17 -0400

Changed in ktorrent:
status: In Progress → Fix Released
John Dong (jdong) wrote :

Ok, builds are succeeding and publishing. Can someone confirm if the bug is fixed or not?

it's working fine now on my system.

John Dong (jdong) wrote :

Thanks for the feedback. I'd like to wait for a few more success reports, then I'll backport this to Dapper, Edgy, and Feisty.

Changed in dapper-backports:
status: New → Triaged
Changed in edgy-backports:
status: New → Triaged
Changed in feisty-backports:
status: New → Triaged
berg (berg-foss) wrote :

thanks john,

works ok to me now :)

John Dong (jdong) wrote :

Approved for backporting to Dapper, Edgy, and Feisty to fix reported crash-on-exits.

Changed in dapper-backports:
status: Triaged → In Progress
Changed in edgy-backports:
status: Triaged → In Progress
Changed in feisty-backports:
status: Triaged → In Progress
Jonathan Riddell (jr) wrote :

 * Trying to backport ktorrent...
  - <ktorrent_2.2.1.orig.tar.gz: downloading from librarian>
  - <ktorrent_2.2.1-0ubuntu3.diff.gz: downloading from librarian>
  - <ktorrent_2.2.1-0ubuntu3.dsc: downloading from librarian>
I: Extracting ktorrent_2.2.1-0ubuntu3.dsc ... done.
I: Building backport of ktorrent-2.2.1 as 2.2.1-0ubuntu3~feisty1 ... done.

 * Trying to backport ktorrent...
  - <ktorrent_2.2.1.orig.tar.gz: downloading from librarian>
  - <ktorrent_2.2.1-0ubuntu3.diff.gz: downloading from librarian>
  - <ktorrent_2.2.1-0ubuntu3.dsc: downloading from librarian>
I: Extracting ktorrent_2.2.1-0ubuntu3.dsc ... done.
I: Building backport of ktorrent-2.2.1 as 2.2.1-0ubuntu3~edgy1 ... done.

 * Trying to backport ktorrent...
  - <ktorrent_2.2.1.orig.tar.gz: downloading from librarian>
  - <ktorrent_2.2.1-0ubuntu3.diff.gz: downloading from librarian>
  - <ktorrent_2.2.1-0ubuntu3.dsc: downloading from librarian>
I: Extracting ktorrent_2.2.1-0ubuntu3.dsc ... done.
I: Building backport of ktorrent-2.2.1 as 2.2.1-0ubuntu3~dapper1 ... done.

Changed in feisty-backports:
status: In Progress → Fix Released
Changed in edgy-backports:
status: In Progress → Fix Released
Changed in dapper-backports:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.