Indentation is broken

Bug #1724709 reported by Simon Quigley
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ktexteditor (Ubuntu)
Fix Released
Medium
Simon Quigley
Artful
Fix Released
Medium
Simon Quigley
Bionic
Fix Released
Medium
Simon Quigley

Bug Description

For 17.10, please treat this as a 0-day SRU bug report.

[Impact]

Without this fix, in any text editor that uses this framework (Kate and KDevelop are two of them), the text editor unexpectedly and automatically indents when the user types any of the following characters directly after a function (which is indented): u, n, d, e, f, i and n

[Test Case]

1. Open Kate.
2. On the lower right corner, set the syntax highlighting to Python (default for .py files).
3. Type the following code, go to a new line, and backspace so your cursor is not indented like the print function:
def func():
    print("foo")
4. Type "abcd"

The cursor should stay where it is, but instead after pressing "d" it autoindents.

[Regression Potential]

There is little to no regression potential, unless somehow the trigger character is undefined but needs to automatically indent for some reason (which, it should be defined in the template anyways, it shouldn't need hardcoding in this spot).

Simon Quigley (tsimonq2)
Changed in ktexteditor (Ubuntu Artful):
assignee: nobody → Simon Quigley (tsimonq2)
importance: Undecided → Critical
importance: Critical → Medium
status: New → Confirmed
milestone: none → artful-updates
Revision history for this message
Andy Whitcroft (apw) wrote : Please test proposed package

Hello Simon, or anyone else affected,

Accepted ktexteditor into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ktexteditor/5.38.0-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ktexteditor (Ubuntu Artful):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-artful
Revision history for this message
Simon Quigley (tsimonq2) wrote :

This fix works as intended for me.

tags: added: verification-done verification-done-artful
removed: verification-needed verification-needed-artful
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ktexteditor - 5.38.0-0ubuntu1.1

---------------
ktexteditor (5.38.0-0ubuntu1.1) artful; urgency=medium

  * Fix indentation problems introduced in 5.38 (LP: #1724709).
    - fix-indentation.patch

 -- Simon Quigley <email address hidden> Wed, 18 Oct 2017 19:50:52 -0500

Changed in ktexteditor (Ubuntu Bionic):
status: Confirmed → Fix Released
Changed in ktexteditor (Ubuntu Artful):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for ktexteditor has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers