arithmetic functions such as sqrt fails

Bug #243285 reported by lrgarrett on 2008-06-26
6
Affects Status Importance Assigned to Milestone
ksh (Ubuntu)
Undecided
Unassigned

Bug Description

According to the man page for ksh the following arithmetic functions are built in:
abs acos acosh asin asinh atan atan2 atanh cbrt copysign cos cosh erf erfc exp exp2 expm1 fabs fdim finite
floor fma fmax fmod hypot ilogb int isinf isnan lgamma log log2 logb nearbyint nextafter nexttoward pow
remainder rint round sin sinh sqrt tan tanh tgamma trunc

However when I try to use the function such as:
print $(( sqrt(25) ))
I get the error message
/bin/ksh: sqrt(25) : unknown function

I tried the same command on other distributions of ksh93, RH, Fedora, AIX and I received the correct answer of 5.

finifly (fini-fly) wrote :

I can confirm this bug. I'm running Kubuntu 8.04 and I get the same 'unknown function' error when I tried using exp and log. I tried sin and cos too to see if it was a syntax error on my part, but they also failed.

Laurent FARHI (lrcom) wrote :

This bug has been fixed with ksh version M 93t released on 2008-11-04.
(http://www.research.att.com/~gsf/download/tgz/ast-ksh.2008-11-04.linux.i386.tgz)

finifly (fini-fly) wrote :

I did a fresh install of Kubuntu 8.10 and the math functions work perfectly. So it looks like it might be isolated to 8.04.

Thanks...I switched for Fedora Core 10 a while back and the math
functions worked.

Larry Garrett
Aequam memento rebus in arduis servare mentem
Horace

finifly wrote:
> I did a fresh install of Kubuntu 8.10 and the math functions work
> perfectly. So it looks like it might be isolated to 8.04.
>
>

--------------------------------------------------------------------------
This message w/attachments (message) may be privileged, confidential or proprietary, and if you are not an intended recipient, please notify the sender, do not use or share it and delete it. Unless specifically indicated, this message is not an offer to sell or a solicitation of any investment products or other financial product or service, an official confirmation of any transaction, or an official statement of Merrill Lynch. Subject to applicable law, Merrill Lynch may monitor, review and retain e-communications (EC) traveling through its networks/systems. The laws of the country of each sender/recipient may impact the handling of EC, and EC may be archived, supervised and produced in countries other than the country in which you are located. This message cannot be guaranteed to be secure or error-free. References to "Merrill Lynch" are references to any company in the Merrill Lynch & Co., Inc. group of companies, which are wholly-owned by Bank of America Corporation. Secur
 ities and Insurance Products: * Are Not FDIC Insured * Are Not Bank Guaranteed * May Lose Value * Are Not a Bank Deposit * Are Not a Condition to Any Banking Service or Activity * Are Not Insured by Any Federal Government Agency. Attachments that are part of this E-communication may have additional important disclosures and disclaimers, which you should read. This message is subject to terms available at the following link: http://www.ml.com/e-communications_terms/. By messaging with Merrill Lynch you consent to the foregoing.
--------------------------------------------------------------------------

finifly (fini-fly) wrote :

It looks like this problem is not isolated to 8.04, because I'm getting the same error on 8.10 but a different install. I will have to double check to see if it is working on the other machine. But it is definitely not working on a fresh install of 8.10 now.

madbiologist (me-again) on 2011-12-11
tags: added: kubuntu
madbiologist (me-again) wrote :

Is this still happening on Kubuntu 11.10?

Changed in ksh (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for ksh (Ubuntu) because there has been no activity for 60 days.]

Changed in ksh (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers