Krusader crashes when closing certain popups with embedded terminal emulator open

Bug #1197679 reported by Ciro Santilli 六四事件 法轮功 on 2013-07-04
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
krusader (Ubuntu)
Undecided
Unassigned

Bug Description

My krusader and its terminal emulator (Settings > Show terminal emulator) were working fine, when suddenly started crashing whenever all of the following conditions are satisfied:

- the termianal emulator was open
- I am using Unity. All works fine for: KDE Plasma, Gnome 3, and Cinnamon desktops

*and* at the moment when I would either:

- delete a file with right click > Delete > Delete (opens a popup)
- dclose the embedded editor ( opened with F3, opens a popup )
- close the krusader settings popup

The terminal emulator itself works fine though.

I imagined it was because of an update, so I backed up my config files and restarted without any config files (~/.kde/share/apps/krusader and ~./kde/share/config/krusaderrc),
and the problem is still there.

Also, I noticed that a new problem: Krusader crashes immediately after startup if I:

- remove the configuration files
- start Krusader for the first time, he asks me for the initial configurations I go with defaults
- select Settings > Configure Krusader > Startup > User interface > Show terminal emulator > Apply
- restart krusader

Now every time I start Krusader after that it crashes.

If I erase the krusaderrc line:

    Show Terminal Emulator=true

It can startup again as before.

The error message on the terminal from which I launched krusader is the same in all cases:

krusader(19916)/kdecore (KLibrary) findLibraryInternal: plugins should not have a 'lib' prefix: "libkonsolepart.so"
The program 'krusader' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 1884 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
A KUiServerJobTracker instance contains 1 stalled jobs
krusader(19916)/konsole Konsole::SessionManager::~SessionManager: Konsole SessionManager destroyed with sessions still alive

Specs:

lsb_release -rd
Description: Ubuntu 13.04
Release: 13.04

apt-cache policy krusader
krusader:
  Installed: 1:2.4.0~beta1+git76+de1ea35-1.1
  Candidate: 1:2.4.0~beta1+git76+de1ea35-1.1
  Version table:
 *** 1:2.4.0~beta1+git76+de1ea35-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy konsole
konsole:
  Installed: 4:4.10.4-0ubuntu0.1
  Candidate: 4:4.10.4-0ubuntu0.1
  Version table:
 *** 4:4.10.4-0ubuntu0.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring-updates/universe i386 Packages
        100 /var/lib/dpkg/status
     4:4.10.2-0ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages

description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in krusader (Ubuntu):
status: New → Confirmed
summary: - Krusader crashes immediatelly after startup if show terminal emulator is
- selected
+ Krusader crashes immediately after startup if show terminal emulator is
+ selected and if I delete a file with the terminal open
summary: Krusader crashes immediately after startup if show terminal emulator is
- selected and if I delete a file with the terminal open
+ selected and if I delete a file with the terminal emulator open
description: updated

I have the same problem after recently qt packages updates, but it's doing this even with terminal emulator turned off.
The same problem is with Dolphin.

summary: - Krusader crashes immediately after startup if show terminal emulator is
- selected and if I delete a file with the terminal emulator open
+ Krusader crashes when closing certain popups with embedded terminal
+ emulator open
description: updated
simeone (mistobaal) wrote :

same problem her after last (04/07/2013) update/upgrade

ubuntu 13.04 + kubuntu desktop: krusader 2.4 beta3 crash every time on every operation independently from what i do (dir creation, move, rename, delete files...)

under kde plasma desktop seems ok, but i prefer to use unity

WoodyEckelzone (bcr497) wrote :

Same here
Related bugs bug 1198080, bug 1197937

description: updated
description: updated
Richard Hansen (rhansen) on 2013-07-08
tags: added: badwindow
simeone (mistobaal) wrote :

today update (2013_07_09) of qt4 solve the problem at least for me

Viorel Lazar (viorelmarius) wrote :

latest qt updates fixed the problem

Changed in krusader (Ubuntu):
status: Confirmed → Fix Released

Ok fixed for me! Thanks a lot for whoever was responsible! Is there a way to change this to issue to closed, or should I leave it as Fix Released?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers