krusader fails to enter .zip archive with "Error: krarc is disabled"

Bug #1065110 reported by Martin Vysny on 2012-10-10
152
This bug affects 33 people
Affects Status Importance Assigned to Milestone
krusader (Ubuntu)
High
martin suc

Bug Description

I tried to look into the problem and read the information at http://www.krusader.org/documentation/faq_usage.html#id2672747
The file kio_krarc.la seems to be missing - perhaps this could cause the problem? Thank you :)

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: krusader 1:2.4.0~beta1+git76+de1ea35-1.1
Uname: Linux 3.6.0-030600-generic i686
ApportVersion: 2.6.1-0ubuntu2
Architecture: i386
Date: Wed Oct 10 17:43:31 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: krusader
UpgradeStatus: Upgraded to quantal on 2012-10-03 (7 days ago)

Martin Vysny (vyzivus) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in krusader (Ubuntu):
status: New → Confirmed
themroc (rauchweihe) wrote :

Same here in Kubuntu 12.10 x64 after upgrade from 12.04 on all off my PCs.

martin suc (martin-suc) wrote :

problem is solved in krusader beta3 .
I have read on some forum that it has been intentionally commented within compilation because there has been bug in it within open the zip file.

Changed in krusader (Ubuntu):
status: Confirmed → Fix Committed
themroc (rauchweihe) wrote :

I use this package, until an update is available on the official sources:

https://launchpad.net/~ladislav.bonita/+archive/precise-backports/+packages

woks in quantal (12.10) too.

Ondřej Buriánek (zerem) wrote :

Workaround for me was installing krusader package from precise http://packages.ubuntu.com/precise/amd64/krusader/download and forcing this version

Peter Antoniac (pan1nx) on 2012-11-29
Changed in krusader (Ubuntu):
importance: Undecided → High
assignee: nobody → martin suc (martin-suc)
zigi (ziegleka) wrote :

Please release the latest krusader-2.4.0-beta3.tar.bz2 version.

Martin Vysny (vyzivus) wrote :

This bug also applies to a fully upgraded 13.04. Please upgrade krusader.

WoodyEckelzone (bcr497) wrote :

Now Nautilus is completely borked in 13.04 we need a decent two pane file-manager for Ubuntu, but this bug is nasty.
Please update

WoodyEckelzone (bcr497) wrote :

Made my own deb from 2.4.0.beta3 which solved the `krarc` problem.

How to:
0 Uninstall Krusader
1 download source from http://www.krusader.org/
2 cd krusader-2.4.0-beta3
3 cmake -DCMAKE_INSTALL_PREFIX=/usr/ -DQT_INCLUDES=/usr/share/qt4/include
4 make
5 sudo checkinstall

Don´t forget in step 5 to set version on 3 instead of beta3, only digits are allowed in versions in debs nowadays.

Please give us an example of the line

3 cmake -DCMAKE_INSTALL_PREFIX=/usr/ -DQT_INCLUDES=/usr/share/qt4/include

in order to understand it.

Thank you!

I tried the recipe from #10, which is derived from the Krusader documentation at http://www.krusader.org/documentation/kde4_lin_install.html However, step 3 fails with errors from cmake. It would be fine to get a new version in the repositories - thank you!

tlu (thomas-ludwig-gmx) wrote :

Just download the respective Debian package from http://packages.debian.org/experimental/krusader

WoodyEckelzone (bcr497) wrote :

@ Dobrai:
- cmake A cross-platform, open-source make system
-------------
-DQT_INCLUDES=/usr/share/qt4/include
 is the location of the QT4 includes

-DCMAKE_INSTALL_PREFIX=/usr/
 is the location where Krusader will be installed with the make command.
 An other example is: -DCMAKE_INSTALL_PRFIX=/opt/krusader
 to install the compiled Krusader in an other directory to not overwrite
 the Krusader version installed by your package manager.
.
@Christian. Do you have cmake installed? It isn't by default.

BTW in the new version, read support for krarc is enabled, write support can be enabled but is buggy

Please write us all of the steps using a real example. Thank you!

I've went back to Ubuntu 12.04 and the issue finally is resolved.

Could you put latest krusader-2.4.0-beta3 to the ubuntu standard reposotories?

Alexandru G (vimishor) wrote :

@Christian Hildmann: cmake probably complains about missing dependencies needed for compilation. You can get those using:

sudo apt-get build-dep krusader

and then continue with step 3 from comment #10

WoodyEckelzone (bcr497) wrote :

@Dobrai It is a real example.
But before you start check if you have these installed::
sudo apt-get build-dep krusader
sudo apt-get install cmake checkinstall

When you install the produced deb you'll probably get a warning message that the package is of bad quality. You can ignore that.

#17 Yes please.

BTW I experience unexpected closes/crashes of Krusader after the latest KDE updates of this week. It just crashes after pressing ESC or some other keys.

Murz (murznn) wrote :

Manually installing package with beta3 from Ubuntu Saucy - http://packages.ubuntu.com/saucy/amd64/krusader/download solves this issue. Please backport it to previous versions of Ubuntu!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers