krename crashed with SIGSEGV in __libc_csu_init()

Bug #849882 reported by Paul White on 2011-09-14
324
This bug affects 61 people
Affects Status Importance Assigned to Milestone
krename (Ubuntu)
Medium
Fathi Boudra
Oneiric
High
Fathi Boudra

Bug Description

Segmentation fault error happens every time I start krename

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: krename 4.0.7-1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Wed Sep 14 12:07:16 2011
ExecutablePath: /usr/bin/krename
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110901)
ProcCmdline: krename
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_GB.UTF-8
 LANGUAGE=en_GB:en
SegvAnalysis:
 Segfault happened at: 0x805eedd: lock incl (%eax)
 PC (0x0805eedd) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: krename
StacktraceTop:
 ?? ()
 __libc_csu_init ()
 __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
 _start ()
Title: krename crashed with SIGSEGV in __libc_csu_init()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Paul White (paulw2u) wrote :
visibility: private → public

StacktraceTop:
 ?? ()
 __libc_csu_init ()
 __libc_start_main (main=0x805c710, argc=1, ubp_av=0xbf92a214, init=0x80e1480 <__libc_csu_init>, fini=0x80e14e0 <__libc_csu_fini>, rtld_fini=0x968bc0, stack_end=0xbf92a20c) at libc-start.c:185
 _start ()

Changed in krename (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Changed in krename (Ubuntu):
status: New → Confirmed
Petr Svoboda (weits666) wrote :

I have the same problem in Kubuntu 11.10 64bit

mu3en (mu3en) wrote :

confirmed in fresh oneiric 64 and 32 bit installs.

kajhaul (kaj-haulrich) wrote :

Same problem : Segmentation fault (core dumped) on Kubuntu 11.10 beta AMD64.

KSSG (kssg) wrote :

I also get a crash. Tried to build it from source, and this is what happened. Oneiric 32-bit, all packages up-to-date to this day.

(gdb) r
Starting program: /usr/bin/krename
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
QString (other=<optimized out>, this=0x81062ac) at /usr/include/qt4/QtCore/qstring.h:729
729 { Q_ASSERT(&other != this); d->ref.ref(); }
(gdb) bt
#0 QString (other=<optimized out>, this=0x81062ac)
    at /usr/include/qt4/QtCore/qstring.h:729
#1 __static_initialization_and_destruction_0 (__priority=65535, __initialize_p=1)
    at /dev/shm/krename/src/plugin.cpp:22
#2 _GLOBAL__sub_I__ZN6Plugin17S_TOKEN_SEPARATORE () at /dev/shm/krename/src/plugin.cpp:51
#3 0x080dd422 in __libc_csu_init ()
#4 0x01a890aa in __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
#5 0x080603e9 in _start ()
(gdb)

KSSG (kssg) wrote :

This bug report from Redhat seems to have more about it. I tried this solution in the source and works.

https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=684908

Vlad Lungeanu (drvladl) wrote :

For a quick fix: I have downloaded the Fedora RPM from here:
http://download.fedora.redhat.com/pub/fedora/linux/development/16/i386/os/Packages/krename-4.0.7-2.fc16.i686.rpm
and converted it to DEB with alien. Seems to work fine. Please find it attached in case you want it.

Mannex (russ-mannex) wrote :

Thanks so much, Vlad. That works great!

Fathi Boudra (fboudra) wrote :

fixed package uploaded to revu:
http://revu.ubuntuwire.com/details.py?upid=9305

Changed in krename (Ubuntu):
assignee: nobody → Fathi Boudra (fboudra)
status: Confirmed → In Progress
Ales (w-ales) wrote :

To Vlad Lungeanu: yes it works. Thanks!

Oleg Grom (gromescu) wrote :

>For a quick fix: I have downloaded the Fedora RPM from here:
>http://download.fedora.redhat.com/pub/fedora/linux/development/16/i386/os/Packages/krename-4.0.7-2.fc16.i686.rpm
>and converted it to DEB with alien. Seems to work fine. Please find it attached in case you want it.

I just downgraded to natty's version.

Kyle Sager (kylesager1) wrote :

Hi, Does anyone know if there is an easy way to use apt-get to downgrade Krename? I had the same crash as in this bug report. I removed the package that crashes but I can not seem to locate a good name to get an older version with apt-get.

Sam Rog (samrog131) wrote :

Q: Hi, Does anyone know if there is an easy way to use apt-get to downgrade Krename?

A:
1. Remove the current package
2. Download an older package: http://packages.ubuntu.com/search?keywords=krename&searchon=names&suite=all&section=all
3. Install an oder package (QApt).
4. Pin/ lock the package version: http://kubuntuforums.net/forums/index.php?topic=3117254.0

I'm using a patched version (fix_crash_on_static_initialization.diff). It seems to work. It is available from the PPA: https://launchpad.net/~samrog131/+archive/ppa

Paul White (paulw2u) wrote :

Also affects Precise 12.04

tags: added: precise

Segfault on startup krename 4.0.7-1 downloaded from Software center today. Ubuntu 11.10

Dan (daniel-armbrust-list) wrote :

When will this get pushed out as an update? The existing version is useless, and the fix is known. Change 1 line of code.

https://bugs.launchpad.net/ubuntu/+source/krename/+bug/898746/comments/3

Dan (daniel-armbrust-list) wrote :

I got in touch with the author of KRename yesterday, and he fixed this specific bug, along with a bunch of other potential re-occurrences of this bug in KRename release 4.0.8 (which was just released this morning)

http://www.krename.net/Stable.6.0.html

The hack fixes recommended here can be skipped entirely, if someone can package up 4.0.8 properly for ubuntu.

Fathi Boudra (fboudra) wrote :

Fixed in 4.0.9-1 upload.

Changed in krename (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package krename - 4.0.9-1

---------------
krename (4.0.9-1) unstable; urgency=low

  * New upstream release:
    - fix segfauls on startup. (Closes: #653892)
    - fix crash with SIGSEGV in __libc_csu_init(). (LP: #849882, #903593)

krename (4.0.7-2) unstable; urgency=low

  * Add find_libpodofo.patch to build with podofo support. (LP: #889425)
 -- Fathi Boudra <email address hidden> Tue, 03 Jan 2012 15:19:38 +0000

Changed in krename (Ubuntu):
status: Fix Committed → Fix Released
Murz (murznn) wrote :

krename - 4.0.9-1 available only for precise, can we backport it to oneric?

4.0.9-1 does not satisfy dependencies oneric.
My solution to the problem:
1. download http://download.fedora.redhat.com/pub/fedora/linux/releases/16/Everything/i386/os/Packages/krename-4.0.7-2.fc16.i686.rpm
2. sudo alien --scripts krename-4.0.7-2.fc16.i686.rpm

W dniu 27 stycznia 2012 10:54 użytkownik Murz
<email address hidden> napisał:
>
> krename - 4.0.9-1 available only for precise, can we backport it to
> oneric?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/849882
>
> Title:
> krename crashed with SIGSEGV in __libc_csu_init()
>
> Status in "krename" package in Ubuntu:
> Fix Released
>
> Bug description:
> Segmentation fault error happens every time I start krename
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: krename 4.0.7-1
> ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
> Uname: Linux 3.0.0-11-generic i686
> ApportVersion: 1.23-0ubuntu1
> Architecture: i386
> CrashCounter: 1
> Date: Wed Sep 14 12:07:16 2011
> ExecutablePath: /usr/bin/krename
> InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110901)
> ProcCmdline: krename
> ProcEnviron:
> SHELL=/bin/bash
> LANG=en_GB.UTF-8
> LANGUAGE=en_GB:en
> SegvAnalysis:
> Segfault happened at: 0x805eedd: lock incl (%eax)
> PC (0x0805eedd) ok
> source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: krename
> StacktraceTop:
> ?? ()
> __libc_csu_init ()
> __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
> _start ()
> Title: krename crashed with SIGSEGV in __libc_csu_init()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/krename/+bug/849882/+subscriptions

The download.fedora.redhat.com link is dead (at least right now).
Here is the main page from rpm.pbone.net to get links to mirrors:
http://rpm.pbone.net/index.php3/stat/4/idpl/17647451/dir/fedora_16/com/krename-4.0.9-1.fc16.i686.rpm.html

1- download
2- alien: converts the rpm to deb: sudo alien --scripts krename-4.0.9-1.fc16.i686.rpm
3- install the deb: sudo dpkg -i krename_4.0.9-2_i386.deb

Thanks for the tip Vlad

Pastor (sinel1980) wrote :

I don't know whye there are still (so long) no official update for oneiric. If you want working version now you can just use this unofficial DEB: https://launchpad.net/~samrog131/+archive/ppa/+files/krename_4.0.9%7Eoneiric%7Eppa1_i386.deb (for other architectures check https://launchpad.net/~samrog131/+archive/ppa/+packages

David Pérez (sanete) wrote :

Thanks Pastor, it works ok. :-)

Cedric (cedriczg) wrote :

Thanks Pastor. Worked for me as well (ubuntu Oneiric 64-bit)
Which step is missing to promote the working deb under to the normal repository for ubuntu Oneiric?

Fathi Boudra (fboudra) on 2012-03-19
Changed in krename (Ubuntu):
milestone: none → ubuntu-12.04
Fathi Boudra (fboudra) wrote :

Backport to Oneiric requested:
https://bugs.launchpad.net/bugs/959103

Fathi Boudra (fboudra) on 2012-03-20
Changed in krename (Ubuntu Oneiric):
assignee: nobody → Fathi Boudra (fboudra)
status: New → In Progress
importance: Undecided → High
milestone: none → oneiric-updates
Fathi Boudra (fboudra) wrote :

Package uploaded to oneiric-proposed, in queue for a SRU.

Changed in krename (Ubuntu Oneiric):
status: In Progress → Fix Committed

Hello Paul, or anyone else affected,

Accepted krename into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Roland Meier (rm369) wrote :

TEST CASE:
1. install krename 4.0.7-1ubuntu1 from oneiric -proposed
2. start krename
3. verify that it starts without SEGV

VERIFICATION DONE:
- krename starts cleanly

SomeOne (andreas-helmcke) wrote :

confirming that krename 4.0.7-1ubuntu1 is starting without error.

Martin Pitt (pitti) on 2012-03-23
tags: added: verification-done
removed: verification-needed
Paul White (paulw2u) wrote :

As the originator of this bug report I can say that I have removed 4.0.7-2 installed as per comment #24 and installed 4.0.7-1ubuntu1. krename now starts, thank you.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package krename - 4.0.7-1ubuntu1

---------------
krename (4.0.7-1ubuntu1) oneiric-proposed; urgency=low

  * Fix crash on static initialization. (LP: #849882)
 -- Fathi Boudra <email address hidden> Wed, 19 Oct 2011 21:12:00 +0300

Changed in krename (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.