trying to upgrade from 11.10 to 12.04: The package 'postgresql-contrib-8.2' is marked for removal but it's in the removal blacklist

Bug #1007314 reported by Peter Nikolov on 2012-06-01
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
krb5 (Ubuntu)
High
Stéphane Graber
Precise
High
Stéphane Graber

Bug Description

I was trying to upgrade from 11.10 to 12.04 using do-release-upgrade

TEST CASE:
1. Install Oneiric and updates
2. Enable Hardy, and install postgresql-contrib-8.2
3. Disable Hardy
4. Upgrade

ACTUAL RESULT
Upgrade failed with the following message in main.log
The package 'postgresql-contrib-8.2' is marked for removal but it's in the removal blacklist

VERIFICATION
1. Enable oneiric-proposed in /etc/apt/sources.list and update apt cache
2. Install all updates from -proposed to prevent upgrade from holding back many packages
3. Upgrade
=> Verify that the upgrade works
=> Verify that postgresql*8.2 is in the obsolete list in /var/log/dist-upgrade/main.log

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: update-manager (not installed)
ProcVersionSignature: Ubuntu 3.0.0-20.34-generic-pae 3.0.30
Uname: Linux 3.0.0-20-generic-pae i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Fri Jun 1 11:42:29 2012
InstallationMedia: Ubuntu-Server 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.2)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
UpgradeStatus: Upgraded to oneiric on 2012-06-01 (0 days ago)

Peter Nikolov (peter-nikolov) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

This is blocked by
2012-06-01 11:42:17,440 DEBUG blacklist expr '^postgresql-.*[0-9]\.[0-9].*' matches 'postgresql-contrib-8.2'
2012-06-01 11:42:17,441 DEBUG The package 'postgresql-contrib-8.2' is marked for removal but it's in the removal blacklist
2012-06-01 11:42:17,525 ERROR Dist-upgrade failed: 'The package 'postgresql-contrib-8.2' is marked for removal but it is in the removal blacklist.'

You can workaround by removing postgresql-contrib-8.2 before upgrade and reinstalling postgresql-contrib afterwards.

Changed in update-manager (Ubuntu):
importance: Undecided → High
status: New → Triaged
summary: - trying to upgrade from 11.10 to 12.04
+ trying to upgrade from 11.10 to 12.04: The package 'postgresql-
+ contrib-8.2' is marked for removal but it's in the removal blacklist
Changed in update-manager (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
milestone: none → ubuntu-12.04.1
tags: added: rls-mgr-p-tracking
Marcel (mpgsmeets) wrote :

I do get the message for the postgres package: An unresolvable problem occurred while calculating the upgrade:
The package 'postgresql-8.2' is marked for removal but it is in the
removal blacklist.

Simply removal of the postgresql package is not the solution as there is a running postgresql server running with working db

Noek vanBiljon (noekvb) on 2012-06-05
Changed in update-manager (Ubuntu Precise):
status: Triaged → Confirmed
Changed in update-manager (Ubuntu):
status: Triaged → Confirmed
Changed in update-manager (Ubuntu):
status: Confirmed → Triaged
Changed in update-manager (Ubuntu Precise):
status: Confirmed → Triaged
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in update-manager (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Brian Murray (brian-murray) wrote :

I think this modification to the blacklist will do it:

=== modified file 'DistUpgrade/removal_blacklist.cfg'
--- DistUpgrade/removal_blacklist.cfg 2012-04-17 21:27:54 +0000
+++ DistUpgrade/removal_blacklist.cfg 2012-07-17 18:24:28 +0000
@@ -9,7 +9,7 @@
 update-manager
 update-manager-core
 # posgresql (LP: #871893)
-^postgresql-.*[0-9]\.[0-9].*
+^postgresql-(client-)?[0-9]\.[0-9].*
 # the upgrade runs in it
 screen
 # unity

Martin Pitt (pitti) wrote :

Please don't modify the blacklist. Instead, as you are using the backports PPA, please update your apt sources to also use the backports PPA for "precise" instead of "oneiric" before upgrading. I'm afraid we can't quite support this kind of upgrade without a PPA, but if in doubt I'd rather vote for preventing data loss.

Ideally the whole postgresql-*-*8.2 package set from Ubuntu 11.10 should work on 12.04 just fine. However, that isn't the case because of the libkrb53 -> libkrb5-3 transition, and we failed to provide a backwards compatible libkrb53 transitional package.

So aside from letting upgraders with PPAs handle the situation manually, I see two solutions:

 - Introduce a transitional libkrb53 into precise (it won't be needed for quantal). This is a pin-pointed and very safe solution for stable.

 - Don't disable PPAs during upgrades, but instead rewrite their apt lines for the release to be upgraded to. This is a bold solution which will presumably also fix similar upgrade failures, but it might also introduce new failures.

Changed in update-manager (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Stéphane Graber (stgraber)
Changed in update-manager (Ubuntu Precise):
assignee: Canonical Foundations Team (canonical-foundations) → Stéphane Graber (stgraber)

On Wed, Jul 18, 2012 at 05:13:37AM -0000, Martin Pitt wrote:
> - Don't disable PPAs during upgrades, but instead rewrite their apt
> lines for the release to be upgraded to. This is a bold solution which
> will presumably also fix similar upgrade failures, but it might also
> introduce new failures.

Disabling ppas on upgrade is quite deliberate, since we have no control over
what packages might be in them that conflict with the tested upgrade path.
This would definitely be trading a known bug for an unknown bug, we
shouldn't do this.

Stéphane Graber (stgraber) wrote :

Yeah, introducing a transitional package seems like our best bet here, it should be safe enough to review for precise-updates and won't require any actual code change in the upgrader.

affects: update-manager (Ubuntu) → krb5 (Ubuntu)
Changed in krb5 (Ubuntu):
status: Triaged → Won't Fix

Hello Peter, or anyone else affected,

Accepted krb5 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/krb5/1.10+dfsg~beta1-2ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in krb5 (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Precise:
I have reproduced the problem with krb5 1.10+dfsg~beta1-2ubuntu0.1 in precise-updates and have verified that the version of krb5 1.10+dfsg~beta1-2ubuntu0.2 in -proposed fixes the issue.

Marking as verification-done

description: updated
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package krb5 - 1.10+dfsg~beta1-2ubuntu0.2

---------------
krb5 (1.10+dfsg~beta1-2ubuntu0.2) precise-proposed; urgency=low

  * Re-introduce libkrb53 as a transitional package to libkrb5-3.
    Also revert the Conflicts against libkrb53 to the old versioned
    Break/Replaces. (LP: #1007314)
 -- Stephane Graber <email address hidden> Wed, 18 Jul 2012 17:41:48 -0400

Changed in krb5 (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers