krb5-strength 3.1-1 source package in Ubuntu

Changelog

krb5-strength (3.1-1) unstable; urgency=medium

  * New upstream release.
    - New configuration option cracklib_maxlen.
    - require_classes now supports requiring a minimum number of classes.
    - Capitalize the first letter of error messages.
    - Apply SuSE patch for a security vulnerability in the embedded
      CrackLib.  This didn't affect the way it was used in this package,
      but best to be sure anyway.
    - Configuration instructions are now provided in installed man pages,
      including a new krb5-strength man page, to make them more accessible
      after installation.
  * Patch the upstream test suite to change the expected results for a few
    passwords that are rejected by the embedded CrackLib but accepted by
    the system CrackLib (which the Debian package is built with).
  * Re-enable treating test suite failures as package build failures now
    that bug #724570 in CrackLib was fixed in Debian.
  * Switch to the DEP-14 branch layout and update debian/gbp.conf and
    Vcs-Git accordingly.
  * Prefer *.tar.xz in debian/watch to match packaging.
  * Fix Upstream-Contact email address in debian/copyright.
  * Switch to https for all package URLs.
  * Run wrap-and-sort -ast.
  * Refresh upstream signing key.
  * Enable all hardening flags.
  * Update to debhelper compatibility level V10.
    - Remove explicit dh-autoreconf dependency and invocation.
    - Remove explicit --parallel flags.
  * Update standards version to 3.9.8 (no changes required).

 -- Russ Allbery <email address hidden>  Sun, 25 Dec 2016 12:40:41 -0800

Upload details

Uploaded by:
Russ Allbery on 2016-12-26
Uploaded to:
Sid
Original maintainer:
Russ Allbery
Architectures:
any
Section:
misc
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Bionic release on 2017-10-24 universe misc

Downloads

File Size SHA-256 Checksum
krb5-strength_3.1-1.dsc 1.9 KiB 651d84f4f27715b50b0ac0522a81ff5141849daedc81c8cba25e7a4c96042fa4
krb5-strength_3.1.orig.tar.xz 378.5 KiB 736f940c17f40c2d418cff48b93ad5f0296ee6fa2093679a79cba2a88e4c2ed6
krb5-strength_3.1-1.debian.tar.xz 14.9 KiB bebc8865c15fb759acde3915133f23861a26519d85b61464b28111b64de997ea

Available diffs

No changes file available.

Binary packages built by this source

krb5-strength: No summary available for krb5-strength in ubuntu disco.

No description available for krb5-strength in ubuntu disco.

krb5-strength-dbgsym: No summary available for krb5-strength-dbgsym in ubuntu zesty.

No description available for krb5-strength-dbgsym in ubuntu zesty.