RFE: optionally refresh AFS tokens too

Bug #113347 reported by Marty Vona on 2007-05-08
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bugzilla.gnome.org
Fix Released
Wishlist
krb5-auth-dialog (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: krb5-auth-dialog

krb5-auth-dialog is getting better and better. One thing it seems to still lack, even in current svn, is a feature to also refresh AFS tokens after getting or renewing kerberos tickets.

Such a feature is important to people like me who mainly use kerberos to authenticate to afs servers. For reference, another package vaguely similar to krb5-auth-dialog which does include this feature is krenew (http://www.eyrie.org/~eagle/software/kstart/krenew.html).

I tested a quick and dirty hack to krb5-auth-dialog svn, patch attached, which seems to work for me. A proper implementation would of course be configurable.

Marty Vona (vona) wrote :
Daniel T Chen (crimsun) wrote :

Is this request still valid for 8.10 beta?

Changed in krb5-auth-dialog:
importance: Undecided → Wishlist
status: New → Incomplete
Marty Vona (vona) wrote :

I stopped using krb5-auth-dialog, now I use kredentials, which works for me.

Duane Hinnen (duanedesign) wrote :

 We are closing this bug report because it lacks the information we need to investigate the problem, and it appears to no longer be a problem for the submitter. Please reopen it if you can test this bug against the latest release and it is still an issue, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in krb5-auth-dialog (Ubuntu):
status: Incomplete → Invalid
Evan Broder (broder) wrote :

Re-opening. This bug still exists. I'll also link in the upstream bug report in just a moment.

Changed in krb5-auth-dialog (Ubuntu):
status: Invalid → Confirmed
Changed in bugzilla.gnome.org:
status: Unknown → New
Changed in bugzilla.gnome.org:
status: New → Fix Released
Changed in bugzilla.gnome.org:
importance: Unknown → Wishlist
Nikolai Beier (nikbeier) wrote :

There is already a package with AFS support in version 0.16-4 at http://packages.debian.org/stable/utils/krb5-auth-dialog
Why not include this package in the Ubuntu repository instead of the 0.15 version? (Perhaps that upgrade will also fix https://bugs.launchpad.net/ubuntu/+source/krb5-auth-dialog/+bug/478975 )

(AFS support is enabled by running "gconftool-2 --set --list-type=string --type=list /apps/krb5-auth-dialog/plugins/enabled [afs]" and restart krb5-auth-dialog. In order to start the app, even when there are no credentials or tickets, run "krb5-auth-dialog -A".)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.