New upstream release: Kraft 0.40

Bug #374247 reported by Alessandro Ghersi on 2009-05-09
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kraft (Ubuntu)
Wishlist
Unassigned

Bug Description

New version 0.32, also I fixed missing depends (bug #280530)

Sources: http://kde-apps.org/content/show.php/Kraft?content=54172

description: updated

Thank you for the bug report, and thanks for the deb files too. Marking as wishlist and triaged.

summary: - New upstream release
+ New upstream release: Kraft 0.32
Changed in kraft (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged

Sorry, FTBS. This upgrade needs google-ctemplate (http://code.google.com/p/google-ctemplate/) for build.
Google-ctemplat is not in our repository.

Changed in kraft (Ubuntu):
assignee: nobody → Alessandro Ghersi (alessandro-ghersi)

Please note that Kraft 0.32 also depends on libctemplate0 and since version 0.32 also on pdftk

Nick Ellery (nick.ellery) wrote :

Looks like this is in progress, for now. I'll unsubscribe sponsors, and please resubscribe when ready. Thanks!

Artur Rona (ari-tczew) on 2009-07-27
tags: added: upgrade
Changed in kraft (Ubuntu):
assignee: Alessandro Ghersi (alessandro-ghersi) → nobody
Felix Geyer (debfx) wrote :

I packaged Kraft 0.40. Please consider sponsoring it.

Upstream tarball: http://downloads.sourceforge.net/project/kraft/kraft/0.40/kraft-0.40.tar.bz2

kraft (0.40-0ubuntu1) maverick; urgency=low

  * New upstream release. (LP: #374247).
  * Update build-dependencies to new upstream version.
  * Depend on libqt4-sql-sqlite, pdftk and python-trml2pdf.
  * Recommend libqt4-sql-mysql.
  * Switch to source format 3.0 (quilt), dh7 style rules and compat level 7.
  * Update debian/copyright and port to DEP-5.
  * Drop manpage as it's outdated and isn't really useful.
  * Add watch file.
  * Add 01_dont_install_cmake_script.patch to prevent Kraft from installing
    FindCtemplate.cmake.
  * Add 02_libkraftcat_private_dir.patch so libkraftcat.so is installed to
    /usr/lib/kraft.
  * Add 03_fix_desktop_file.patch to remove duplicate "Encoding" entry.

 -- Felix Geyer <email address hidden> Sun, 16 May 2010 17:17:35 +0200

summary: - New upstream release: Kraft 0.32
+ New upstream release: Kraft 0.40
Felix Geyer (debfx) wrote :
Benjamin Drung (bdrung) wrote :

The package looks good (using the latest packaging tools), but there are some lintian warnings:

W: kraft: binary-without-manpage usr/bin/kplant
W: kraft: binary-without-manpage usr/bin/kraft
W: kraft: binary-without-manpage usr/bin/trml2pdf_kraft.sh
E: kraft: binary-or-shlib-defines-rpath ./usr/bin/kplant /usr/lib
E: kraft: binary-or-shlib-defines-rpath ./usr/bin/kraft /usr/lib
E: kraft: binary-or-shlib-defines-rpath ./usr/lib/kraft/libkraftcat.so /usr/lib
W: kraft: script-with-language-extension usr/bin/trml2pdf_kraft.sh

* At least binary-or-shlib-defines-rpath and script-with-language-extension needs to be fixed.
* Please fix the Name in debian/copyright. It's not "Blobby Volley 2". ;)
* Please drop the comment (first line) from debian/watch

Please resubscribe ubuntu-sponsors once these issues are addressed.

Are there any plans to bring this package to Debian?

Felix Geyer (debfx) wrote :

> * At least binary-or-shlib-defines-rpath and script-with-language-extension needs to be fixed.
The binary-or-shlib-defines-rpath warnings are fixed with the latest kde4libs upload.
I'm a bit a bit reluctant to change the name of trml2pdf_kraft.sh as I don't want to break compatibility with upstream.
I have opened an upstream bug report though.

> * Please fix the Name in debian/copyright. It's not "Blobby Volley 2". ;)
Doh, stupid copy'n'paste :D

> * Please drop the comment (first line) from debian/watch
Will do.

> Are there any plans to bring this package to Debian?
After packaging the new version I noticed that it's already being worked on in Debian:
http://bugs.debian.org/580718
I'll post a link to my package to the Debian bug once I have fixed it.

Benjamin Drung (bdrung) wrote :

> I'm a bit a bit reluctant to change the name of trml2pdf_kraft.sh as I don't want to break compatibility with upstream.
> I have opened an upstream bug report though.

Ok, let's have this fixed in upstream first.

> After packaging the new version I noticed that it's already being worked on in Debian:
> http://bugs.debian.org/580718

You could maintain this package in Debian together with the Debian developer and keep the package synced to Ubuntu.

Felix Geyer (debfx) wrote :

> You could maintain this package in Debian together with the Debian developer and keep the package synced to Ubuntu.
Yep, I'm doing that now.
0.40-1 has been synced to Ubuntu.

Changed in kraft (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.