FM Radio doesn't work, only TV

Bug #776065 reported by casoft on 2011-05-03
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Gnomeradio
Won't Fix
High
kradio4 (Ubuntu)
Undecided
Unassigned
xawtv (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnomeradio

Hi.
In Ubuntu 10.10 the SAA7134 working perfect with gnomeradio and this options:

options saa7134 i2c_scan=1 card=65

Now, un Ubuntu 11.04 im put this options and Working only the TV, the radio (gnomeradio and kradio) no work, no detect the radio, but this options create the file /dev/radio0.

My dmesg | grep saa7134 is:

[ 69.339244] saa7134 0000:01:06.0: PCI INT A -> Link[LNKA] -> GSI 17 (level, low) -> IRQ 17
[ 69.364118] input: saa7134 IR (V-Stream Studio TV as /devices/pci0000:00/0000:00:08.0/0000:01:06.0/rc/rc0/input6
[ 69.364186] rc0: saa7134 IR (V-Stream Studio TV as /devices/pci0000:00/0000:00:08.0/0000:01:06.0/rc/rc0
[ 73.443533] saa7134 ALSA driver for DMA sound loaded

My /proc/version is:

Linux version 2.6.38-8-generic-pae (buildd@vernadsky) (gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu3) ) #42-Ubuntu SMP Mon Apr 11 05:17:09 UTC 2011

The TVTIME working fine!

UPDATE: 3-MAY-2011
Im update the Kernel to:
Linux version 2.6.38-9-generic-pae (buildd@vernadsky) (gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4) ) #43-Ubuntu SMP Thu Apr 28 17:12:11 UTC 2011

The problem continue

casoft (casoft) wrote :
casoft (casoft) on 2011-05-03
description: updated
casoft (casoft) on 2011-05-03
description: updated
nihilus (nihilus-i) wrote :

Same problem. Have Pinnacle Systems PCTV 50i PCI card (saa7134 based) that worked on all Ubuntu versions from Hardy through Maverick. Tried to install different frontend CLI and GUI apps (gnomeradio, kradio, ncurses-radio etc to no avail). It looks like the audio part of saa7134 driver works fine (through loud static noise i can hear badly tuned FM stations on some "default" frequency), it is frequency tuning problem (VIDIOCGAUDIO, VIDIOCSFREQ errors are visible in all apps when running from terminal). The issue was solved by downgrading linux kernel from 2.6.38-8 to 2.6.35-22 (had to temporarily change "natty main" to "maverick main" in /etc/apt/sources.list to do that).

Łukasz Semler (lukasz-semler) wrote :

Don't know is this related to driver of saa7134, cause I've got Winfast TV2000XP which is based ( is what dmesg is saying )

TDA9887

Same problems like nihilus have. Did't tried with older kernel.

Łukasz Semler (lukasz-semler) wrote :

This is lspci output about my card:

05:01.0 Multimedia video controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)

nihilus (nihilus-i) wrote :

Until now, the only application which works fine with my board on newer kernel is mplayer, compiled from source with such parameters (the mplayer binary package, which can be obtained via repository is apparently compiled WITHOUT radio support):
./configure --enable-radio --enable-radio-capture.
Currently i'm successfully using SMplayer as a frontend to it.

nihilus (nihilus-i) wrote :

Forgot to mention - to play your stations in smplayer - add such entries in the playlist:
radio://101.50/capture
- where 101.50 is your FM frequency in MHz.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnomeradio (Ubuntu):
status: New → Confirmed
Blaze (blaze) wrote :

Expiriencing on Oneiric.
apps: radio, kradio
kernel: 3.0.0-12-generic

Blaze (blaze) on 2011-10-13
summary: - The SAA7134 no work Radio only TV
+ FM Radio doesn't work, only TV
Blaze (blaze) on 2011-10-13
affects: gnomeradio (Ubuntu) → kradio4 (Ubuntu)
Blaze (blaze) wrote :

well

> V4L2 in Linux 2.6.39
> The old VIDIOC_*_OLD symbols and V4L1 support were removed.
http://linuxtv.org/downloads/v4l-dvb-apis/hist-v4l2.html#id3107990

So we have a bunch of apps that was not actually ported to V4L2 or simply doesn't work without V4L1.

LA (radiobuzzer) wrote :

Most importantly they are the only applications that play FM radio

LA (radiobuzzer) wrote :

I confirm the error on radio package of xawtv (mentioned as nurce radio above)

no longer affects: xawtv (Ubuntu)
Changed in xawtv (Ubuntu):
status: New → Confirmed
Changed in gnomeradio:
importance: Unknown → High
status: Unknown → New

Hi all,

to my (current) knowledge, this bug is not an issue of the V4L1 API dropped in recent Linux kernels, since particularly KRadio supports V4L2. Furthermore, even mplayer does not solve the problems on such systems.
Those V4L2 drivers seem to report an invalid frequency range (0 to 0 Hz).

The problem seems to be at least narrowed down on the LKML since November 2011:

   https://lkml.org/lkml/2011/11/11/257
   https://lkml.org/lkml/2011/12/15/177

... unfortunately without answers to those posts on the LKML yet.

Therefore, I'd propose to consider this bug as a kernel bug - unfortunately without any clue how to further approach a solution of this issue.

Best regards,

   Martin

casoft (casoft) wrote :

Hi all,

This bug is solved in the Kernel Linux version 3.2.0-24.

Thanks to all!

Touch T (toucht) wrote :

Hi

I can not confirm that this bug is fixed. In 12.04 with recent kernel 3.2.0-30-generic-pae FM Radio is not working with gnomeradio. I can only hear an annoying noise. When booting Lucid kernel 2.6.32-42-generic (in 12.04) gnomeradio works out of the box.

booting kernel 3.2.0-30:
~$ v4l2-ctl -d /dev/radio0 --all -L
Frequency range : 0.0 MHz - 0.0 MHz
~$ dmesg
tuner 2-0061: Tuner -1 found with type(s) Radio TV

booting kernel 2.6.32.42:
~$ v4l2-ctl -d /dev/radio0 --all -L
Frequency range : 65.0 MHz - 108.0 MHz
~$ dmesg
tuner 2-0061: chip found @ 0xc2 (bt878 #0 [sw])

ThomasB

Blaze (blaze) wrote :

In 12.10 all works fine.

$ uname -a
Linux <...> 3.5.0-15-generic #22-Ubuntu SMP Wed Sep 19 20:06:19 UTC 2012 i686 i686 i686 GNU/Linux

$ v4l2-ctl -d /dev/radio0 --all -L
Driver Info (not using libv4l2):
        Driver name : bttv
<...>
Tuner:
        Name : Radio
        Capabilities : 62.5 Hz stereo
        Frequency range : 65.0 MHz - 108.0 MHz
<...>

Touch T (toucht) wrote :

I tried in 12.10, booted from iso file quantal-desktop-i386.iso. I couldn't get the GUI working so I booted into text mode and used fmtools. I hear my favourite radio station.

$ uname -a
Linux ubuntu 3.5.0-15-generic #22-Ubuntu SMP Wed Sep 19 20:06:19 UTC 2012 i686 athlon i686 GNU/Linux

$ fm 99.05
Radio tuned to 99.05 MHz (radio does not support volume control)

$ fm on
Radio on (radio does not support volume control)

$ v4l2-ctl -d /dev/radio0 -all -L
Driver Info (not using libv4l2):
 Driver name : bttv
 Card type : BT878 radio (Hauppauge (bt878))
 Bus info : PCI:0000:02:08.0
 Driver version: 3.5.4
 Capabilities : 0x00010000
  Tuner
Video input : 0 (Radio: ok)
Audio input : 0 (Radio)
Frequency: 1584799 (99.049937 MHz)
Tuner:
 Name : Radio
 Capabilities : 62.5 Hz stereo
 Frequency range : 65.0 MHz - 108.0 MHz
 Signal strength/AFC : 25%/0
 Current audio mode : stereo
 Available subchannels: stereo
                           mute (bool) : default=0 value=0

Then I booted ubuntu-12.04.1-desktop-i386.iso from iso file. Radio is not working
$ uname -a
Linux ubuntu 3.2.0-29-generic-pae #46-Ubuntu SMP Fri Jul 27 17:25:43 UTC 2012 i686 athlon i386 GNU/Linux

$ fm 99.05
fm: Frequency 99.0 MHz out of range (0.0 - 0.0 MHz)

$ fm on
Radio on (radio does not support volume control)

$ v4l2-ctl -d /dev/radio0 --all -L
Driver Info (not using libv4l2):
 Driver name : bttv
 Card type : BT878 radio (Hauppauge (bt878))
 Bus info : PCI:0000:02:08.0
 Driver version: 3.2.24
 Capabilities : 0x00010000
  Tuner
Video input : 0 (Radio: ok)
Audio input : 0 (Radio)
Frequency: 0 (0.000000 MHz)
Tuner:
 Name : Radio
 Capabilities : 62.5 kHz
 Frequency range : 0.0 MHz - 0.0 MHz
 Signal strength/AFC : 0%/0
 Current audio mode : mono
 Available subchannels:
                           mute (bool) : default=0 value=0

Bernhard (baumber) wrote :
Download full text (4.1 KiB)

Hello,

I have the same problem with a Hauppauge WinTV PVR card (bt878 with radio).

Since 2.6.39.x radio is broken => No Frequency range :

v4l2-ctl -d /dev/radio0 --all -L
kernel 2.6.32.x:
----------------
Driver Info (not using libv4l2):
        Driver name : bttv
        Card type : BT878 radio (Hauppauge WinTV PV
        Bus info : PCI:0000:02:0a.0
        Driver version: 0.9.18
        Capabilities : 0x00010000
                Tuner
Video input : 0 (Radio: ok)
Audio input : 0 (Radio)
Frequency: 0 (0.000000 MHz)
Tuner:
        Name : Radio
        Capabilities : 62.5 Hz stereo
        Frequency range : 65.0 MHz - 108.0 MHz
        Signal strength/AFC : 13%/0
        Current audio mode : stereo
        Available subchannels: mono
                           mute (bool) : default=0 value=1

kernel 2.6.38.x:
----------------
Driver Info (not using libv4l2):
        Driver name : bttv
        Card type : BT878 radio (Hauppauge WinTV PV
        Bus info : PCI:0000:02:0a.0
        Driver version: 0.9.18
        Capabilities : 0x00010000
                Tuner
Video input : 0 (Radio: ok)
Audio input : 0 (Radio)
Frequency: 0 (0.000000 MHz)
Tuner:
        Name : Radio
        Capabilities : 62.5 Hz stereo
        Frequency range : 65.0 MHz - 108.0 MHz
        Signal strength/AFC : 0%/0
        Current audio mode : stereo
        Available subchannels: mono
                           mute (bool) : default=0 value=1

kernel 3.0.x:
----------------
Driver Info (not using libv4l2):
        Driver name : bttv
        Card type : BT878 radio (Hauppauge WinTV PV
        Bus info : PCI:0000:02:0a.0
        Driver version: 0.9.18
        Capabilities : 0x00010000
                Tuner
Video input : 0 (Radio: ok)
Audio input : 0 (Radio)
Frequency: 0 (0.000000 MHz)
Tuner:
        Name : Radio
        Capabilities : 62.5 kHz
        Frequency range : 0.0 MHz - 0.0 MHz
        Signal strength/AFC : 0%/0
        Current audio mode : mono
        Available subchannels:
                           mute (bool) : default=0 value=1

3.2:
-----
Driver Info (not using libv4l2):
        Driver name : bttv
        Card type : BT878 radio (Hauppauge WinTV PV
        Bus info : PCI:0000:02:0a.0
        Driver version: 3.2.27
        Capabilities : 0x00010000
                Tuner
Video input : 0 (Radio: ok)
Audio input : 0 (Radio)
Frequency: 0 (0.000000 MHz)
Tuner:
        Name : Radio
        Capabilities : 62.5 kHz
        Frequency range : 0.0 MHz - 0.0 MHz
        Signal strength/AFC : 0%/0
        Current audio mode : mono
        Available subchannels:
                           mute (bool) : default=0 value=1

I will test it with the quantal kernel (3.5.x) too, which is also available in proposed under precise.

Udo Steinberg bisected the commit:
Link and message: https://lkml.org/lkml/2011/11/11/257
I've bisected the problem. The commit that breaks things is:

commit cbde689823776d187ba1b307a171625dbc02dd4f
Author: Mauro Carvalho Chehab <email address hidden>
Date: Fri Feb 4 1...

Read more...

Changed in gnomeradio:
status: New → Won't Fix
Bernhard (baumber) wrote :

I can confirm that with kernel 3.5.7 (ubuntu kernel 3.5.0-18-generic
#29~precise), my radio is working again.

v4l2-ctl -d /dev/radio0 --all -L
Driver Info (not using libv4l2):
         Driver name : bttv
         Card type : BT878 radio (Hauppauge WinTV PV
         Bus info : PCI:0000:02:0a.0
         Driver version: 3.5.7
         Capabilities : 0x00010000
                 Tuner
Video input : 0 (Radio: ok)
Audio input : 0 (Radio)
Frequency: 0 (0.000000 MHz)
Tuner:
         Name : Radio
         Capabilities : 62.5 Hz stereo
         Frequency range : 65.0 MHz - 108.0 MHz
         Signal strength/AFC : 13%/0
         Current audio mode : stereo
         Available subchannels: mono
                            mute (bool) : default=0 value=1

Is there the possibility to backport to Long-Term-Stable kernels and
so to solve the problem in kernel 3.2.x?

Blaze (blaze) on 2013-01-17
Changed in kradio4 (Ubuntu):
status: Confirmed → Fix Released
Changed in xawtv (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.