Ubuntu

/dev/kqemu is not created by udev

Reported by Cedric Schieli on 2007-04-12
12
Affects Status Importance Assigned to Milestone
kqemu (Debian)
Fix Released
Unknown
kqemu (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kqemu-common

After modprobing kqemu.ko built from kqemu-source, there is no /dev/kqemu file created.

Adding this udev rule is necessary (but not sufficient) :
KERNEL=="kqemu", NAME="%k", MODE="0666"

The file /etc/modprobe.d/kqemu is preventing the previous rule to work.
Removing the file works for me.

Changed in kqemu:
status: Unconfirmed → Confirmed
Victor Stinner (victor-stinner) wrote :

There is two different approch.

(1) without udev, static device

* Major have to be 250: kqemu-common version 1.3.0~pre11-4 contains /etc/modprobe.d/kqemu (options kqemu major=250) to do that
* Create node using « mknod /dev/kqemu c 250 0; chmod 666 /dev/kqemu »

(2) with udev, dynamic device

* Major have to be 0 => fix /etc/modprobe.d/kqemu (options kqemu major=0)
* Need the file /etc/udev/rules.d/60-kqemu.rules (content: « KERNEL=="kqemu", NAME="%k", MODE="0666" »)

I prefer dynamic devices so please fix the package to do that :-)

Changed in kqemu:
status: Unknown → Fix Released
hdante (hdante) wrote :

Bug confirmed here. Ubuntu uses udev, so only number (2) is an option.

Steve Kowalik (stevenk) wrote :

Actually, this should have been fixed in the version of kqemu that was shipped with Feisty.

Changed in kqemu:
status: Confirmed → Fix Released
Stefano Rivera (stefanor) wrote :

The next stage is bug 135067...

Adrien Laurent (adrien-laurent) wrote :

For those who still have the unpatched version, here is the fix:

sudo mknod /dev/kqemu c 250
sudo chmod 666 /dev/kqemu

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.