kpatch-dkms 0.3.2-1ubuntu4.2: kpatch kernel module failed to build

Bug #1665613 reported by sambolinux on 2017-02-17
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
kpatch (Ubuntu)
Medium
Unassigned

Bug Description

again using aptik to restore did not see error

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: kpatch-dkms 0.3.2-1ubuntu4.2
ProcVersionSignature: Ubuntu 4.8.0-36.36~16.04.1-generic 4.8.11
Uname: Linux 4.8.0-36-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
DKMSKernelVersion: 4.8.0-36-generic
Date: Fri Feb 17 03:20:10 2017
DuplicateSignature: dkms:kpatch-dkms:0.3.2-1ubuntu4.2:/var/lib/dkms/kpatch/0.3.2/build/kmod/core/core.c:256:13: error: initialization from incompatible pointer type [-Werror=incompatible-pointer-types]
InstallationDate: Installed on 2017-02-17 (0 days ago)
InstallationMedia: Ubuntu-MATE 16.04.2 LTS "Xenial Xerus" - Release amd64 (20170215)
PackageVersion: 0.3.2-1ubuntu4.2
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.19
SourcePackage: kpatch
Title: kpatch-dkms 0.3.2-1ubuntu4.2: kpatch kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

sambolinux (sambolinux) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kpatch (Ubuntu):
status: New → Confirmed
Gaëtan Trellu (goldyfruit) wrote :

Same issue here, Ubuntu Xenial 16.04.2

Changed in kpatch (Ubuntu):
importance: Undecided → Medium
Gaëtan Trellu (goldyfruit) wrote :

Any updates ?

Gaëtan Trellu (goldyfruit) wrote :

No more maintainer ?

Gaëtan Trellu (goldyfruit) wrote :

Still not building with 4.11.0-14 kernel.

cc1: some warnings being treated as errors
scripts/Makefile.build:294: recipe for target '/var/lib/dkms/kpatch/0.3.2/build/kmod/core/core.o' failed
make[3]: *** [/var/lib/dkms/kpatch/0.3.2/build/kmod/core/core.o] Error 1
Makefile:1698: recipe for target 'kpatch.ko' failed
make[2]: *** [kpatch.ko] Error 2
make[2]: Leaving directory '/usr/src/linux-headers-4.11.0-14-generic'
Makefile:13: recipe for target 'kpatch.ko' failed
make[1]: *** [kpatch.ko] Error 2
make[1]: Leaving directory '/var/lib/dkms/kpatch/0.3.2/build/kmod/core'
Makefile:5: recipe for target 'all' failed
make: *** [all] Error 2
make: Leaving directory '/var/lib/dkms/kpatch/0.3.2/build/kmod'

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kpatch - 0.5.0-0ubuntu1

---------------
kpatch (0.5.0-0ubuntu1) bionic; urgency=low

   * Upstream bump to 0.5.0 (LP: #1763065).
   * Drop patches that are present in the upstream release:
     - kpatch-build-works-without-kpatch-kmod.patch
     - kmod-core-fix-stacktrace_ops-address-function-protot.patch
     - create-diff-object-fix-WARN-_ONCE-detection-on-newer.patch
     - use-livepatch-4.5-kernel-features.patch
   * output-kernel-build-in-debug.patch was dropped to reduce build output.
   * These remaining patches have been updated to apply to the refreshed
     upstream:
     - kpatch-build-adjust-dirs.patch
     - use-debian-rules-for-ubuntu-builds.patch
     - ubuntu-kernel-variants.patch
   * The shellcheck linter is called during packaging, to verify the quality of
     the scripts used in the package.
   * List the Ubuntu Kernel Team as the package maintainer in the control file
   * kmod/core: fix stacktrace_ops 'address' function prototype for 4.6 (LP: #1665613, #1659581)

 -- Benjamin M Romer <email address hidden> Wed, 11 Apr 2018 21:41:51 -0400

Changed in kpatch (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers