kpatch-build build log file needs to be smaller

Bug #1570012 reported by Ben Romer on 2016-04-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kpatch (Ubuntu)
Wishlist
Ben Romer
Xenial
Wishlist
Unassigned

Bug Description

The .kpatch/build.log file is enormous because it is carrying around the entire build log for two kernel builds, when realistically it only needs to keep the last build performed.

There's no reason to hang on to the initial kernel build after it is complete, as a) it should normally complete without error, and b) if there is a problem, the script will bail out there anyway. The script needs the second build output for checking for unresolved symbols, but since this build is only touching files modified by the patch, it should be much smaller.

Running the build in non-debug mode cuts down on noise as well, though some output is still necessary to avoid timeouts. Adding a function to output dots during the kernel builds will take care of timeouts without cluttering the screen.

Ben Romer (bromer) wrote :

The attachment "Cut down on file size" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in kpatch (Ubuntu):
importance: Undecided → Wishlist
Chris J Arges (arges) on 2016-05-02
Changed in kpatch (Ubuntu):
status: New → In Progress

Hello Ben, or anyone else affected,

Accepted kpatch into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/kpatch/0.3.2-1ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in kpatch (Ubuntu):
status: In Progress → Fix Committed
Changed in kpatch (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kpatch - 0.3.2-1ubuntu5

---------------
kpatch (0.3.2-1ubuntu5) yakkety; urgency=medium

  * Use debian/rules to build the kernel (LP: #1578661)
  * During kernel builds, generate output when not in debug mode to
    prevent builders timing out due to the build appearing hung (LP: #1570012)

 -- Benjamin M Romer <email address hidden> Wed, 04 May 2016 12:49:33 -0400

Changed in kpatch (Ubuntu):
status: Fix Committed → Fix Released
Ben Romer (bromer) wrote :

Tested, looks good here.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kpatch - 0.3.2-1ubuntu4.1

---------------
kpatch (0.3.2-1ubuntu4.1) xenial; urgency=medium

  * Use debian/rules to build the kernel (LP: #1578661)
  * During kernel builds, generate output when not in debug mode to
    prevent builders timing out due to the build appearing hung (LP: #1570012)

 -- Benjamin M Romer <email address hidden> Wed, 04 May 2016 12:49:33 -0400

Changed in kpatch (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for kpatch has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in kpatch (Ubuntu Xenial):
importance: Undecided → Wishlist
Changed in kpatch (Ubuntu):
milestone: xenial-updates → none
Changed in kpatch (Ubuntu Xenial):
milestone: none → xenial-updates
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers