Ubiquity prompting for step 5 in --automatic mode on Ubuntu MID RC image

Bug #287857 reported by Emmet Hikory on 2008-10-23
6
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
kourou (Ubuntu)
High
Unassigned
Intrepid
High
Unassigned

Bug Description

Binary package hint: ubiquity

Ubiquity 1.10.7 prompts the user for step 5 (name, username, password, hostname, auto-login) when run from the .desktop file with the following preseed file:

d-i passwd/user-fullname string Ubuntu MID User
d-i passwd/username string ubuntu
d-i passwd/allow-password-empty boolean true
d-i passwd/user-password password
d-i passwd/user-password-again password
d-i netcfg/get_hostname string ubuntu
d-i mirror/http/hostname string ports.ubuntu.com
d-i mirror/http/directory string /ubuntu-ports
d-i mirror/suite string intrepid

When run from the command line, the expected behaviour is seen. Further, adding --debug to the .desktop file does not appear to produce debug output.

Emmet Hikory (persia) on 2008-10-23
description: updated
Emmet Hikory (persia) on 2008-10-23
Changed in ubiquity:
importance: Undecided → High
Changed in kourou:
milestone: none → ubuntu-8.10

The cause of this bug is that kourou is not passing the arguments provided in the Exec: block of the .desktop file to the launched application. As a result, ubiquity is not being launched with the --automatic option, although the .desktop file clearly indicates this is the correct behaviour.

This was verified by modifying .desktop files for other applications with arguments and noting that the arguments were ignored on launch. Once kourou honours arguments, ubiquity should just work.

Changed in kourou:
status: New → Triaged
Emmet Hikory (persia) wrote :

Suggested Release Note / Errata:

Ubuntu MID:

When performing an install from the Ubuntu MID image, the installer will prompt for a username. The username must be "ubuntu", if the username is changed from "ubuntu", X will not start on the installed system

Loïc Minier (lool) wrote :

I *think* it's because kourou didn't know how to handle %u %U etc.

Loïc Minier (lool) wrote :

I think the exact command which should be run is:
ubiquity --automatic --desktop /usr/share/applications/ubiquity-gtkui.desktop gtkui

Steve Langasek (vorlon) wrote :

documented at <https://wiki.ubuntu.com/IntrepidIbex/TechnicalOverview#Known%20Issues>. (not at <https://wiki.ubuntu.com/IntrepidReleaseNotes>, because this is intended to be resolved before final release.)

Changed in ubuntu-release-notes:
status: New → Fix Released
Loïc Minier (lool) wrote :

Could someone please test the bzr branch at lp:~lool/kourou/desktop-entry-spec ?

Thanks

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kourou - 0.8-0ubuntu1

---------------
kourou (0.8-0ubuntu1) intrepid; urgency=low

  * New upstream release.
    - Fixes how ubiquity is called. (LP: #287857)

 -- Steve Kowalik <email address hidden> Fri, 24 Oct 2008 12:20:38 +1100

Changed in kourou:
status: Triaged → Fix Released
Steve Kowalik (stevenk) wrote :

Tested, merged, commited, pushed, etc. Uploaded, waiting for -release to approve it.

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers