UVFe ( main ) for konversation 1.0 to 1.0.1

Bug #64488 reported by Brandon Holtsclaw on 2006-10-07
6
Affects Status Importance Assigned to Milestone
konversation (Ubuntu)
Undecided
Unassigned

Bug Description

Upstream Changelog from 1.0 to 1.0.1 bugfix only release

Changes in 1.0.1:

    * A bug that caused left-to-right text contained in lines determined to be right-to-left text to appear reversed has been fixed.
    * Whether a line is treated as right-to-left vs. left-to-right text is now determined by the amount of each type of character in the line, improving the user experience in chats involving bi-directional text considerably.
    * The "Edit Network" dialog has been refined for clarity and ease of use.
    * A warning dialog to prevent accidentally quitting Konversation has been added.
    * The Auto Replace list can now be sorted.
    * The '/media' script command now sports improved player recognition, enhanced and easier configurability, the ability to distinguish between audio and video media as well as newly added support for kdetv. New '/audio' and '/video' command aliases have been added to expose these new abilities.
    * The lower boundary of the default DCC port range has been raised from 1025 to 1026 to avoid conflicts with the commonly blocked Windows RPC port 1025.
    * Dismissing an OSD notification by clicking on it will now also cancel the systray notification flash.
    * A new configuration file option [OSD]OSDCheckDesktopLock has been added, allowing to manually disable the screensaver check in non-KDE environments that do not support it, causing the OSD not to be displayed.
    * A bug that could lead to the "Switch to" sub-menu in the context menus of tabs not to be updated properly upon switching tabs has been fixed.
    * A bug that caused the 'irc setBack' DCOP call not to function has been fixed.
    * A bug that caused ampersands in the names of tabs not to be displayed and an immediately following character to be used as keyboard accelerator has been fixed.
    * A bug that caused ignoring nicknames with '[' or ']' characters in them to fail has been fixed.
    * Command aliases containing regular expression syntax can no longer cause built-in commands not to function.
    * A bug that caused the Konversation irc:// protocol handler not to function
    * has been fixed. Its compatibility with systems that do not use the GNU bash shell as default shell has been improved. A notable number of code quality improvements suggested by KDEs automated quality control service EBN have been implemented.

On Fri, Oct 06, 2006 at 11:50:55PM -0500, Brandon Holtsclaw wrote:
> Can you please approve this UVFe ,its all bug fixes
> info all attached to the bug, thanks
> https://launchpad.net/distros/ubuntu/+source/konversation/+bug/64488

Several of these changes are not simple bug fixes, including:

* The "Edit Network" dialog has been refined for clarity and ease of use.

* The '/media' script command now sports improved player recognition,
  enhanced and easier configurability, the ability to distinguish between
  audio and video media as well as newly added support for kdetv. New
  '/audio' and '/video' command aliases have been added to expose these new
  abilities.

* A new configuration file option [OSD]OSDCheckDesktopLock has been added,
allowing to manually disable the screensaver check in non-KDE environments
that do not support it, causing the OSD not to be displayed.

In particular, some of these may involve string changes, which are to be
avoided at this point in the freeze.

--
 - mdz

Hein (sho) wrote :

Konversation did not leave string freeze between 1.0 and 1.0.1. In fact, translation coverage is much improved, with eight new languages in the tarball and a higher coverage percentage for many other translations.

Hein (sho) wrote :

(Addendum for clarity: "did not leave string freeze" means that the application was in string freeze the whole time.)

Matt Zimmerman (mdz) wrote :

The above changelog is the only information I have to go on, and since this is clearly not a pure bugfix release and the extent of the changes are not apparent, I can't approve this

Hein (sho) wrote :

Well, you have my statements to go on, me being one of the maintainers and developers of the application in question and in frequent communication with both Jonathan Riddell and Brandon Holtsclaw.

We enjoy a great working relationship with Kubuntu. Konversation is installed as part of its default package selection. We align our release schedule with Kubuntu's. They do build tests and binary nightlies for us. Given this strong relationship, it would be a shame if Kubuntu 6.10 did not ship with the best version of Konversation available, which includes key improvements for the international user community in the form better bi-directional text support and greatly increased translation coverage.

On Wed, Oct 11, 2006 at 05:52:22PM -0000, Eike Hein wrote:
> Well, you have my statements to go on, me being one of the maintainers
> and developers of the application in question and in frequent
> communication with both Jonathan Riddell and Brandon Holtsclaw.
>
> We enjoy a great working relationship with Kubuntu. Konversation is
> installed as part of its default package selection. We align our release
> schedule with Kubuntu's. They do build tests and binary nightlies for
> us. Given this strong relationship, it would be a shame if Kubuntu 6.10
> did not ship with the best version of Konversation available, which
> includes key improvements for the international user community in the
> form better bi-directional text support and greatly increased
> translation coverage.

I have written some documentation at
https://wiki.ubuntu.com/TimeBasedReleases which explains how our time-based
release process works, and why we have a freeze process.

We also have a documented process for requesting freeze exceptions here:
https://wiki.ubuntu.com/MOTU/Processes/UVF

To have a release schedule aligned with Kubuntu's would mean that feature
development concluded on 7th September, and that only important bug fixes
were being made at this time. There is much more to the release process
than pushing in new packages before the final release date.

--
 - mdz

Hein (sho) wrote :

> To have a release schedule aligned with Kubuntu's would mean that feature
> development concluded on 7th September, and that only important bug fixes
> were being made at this time.

By "release schedule aligned with Kubuntu's" I was referring to the Konversation 0.19 and 1.0 releases, which were successfully scheduled and executed to happen in time for Kubuntu Breezy and Dapper, respectively (see http://konversation.kde.org/wiki/Release_Schedule for details), in conference with Kubuntu's Jonathan Riddell and Brandon Holtsclaw. We are very happy both goals were met. We consider Kubuntu/Ubuntu one of the premier distributions carrying our software.

Konversation 1.0.1 is a maintenance release for Konversation 1.0, which is limited to refinements and bugfixes. Where new functionality was introduced, such as in the media script or the new config file option allowing to successfully use the Konversation OSD in Gnome and XFce, they have no impact on i18n. The "Edit Network" dialog refinement involves a redistribution of interface elements, and no string additions. One of our goals for the 1.0.1 maintenance release was to be mindful of changes that would prevent distributions - including Kubuntu - from replacing 1.0 with 1.0.1, i.e. not do such changes. Considering we explicitly highlight i18n improvements in the changelog, we obviously care about the issue. As a result, Konversation is one of the applications with the best translation coverage in the KDE Extragear module, given the amount of strings.

Again, the timing for this maintenance release was worked out in conference with Kubuntu. We were told that the UFVe was a formality of the process and the word "guaranteed" was used.

The bottom line is this: I understand and respect that Ubuntu is wary of putting in a new version of an application into the tree two weeks before a release. It's because you care about stability and the experience your users are going to have. So do we. And this release was executed with that very much on mind.

Matt Zimmerman (mdz) wrote :
Download full text (4.4 KiB)

On Wed, Oct 11, 2006 at 06:30:38PM -0000, Eike Hein wrote:
> Konversation 0.19 and 1.0 releases, which were successfully scheduled
> and executed to happen in time for Kubuntu Breezy and Dapper,
> respectively (see http://konversation.kde.org/wiki/Release_Schedule for
> details), in conference with Kubuntu's Jonathan Riddell and Brandon
> Holtsclaw. We are very happy both goals were met. We consider
> Kubuntu/Ubuntu one of the premier distributions carrying our software.

I am very pleased to see this level of coordination, and to hear that it was
successfully executed for 1.0. However, 1.0.1 seems to diverge from it by
adding new features which require testing and may require further bug fixes.
It is a critical feature of our release process that after a certain point,
we monotonically decrease the number of bugs by ceasing to add new code and
fixing bugs in the code we have.

> Konversation 1.0.1 is a maintenance release for Konversation 1.0, which
> is limited to refinements and bugfixes. Where new functionality was
> introduced, such as in the media script or the new config file option
> allowing to successfully use the Konversation OSD in Gnome and XFce,
> they have no impact on i18n. The "Edit Network" dialog refinement
> involves a redistribution of interface elements, and no string
> additions. One of our goals for the 1.0.1 maintenance release was to be
> mindful of changes that would prevent distributions - including Kubuntu
> - from replacing 1.0 with 1.0.1, i.e. not do such changes. Considering
> we explicitly highlight i18n improvements in the changelog, we obviously
> care about the issue. As a result, Konversation is one of the
> applications with the best translation coverage in the KDE Extragear
> module, given the amount of strings.

Thank you for the additional detail. However, our current state of freeze
restricts much more than just string changes, and based on the information I
have available, several of the changes in 1.0.1 do not seem to meet the
current freeze criteria. Therefore, I am curious what criteria you used
when determining what would prevent distributions (including Kubuntu) from
updating to 1.0.1, given that Kubuntu is now in beta and the release
candidate freeze begins tomorrow. Did you receive guidance from Jonathan
and Brandon?

> Again, the timing for this maintenance release was worked out in
> conference with Kubuntu. We were told that the UFVe was a formality of
> the process and the word "guaranteed" was used.

I apologize on behalf of whomever provided that misinformation; this is not
the case at all. We are in the final stages of preparing the release, and
we absolutely do not accept new upstream releases without due consideration.
We begin to prepare CD images for the release candidate very soon, and to
find a regression in konversation at that point would cause the CD image
testing process to be aborted while we fix the problem and build a
completely new set of images, a process which can take half a day or more.

I've tried to explain in TimeBasedReleases why we have deadlines well in
advance of the final release date. Let's say that you released a 1.0.2 on
October 25th: even though Kubun...

Read more...

Hein (sho) wrote :

> Therefore, I am curious what criteria you used when determining what
> would prevent distributions (including Kubuntu) from updating to 1.0.1

1) Don't break string freeze.
2) No dependency changes.
3) Sucessful build tests on the same fairly large variety of platforms and systems that 1.0 underwent (Linux, Mac OS X, FreeBSD; gcc 3.4 - 4.2; KDE 3.4 and 3.5; x86, amd64 and PPC -- some of those tests were done by Kubuntu personnel and therefore on Kubuntu systems, including Edgy).
4) Peer-review all code changes.
5) Confirm bugfixes with the original reporters, where available (example: the aforementioned 'media' script failing to connect to Amarok when the Amarok ReplayGain third-party add-on was installed was reported by CVS-Digest.org author Danny Allen and fixed to his satisfaction).

> However, bear in mind that if you discover a problem with 1.0.1, you solve
> it quickly and easily by testing and releasing a 1.0.2 tarball.

There's no doubt that the scope of the release preperations for a distribution is larger vs. a single application. Since we don't exactly just tar it up and push it out without thinking twice either (as outlined above), I'm aware of the penalty incurred by having to abort and restart the process, albeit on a smaller scale. FWIW, there have been no new defect reports since the release of 1.0.1 on October 6th in our own bugtracking system (KDEs Bugzilla) nor in our IRC channel (a fairly popular feedback medium considering it's an IRC client). Note that there were five weeks between 1.0 and 1.0.1; 1.0.1 was not rushed.

> I hope that I've adequately explained the need to be conservative in making
> changes to the distribution at such a late hour.

You have, and I am certainly understanding of your position. There won't be any hurt feelings if Kubuntu 6.10 ships without Konversation 1.0.1 on our end; Konversation 1.0 is a fine and mature piece of software. Konversation 1.0.1, however, is better software in the aspects listed in the initial report, and my persistence is motivated by the belief that it can provide a significantly better experience to Kubuntu users.

As for the format of this exeption request not conforming to Kubuntu/Ubuntu regulations, that is unfortunately beyond my control. What I can do is provide information about the release.

Hein (sho) wrote :

(Oops, forgot to list a critera: '6) No changes to the preferences file format to not interfere with distro customizations.')

Brandon Holtsclaw (imbrandon) wrote :
Brandon Holtsclaw (imbrandon) wrote :

Diffstat atached, along with upstreams comments on the diffstat

http://www.eikehein.com/diffstat.txt

also Riddell's comment from the dev meeting :

[11:43] <Riddell> mdz: yes, it would be good to have
[11:43] <mdz> Riddell: would be good to have, or is important for the release?
[11:45] <Riddell> mdz: it's important mostly to fix right to left language support, otherwise updated translations and bugfixes are just good to have

Brandon Holtsclaw (imbrandon) wrote :

also note this would close all malone bugs for konversation AND no new bugs have been opened in KDE BTS since release

Matt Zimmerman (mdz) wrote :

If you (Jonathan, Brandon and Eike) are confident enough in this release to forego the possibility of a subsequent update prior to the final Ubuntu release, then I'll grant an exception on that basis. I think this is an accurate way to characterize the situation that we'll be in.

If you're all comfortable with those terms, then go ahead.

Hein (sho) wrote :

We have no plans to release a 1.0.2 release any time soon, nor see any reason to based on our current situation, which is as follows: No further defects have been reported in our bug tracking system, nor reported on our IRC channel, nor discovered by us. In fact, there have been no code changes in this branch of Konversation since the release of 1.0.1. All currently ongoing work is targeted at a major functionality release several months from now, possibly for KDE 4.

Bottom line, yup, we'd be very comfortable with those terms, and extremely happy if Kubuntu 6.10 ships Konversation 1.0.1.

Changed in konversation:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments