kompozer version 1:0.8~b3.dfsg.1-0.1ubuntu1 FTBFS on armhf in precise

Bug #935214 reported by Andreas Moog on 2012-02-18
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kompozer (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

This is a semi-automatic report based on the latest archive rebuild results [1].
Apologies if it reaches you in error.

Excerpt from the buildlog:

{standard input}:326: Error: thumb conditional instruction should be in IT block -- `ldmleia sp,{r1,r2,r3}'
{standard input}:327: Error: thumb conditional instruction should be in IT block -- `addle sp,sp,r4'
{standard input}:328: Error: thumb conditional instruction should be in IT block -- `movle r4,#0'
make[9]: *** [xptcinvoke_arm.o] Error 1
make[9]: Leaving directory `/build/buildd/kompozer-0.8~b3.dfsg.1/obj-kompozer/xpcom/reflect/xptcall/src/md/unix'
make[8]: *** [libs] Error 2
make[8]: Leaving directory `/build/buildd/kompozer-0.8~b3.dfsg.1/obj-kompozer/xpcom/reflect/xptcall/src/md'
make[7]: *** [libs] Error 2
make[7]: Leaving directory `/build/buildd/kompozer-0.8~b3.dfsg.1/obj-kompozer/xpcom/reflect/xptcall/src'
make[6]: *** [libs] Error 2
make[6]: Leaving directory `/build/buildd/kompozer-0.8~b3.dfsg.1/obj-kompozer/xpcom/reflect/xptcall'
make[5]: *** [libs] Error 2
make[5]: Leaving directory `/build/buildd/kompozer-0.8~b3.dfsg.1/obj-kompozer/xpcom/reflect'
make[4]: *** [libs] Error 2
make[4]: Leaving directory `/build/buildd/kompozer-0.8~b3.dfsg.1/obj-kompozer/xpcom'
make[3]: *** [tier_2] Error 2
make[3]: Leaving directory `/build/buildd/kompozer-0.8~b3.dfsg.1/obj-kompozer'
make[2]: *** [default] Error 2
make[2]: Leaving directory `/build/buildd/kompozer-0.8~b3.dfsg.1/obj-kompozer'
make[1]: *** [build] Error 2
make[1]: Leaving directory `/build/buildd/kompozer-0.8~b3.dfsg.1/mozilla'
make: *** [build-stamp] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20120211-0848
FAILED [dpkg-buildpackage died]

The full buidlog can be found at https://launchpad.net/ubuntu/+archive/test-rebuild-20120201/+build/3152879/+files/buildlog_ubuntu-precise-armhf.kompozer_1:0.8~b3.dfsg.1-0.1ubuntu1_FAILEDTOBUILD.txt.gz.

[1] http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20120201-precise.html

Related branches

Andreas Moog (ampelbein) on 2012-02-18
Changed in kompozer (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kompozer (Ubuntu):
status: New → Confirmed
tags: added: arm-porting-queue
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kompozer - 1:0.8~b3.dfsg.1-0.1ubuntu2

---------------
kompozer (1:0.8~b3.dfsg.1-0.1ubuntu2) precise; urgency=low

  * Add -Wa,-mimplicit-it=thumb on ARM to work around lack of IT
    instructions in inline assembly (LP: #935214).
 -- Colin Watson <email address hidden> Tue, 24 Apr 2012 14:37:56 +0100

Changed in kompozer (Ubuntu Precise):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers