Please remove kompozer from quantal

Bug #1065547 reported by Micah Gersten
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
kompozer (Ubuntu)
Fix Released
Wishlist
Unassigned

Bug Description

kompozer upstream is dead and the last Debian maintainer upload was in 2010, I don't think this package is worth putting any effort into at this point. In addition, the xulrunner codebase beneath is it surely out of date and full of security holes.

This package also currently fails to build in quantal, sid, and wheezy

Micah Gersten (micahg)
Changed in kompozer (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
description: updated
Revision history for this message
Micah Gersten (micahg) wrote :

Per IRC, blacklisting seems like overkill, if it comes back in R, hopefully it'll be fixed...

summary: - Please remove kompozer from quantal and blacklist
+ Please remove kompozer from quantal
Revision history for this message
Scott Kitterman (kitterman) wrote :

Removing packages:
        kompozer 1:0.8~b3.dfsg.1-0.1ubuntu3 in quantal
                kompozer 1:0.8~b3.dfsg.1-0.1ubuntu3 in quantal amd64
                kompozer 1:0.8~b3.dfsg.1-0.1ubuntu3 in quantal armel
                kompozer 1:0.8~b3.dfsg.1-0.1ubuntu3 in quantal armhf
                kompozer 1:0.8~b3.dfsg.1-0.1ubuntu3 in quantal powerpc
Comment: Dead upstream, FTBFS, lp: #1065547
Remove [y|N]? y
1 package successfully removed.

Not blacklisting per discussion on IRC.

Changed in kompozer (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Ferry Toth (ftoth) wrote :

I don't follow this reasoning.

Now because of upgrading from Precise to Quantal there is no WYSIWYG web authoring tool at all.

Please build this package for Quantal or suggest an equivalent.

Ferry

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

@Ferry

It fails to build from source on quantal, hence we cannot build it... if you can fix it, it would be great.

Revision history for this message
Ferry Toth (ftoth) wrote :

Well, maybe there is something wrong with the build envirnment then.

I just installed kompozer and kompozer-data from precise in quantal and it seem to just work.

So that means the package can be built (in precise) and the built packages work (in quantal). Isn't it just a packaging error?

PS I admit I just did a quick check to see if it starts and displays a html page. There may be of course bugs now that didn't exist in precise. But the bugs that were already there didn't stop me from using the package. I think it is probably the best free WYSIWYG html editor for linux, and possibly even better then what can you find for windows.

That development has stopped doesn't mean it is not good, it can also mean there is nothing more to do.

Ferry

Revision history for this message
Micah Gersten (micahg) wrote :

This is abandoned software (upstream hasn't done anything for the past 2 years). This means that bugs won't be fixed and security updates to the underlying xul engine won't be applied. Debian has removed this as well. If you're looking for a WYSIWYG HTML editor, there's gwrite.

Revision history for this message
Dimitri John Ledkov (xnox) wrote : Re: [Bug 1065547] Re: Please remove kompozer from quantal

On 2 November 2012 17:32, Ferry Toth <email address hidden> wrote:
> Well, maybe there is something wrong with the build envirnment then.
>

No. The source is no longer compatible with the current xulruner and
fails to compile.
https://launchpadlibrarian.net/117640906/buildlog_ubuntu-quantal-i386.kompozer_1%3A0.8~b3.dfsg.1-0.1ubuntu2_FAILEDTOBUILD.txt.gz

http://qa.ubuntuwire.com/ -> archive test rebuilds ->
http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20120922-quantal.html

Regards,

Dmitrijs.

Revision history for this message
Ferry Toth (ftoth) wrote :

@Micah Like I said, who cares if bugs won't be fixed as long as it works reasonably now. And I am not using Debian right now, so really I don't care what they removed.

Thanks for the suggestion to use gwrite. But like the description says it is a 'simple GTK+ HTML5 WYSIWYG editor'. I'm missing the split wysiwyg/html screen.

For now I'm staying with kompozer as I successfully manually installed from precise.

@Dmitrijs Yeah I did get that. What I mean is: once compiled (in precise), there don't seem to be any missing dependencies when installing in quantal. And I don't see any crashes caused by libraries being incompatible. So, it should be possible to build in quantal without modifying sources right?

Revision history for this message
Manfred Hampl (m-hampl) wrote :
Download full text (3.2 KiB)

The problem for FTBFS seems that gcc 4.7 and higher no more accepts some 'dirty' socurce code that previous versions accepted for compilation.

see also http://gcc.gnu.org/onlinedocs/gcc/Name-lookup.html
and http://stackoverflow.com/questions/10639053/name-lookups-in-c-templates

from the failed build log of kompozer:

In file included from /build/buildd/kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsINIParser.h:47:0,
                 from /build/buildd/kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsINIParser.cpp:41:
/build/buildd/kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsClassHashtable.h: In instantiation of 'PRBool nsClassHashtable<KeyClass, T>::Get(nsClassHashtable<KeyClass, T>::KeyType, T**) const [with KeyClass = nsDepCharHashKey; T = nsINIParser::INIValue; PRBool = int; nsClassHashtable<KeyClass, T>::KeyType = const char*]':
/build/buildd/kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsINIParser.cpp:227:45: required from here
/build/buildd/kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsClassHashtable.h:101:18: error: 'GetEntry' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
/build/buildd/kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsClassHashtable.h:101:18: note: declarations in dependent base 'nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >' are not found by unqualified lookup
/build/buildd/kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsClassHashtable.h:101:18: note: use 'this->GetEntry' instead

In file included from /build/buildd/kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsClassHashtable.h:41:0,
                 from /build/buildd/kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsINIParser.h:47,
                 from /build/buildd/kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsINIParser.cpp:41:
/build/buildd/kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsBaseHashtable.h: In instantiation of 'PRBool nsBaseHashtable<KeyClass, DataType, UserDataType>::Put(nsBaseHashtable<KeyClass, DataType, UserDataType>::KeyType, UserDataType) [with KeyClass = nsDepCharHashKey; DataType = nsAutoPtr<nsINIParser::INIValue>; UserDataType = nsINIParser::INIValue*; PRBool = int; nsBaseHashtable<KeyClass, DataType, UserDataType>::KeyType = const char*]':
/build/buildd/kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsINIParser.cpp:241:39: required from here
/build/buildd/kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsBaseHashtable.h:145:35: error: 'PutEntry' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
/build/buildd/kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsBaseHashtable.h:145:35: note: declarations in dependent base 'nsTHashtable<nsBaseHashtableET<nsDepCharHashKey, nsAutoPtr<nsINIParser::INIValue> > >' are not found by unqualified lookup
/build/buildd/kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsBaseHashtable.h:145:35: note: use 'this->PutEntry' instead

changing two lines should allow building in quantal (as long as this was the only problem/error):
kompozer-0.8~b3.dfsg.1/mozilla/xpcom/glue/nsClassHashtable.h line 101:
change 'GetEntry' to 'this-...

Read more...

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions