kword fails to start

Bug #381599 reported by Matt Joiner on 2009-05-29
46
This bug affects 3 people
Affects Status Importance Assigned to Milestone
koffice2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kword-kde4

got this after installing koffice-kde4 after version 2 was backported to jaunty.

kword(4147) KServiceFactory::findServiceByDesktopPath: "findServiceByDesktopPath: kwordpart.desktop not found"
kword(4147) KServiceFactory::findServiceByDesktopPath: "findServiceByDesktopPath: Office/kword.desktop not found"

Janus (ysangkok+launchpad) wrote :

i think i resolved this by removing the kpresenter-data package (which belongs to koffice 1.x). apparrently there is a conflict.

Matt Joiner (anacrolix) wrote :

I didn't have kpresenter-data installed in the first place.

ehcpdeveloper (ehcpdeveloper) wrote :

same situation:

bvidinli@bvidinli-yenihdd:~$ kplato
kplato(1638) KServiceFactory::findServiceByDesktopPath: "findServiceByDesktopPath: kplatopart.desktop not found"
kplato(1638) KServiceFactory::findServiceByDesktopPath: "findServiceByDesktopPath: Office/kplato.desktop not found"
bvidinli@bvidinli-yenihdd:~$ kword
kword(1639) KServiceFactory::findServiceByDesktopPath: "findServiceByDesktopPath: kwordpart.desktop not found"
kword(1639) KServiceFactory::findServiceByDesktopPath: "findServiceByDesktopPath: Office/kword.desktop not found"
bvidinli@bvidinli-yenihdd:~$

i have no kpresenter-data installed.

emanuel indermühle (e-i) wrote :

I can confirm this bug. I get the same output as mentioned before.

My system:
- Ubuntu Jaunty 64bit
- no kpresenter-data installed

emanuel indermühle (e-i) wrote :

The workaround mentioned in Bug #185551:

"rm /var/tmp/kdecache-$USER/ksycoca4"

solved the problem for me

Harald Sitter (apachelogger) wrote :

Just wondering ... does this issue continue to exist after a reboot?
Also, did you upgrade from some pre-release (alpha, beta...) or was it a new install of koffice2?

The thing is that kbuildsycoca4 (which would basically do what removing ksycoca4 causes) is run everytime a file changes as well as every couple of minutes to catch new files. Taking this into account the issue should be resolved in a matter of seconds after an upgrade and in a matter of minutes after a new install. In any case it should resolve after a reboot or login because kbuildsycoca4 is always executed by the script responsible for KDE's startup.

I can really only think of 2 reasons why this would fail:
1. kbuildsycoca4 fails to parse the desktop files (i.e. there is some wrong format present)
2. ksycoca4 is broken due to previous parsing problems (in earlier version of koffice[2]) or due to some other screwup

Changed in koffice2 (Ubuntu):
status: New → Incomplete
Matt Joiner (anacrolix) wrote :

I first installed Jaunty from the RC, and upgraded since. The problem seems to have gone away now.

i am already using jaunty, and problem continues, re-tried, same...

On Mon, Jun 8, 2009 at 8:45 AM, Matt Joiner<email address hidden> wrote:
> I first installed Jaunty from the RC, and upgraded since. The problem
> seems to have gone away now.
>
> --
> kword fails to start
> https://bugs.launchpad.net/bugs/381599
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Harald Sitter (apachelogger) wrote :

Well, lets try something else then.

Run

  kdebugdialog

and make sure everything is turned on. Then run

  kbuildsycoca4 > sycoca.log 2>&1

that will create a file named sycoa.log, please attach it to this bug.
If the problem is that kbuildsycoca4 fails to parse something, then it should show up in the log. If it is not, then we have quite a drag at our hands :D

Harald Sitter (apachelogger) wrote :

Looking through the packages. It seems that the following is possible, however highly unlikely:
kwordpart.desktop and kwordpart.so are in different packages, so if the former gets installed before the latter, kbuildsycoca might, or might not, fail to add kwordpart to the database (because obviously the library is missing anyway). Judging from earlier encounters with sycoca weirdness this seems rather impossible because from what I know, kbuildsycoca4 will add the part no matter whether there is a library or not, only at actual application runtime it will become noticed and treated (we can see this for example in system settings when the case desktopfile-avail-lib-unavail applies).

Other than that I can hardly imagine anything that could cause this issue packaging wise. So, if someone could go check over at http://bugs.kde.org if KDE got a report for this (ultimately with reports from distributions other than Kubuntu/Ubuntu ;-)).

ehcpdeveloper (ehcpdeveloper) wrote :
  • sycoca.log Edit (136.9 KiB, text/x-log; charset=UTF-8; name="sycoca.log")

bvidinli@bvidinli-yenihdd:~$ kword
kword(22663) KServiceFactory::findServiceByDesktopPath:
"findServiceByDesktopPath: kwordpart.desktop not found"
kword(22663) KServiceFactory::findServiceByDesktopPath:
"findServiceByDesktopPath: Office/kword.desktop not found"
bvidinli@bvidinli-yenihdd:~$ kdebugdialog
bvidinli@bvidinli-yenihdd:~$ kdebugdialog
bvidinli@bvidinli-yenihdd:~$ kbuildsycoca4 > sycoca.log 2>&1
bvidinli@bvidinli-yenihdd:~$

bvidinli@bvidinli-yenihdd:~$ uname -a
Linux bvidinli-yenihdd 2.6.28-12-generic #43-Ubuntu SMP Fri May 1
19:27:06 UTC 2009 i686 GNU/Linux
bvidinli@bvidinli-yenihdd:~$

while debug is turned on, i tried to run kword, it started after print
on console enormous lines of debug messages. i saw kword interface, it
started..

But,
After having log, i re-run kdebugdialog, deselect all, applied,
then, i tried to start kword, it still prints debug messages... That
is, debug is not turned off.
I checked again in kdebugdialog that all turned off...

So, last status:
on command line: kword and kspread starts up by printing many log
messages, so, they startup very slow
from menu: they start very slow...

See you,

On Mon, Jun 8, 2009 at 10:36 AM, Harald Sitter<email address hidden> wrote:
> Well, lets try something else then.
>
> Run
>
>  kdebugdialog
>
> and make sure everything is turned on. Then run
>
>  kbuildsycoca4 > sycoca.log 2>&1
>
> that will create a file named sycoa.log, please attach it to this bug.
> If the problem is that kbuildsycoca4 fails to parse something, then it should show up in the log. If it is not, then we have quite a drag at our hands :D
>
> --
> kword fails to start
> https://bugs.launchpad.net/bugs/381599
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Harald Sitter (apachelogger) wrote :

Well, the debug is caused by an underlying library and probably deserves a seperate bug report.

But there is indeed something very wrong with your ksycoca4 (or rather - was).

Reading through the log you attached you will find a lot of lines saying "new:" or "modified:" each of those lines represents either a newly installed (in this case most importantly KOffice) or a updated .desktop file.

This is very concerning because it seems that something prevented your kbuildsycoca4 from being autoexecuted (or at least prevented it from storing its data afterwards). As far as I know this tool should be invoked by one of the most essential components of the KDE desktop, so I find it rather impossible that it didn't get run at all, which makes this whole issue a whole lot more weird.

Also, I'd like to mention that I failed to reproduce this issue on my almost-stock-jaunty installation. Jonathan Thomas is now going to try with a clean jaunty installation and KOffice 2.0.0.
It is indeed possible that whatever causes this issue is not present in Kubuntu 9.04 and/or KOffice 2.0.0.

Changed in koffice2 (Ubuntu):
status: Incomplete → Confirmed
ehcpdeveloper (ehcpdeveloper) wrote :

Maybe, maybe this issue does not exist in a clean Jaunty 9.04 installation.

My computer runs Ubuntu 9.04, which is upgraded from previous version.
This may not be seen as a clean install. Because this is an upgrade,
and I have many programs installed... What is interesting, I lived
same situation in another desktop computer who has not so much
software, only server components, such as apache, postfix, ehcp
(control panel) and so on..

Anyway, i think that, even somebody installs on a non-new Ubuntu or
similar distro, koffice or kword should handle those situations and
should clean up itself... This is a very generic situation, " i am
using an Ubuntu, and installing koffice.. " thats it..
By the way, other software on my desktop runs almost flawlesly... I
mean, the Ubuntu and other software is working good...

Thank you for your helps, i may do any other test if you wish...

Last status: kword-kspread still starts very slow...

see you...

On Mon, Jun 8, 2009 at 8:04 PM, Harald Sitter<email address hidden> wrote:
> Well, the debug is caused by an underlying library and probably deserves
> a seperate bug report.
>
> But there is indeed something very wrong with your ksycoca4 (or rather -
> was).
>
> Reading through the log you attached you will find a lot of lines saying
> "new:" or "modified:" each of those lines represents either a newly
> installed (in this case most importantly KOffice) or a updated .desktop
> file.
>
> This is very concerning because it seems that something prevented your
> kbuildsycoca4 from being autoexecuted (or at least prevented it from
> storing its data afterwards). As far as I know this tool should be
> invoked by one of the most essential components of the KDE desktop, so I
> find it rather impossible that it didn't get run at all, which makes
> this whole issue a whole lot more weird.
>
> Also, I'd like to mention that I failed to reproduce this issue on my almost-stock-jaunty installation. Jonathan Thomas is now going to try with a clean jaunty installation and KOffice 2.0.0.
> It is indeed possible that whatever causes this issue is not present in Kubuntu 9.04 and/or KOffice 2.0.0.
>
> ** Changed in: koffice2 (Ubuntu)
>       Status: Incomplete => Confirmed
>
> --
> kword fails to start
> https://bugs.launchpad.net/bugs/381599
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Nameless (nameless-oleco) wrote :
Download full text (4.2 KiB)

I'm using Ubuntu 9.04 (upgraded from 8.10) and have the same problem.
No kpresenter-data package is installed, but krita-kde4 ("upgraded" from krita 1.x) fails to start, too.

***@Gremlin:~$ krita
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 0 CFGSimplification
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 1 IPConstantPropagation
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 2 InstructionCombining
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 3 CFGSimplification
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 4 TailDuplication
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 5 CFGSimplification
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 6 InstructionCombining
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 7 Reassociate
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 8 InstructionCombining
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 9 TailCallElimination
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 10 CFGSimplification
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 11 LICM
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 12 InstructionCombining
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 13 IndVarSimplify
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 14 LoopUnroll
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 15 InstructionCombining
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 16 LoadValueNumbering
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 17 GCSE
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 18 SCCP
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 19 InstructionCombining
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 20 DeadStoreElimination
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 21 AggressiveDCE
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 22 CFGSimplification
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 23 ConstantMerge
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 24 CFGSimplification
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 25 PromoteMemoryToRegister
GTLCore (Debug): in Optimiser_p.cpp at 111 in GTLCore::Optimiser::Private::setLevel: 26 InstructionCombining
GTLCore (Debug): in Type.cpp at 104 in GTLCore::Type::Type: Create type for 0
GTLCore (Debug): in Type.cpp at 104 in GTLCore::Type::Type: Create type for 1
GTLCore (Debug): in Typ...

Read more...

Harald Sitter (apachelogger) wrote :

Incredibly weird bug, no doubt on that. But I think we still can assume that it does not appear in 9.04 final (even when upgraded to KO 2.0.0).

Anyway let's try to pursue the theory about kbuildsycoca4 not being invoked at all. Those that are still affected by this bug: please run
kdebudialog
and activate all debugging, logout and back in again, use KDE for some time (maybe install a KDE app etc.)
then run
grep -r -i 'sycoca' $HOME/.xsession-errors > file
that should spit out a file called 'file' which should contain the debug output related to ksycoca. With a bit of luck it might give us a clue as to why the cache doesn't want to detect the kpart desktop file.

Changed in koffice2 (Ubuntu):
status: Confirmed → Incomplete
Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in koffice2 (Ubuntu):
status: Incomplete → Invalid
Changed in koffice2 (Ubuntu):
status: Invalid → New
Mikael Bergqvist (mikaelb) wrote :

I ran into this bug after a fresh install of Karmic Koala followed by an install of koffice-kde4.
Tried the suggested workaround above, "rm rm /var/tmp/kdecache-$USER/ksycoca4".
Thereafter it was possible to start kword.
Reopened the bug since many people will be in the same situation. A fresh install, followed by a fresh install of koffice-kde4.

Harald Sitter (apachelogger) wrote :

Repost of #15
Incredibly weird bug, no doubt on that. But I think we still can assume that it does not appear in 9.04 final (even when upgraded to KO 2.0.0).

Anyway let's try to pursue the theory about kbuildsycoca4 not being invoked at all. Those that are still affected by this bug: please run
kdebudialog
and activate all debugging, logout and back in again, use KDE for some time (maybe install a KDE app etc.)
then run
grep -r -i 'sycoca' $HOME/.xsession-errors > file
that should spit out a file called 'file' which should contain the debug output related to ksycoca. With a bit of luck it might give us a clue as to why the cache doesn't want to detect the kpart desktop file.

And closing again, since yet again I did not get the information requested. This is so not going to be fixed if everyone just keeps working around the issue instead of helping me track it down.

Changed in koffice2 (Ubuntu):
status: New → Invalid
Risto H. Kurppa (risto.kurppa) wrote :

Changed the status back to confirmed. Bumped into this on Kubuntu 11.10 today.

kurppa@el-kone:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
kurppa@el-kone:~$ kword -v
Qt: 4.7.4
KDE Development Platform: 4.7.3 (4.7.3)
KWord: 2.3.3

kurppa@el-kone:~$ kword
kword(4375)/koffice (lib komain): "kword" part.desktop not found.

kword(4375)/koffice (lib komain): Run 'kde4-config --path services' to see which directories were searched, assuming kde startup had the same environment as your current shell.

kword(4375)/koffice (lib komain): Check your installation (did you install KOffice in a different prefix than KDE, without adding the prefix to /etc/kderc ?)

kurppa@el-kone:~$ rm /var/tmp/kdecache-$USER/ksycoca4
kurppa@el-kone:~$ kword
kbuildsycoca4 running...
[then plenty of messages]

And kword started.

Changed in koffice2 (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments