dapper f5: *.Xcf not correct in krita

Bug #35582 reported by Pascal d'Hermilly on 2006-03-19
12
Affects Status Importance Assigned to Milestone
koffice
Fix Released
Wishlist
koffice (Ubuntu)
Wishlist
Unassigned

Bug Description

When opening the *.xcf (native gimp format I believe) in kubuntu f5 livecd it opens in krita and is not displayed in other ways than a white space. It is shown in konqueror preview correctly.

Kenny Duffus (kduffus) on 2006-03-19
Changed in kubuntu-meta:
assignee: nobody → kubuntu-team
Ted Treadwell (ttread) wrote :

Confirmed. The gimp-ubuntu-splash.xcf file in the Examples folder is not handled correctly by Krita. Tested on Kubuntu Dapper Beta.

Didier Raboud (odyx) wrote :

Confirmed here too. This is "Major", because the files in ~/Examples _have_ to be read correctly.

Changed in kubuntu-meta:
status: Unconfirmed → Confirmed
lexual (lexhider) wrote :

http://bugs.kde.org/show_bug.cgi?id=106730

The above bug may be related to this one.
There is interesting discussion on that bug report about the *.xcf format.
Is the *.xcf really format the best choice for files in ~/Examples ?

lexual (lexhider) wrote :

from wikipedia (note: grain of salt) http://en.wikipedia.org/wiki/XCF

"The Gimp developers have deliberately not published a specification document for the XCF format, in an attempt to safeguard the possibility of doing minor format changes in future versions. Thus the souce code of the Gimp itself (which is freely available) is the only documentation of the format."

"There are very few programs besides the Gimp that are capable of writing XCF files, but some image viewers and conversion software can read the format with varying degrees of success::

How about we for now just let gwenview display the file?

Ted Treadwell (ttread) wrote :

This bug is still present in Kubuntu Edgy RC1. Perhaps we could use a simpler .xcf file that Krita can display correctly, or use Krita's native format .kra .

John Vivirito (gnomefreak) wrote :

Assigned to package koffice as that is source package for krita

Changed in koffice:
assignee: kubuntu-team → nobody
Jonathan Thomas (echidnaman) wrote :

Krita is no longer shipped by default, so bumping down the importance accordingly.

Changed in koffice:
importance: High → Low
Changed in koffice (Ubuntu):
importance: Low → Wishlist
status: Confirmed → Triaged
Jonathan Thomas (echidnaman) wrote :

Looks like we may get a fix for this with KOffice 2.2.

Changed in koffice:
status: Unknown → Confirmed
Changed in koffice:
status: Confirmed → Fix Released
Jonathan Thomas (echidnaman) wrote :

Fix committed for Krita 2.2.

Changed in koffice (Ubuntu):
status: Triaged → Fix Committed
Changed in koffice (Ubuntu):
status: Fix Committed → Fix Released
Changed in koffice:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.