Change font dependency to recommends

Bug #1685918 reported by Pander
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
kodi (Ubuntu)
Medium
Unassigned
Xenial
Undecided
Unassigned

Bug Description

In kodi-data is a hard dependency for fonts-noto-mono and for fonts-noto-hinted. Please, change both fromo Depends to Recommends.

Changing this allow for deinstallation of these two font packages, without breaking package dependencies in case these fonts are provided in another way via TeX Live installation. This mainly concerns Ubuntu users that use Tex Live, which are a lot, especially since Tex Live packages are still not up to date in Debian and Ubuntu.

Changing to Recommends allow users to solve font conflicts (in this case the availability of the same font twice) easily and this change in dependency has been done for several other packages for this reason in the last few years.

See also:
* https://bugs.launchpad.net/ubuntu/+source/birdfont/+bug/1593711
* https://bugs.launchpad.net/ubuntu/+source/libpdf-api2-perl/+bug/714588
* https://bugs.launchpad.net/ubuntu/+source/matplotlib/+bug/1593678

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kodi (Ubuntu):
status: New → Confirmed
Revision history for this message
Pander (pander) wrote :

See also bug report at Kodi https://trac.kodi.tv/ticket/17454

Revision history for this message
Pander (pander) wrote :

Kodi confirms that this is a dependency which is not required or added by them but added by the Debian packager. Hence, this is an action item for Ubuntu and Debian.

Rolf Leggewie (r0lf)
summary: - Change font dependency to recommendency
+ Change font dependency to recommendends
Changed in kodi (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
importance: Undecided → Medium
status: Confirmed → In Progress
Revision history for this message
Rolf Leggewie (r0lf) wrote : Re: Change font dependency to recommendends

I agree that I cannot see a reason that a font should be a hard dependency

Changed in kodi (Ubuntu):
assignee: Rolf Leggewie (r0lf) → nobody
milestone: none → ubuntu-18.04
Revision history for this message
Rolf Leggewie (r0lf) wrote :

same change for xenial

Revision history for this message
Simon Quigley (tsimonq2) wrote :

I'm uploading to Bionic for the sake of getting this in the LTS release, but please forward it to Debian as well.

I'd like an opinion from the SRU Team (and of course the usual SRU bug description modifications) before sponsoring to Xenial, so I'll unsubscribe the Sponsors team and subscribe the SRU team.

Thanks.

Changed in kodi (Ubuntu):
status: In Progress → Fix Committed
assignee: nobody → Rolf Leggewie (r0lf)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kodi - 2:17.6+dfsg1-1ubuntu1

---------------
kodi (2:17.6+dfsg1-1ubuntu1) bionic; urgency=medium

  * demote hard font dependencies from Depends to Recommends
    LP: #1685918

 -- Rolf Leggewie <email address hidden> Sun, 15 Apr 2018 10:24:45 +0800

Changed in kodi (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Pander (pander) wrote :

Thanks Rolf and Simon. There are a few other packages with hard dependencies on fonts. When I come across those again, I will propose demoting those too.

Pander (pander)
tags: added: bioinc
tags: removed: bioinc
Pander (pander)
Changed in kodi (Ubuntu Xenial):
status: New → Invalid
Rolf Leggewie (r0lf)
Changed in kodi (Ubuntu Xenial):
status: Invalid → Triaged
Revision history for this message
Rolf Leggewie (r0lf) wrote :

It looks like this fix was dropped when going to cosmic, reopening.

Changed in kodi (Ubuntu):
assignee: Rolf Leggewie (r0lf) → nobody
status: Fix Released → Triaged
milestone: ubuntu-18.04 → none
Pander (pander)
tags: added: focal groovy
removed: zesty
Revision history for this message
Pander (pander) wrote :

Seems like fixed in Focal

Changed in kodi (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Pander (pander) wrote :

Now other fonts have become a hard dependcy,

fonts-liberation | ttf-liberation, fonts-dejavu-core | ttf-dejavu-core

Please change these to Recommended

Changed in kodi (Ubuntu):
status: Fix Released → Confirmed
Rolf Leggewie (r0lf)
summary: - Change font dependency to recommendends
+ Change font dependency to recommends
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.