autopkgtest 'kdig' always fails

Bug #1886270 reported by Dan Streetman on 2020-07-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
knot (Ubuntu)
Undecided
Unassigned
Bionic
Low
Unassigned
Focal
Low
Unassigned

Bug Description

[impact]

kdig autopkgtest always fails on autopkgtest infrastructure, due to firewalling, and the test requires internet access

[test case]

check autopkgtest results:
http://autopkgtest.ubuntu.com/packages/knot

[regression potential]

any regression would likely result in incorrectly failed kdig test, or an incorrectly skipped kdig test on a testbed that does have internet access.

[scope]

this is fixed in g already, and needs fixing only in b and f. the knot package in x does not include autopkgtests so no change is needed there.

Dan Streetman (ddstreet) on 2020-07-04
Changed in knot (Ubuntu):
status: New → Fix Released
Changed in knot (Ubuntu Bionic):
assignee: nobody → Dan Streetman (ddstreet)
Changed in knot (Ubuntu Focal):
assignee: nobody → Dan Streetman (ddstreet)
importance: Undecided → Low
Changed in knot (Ubuntu Bionic):
importance: Undecided → Low
Changed in knot (Ubuntu Focal):
status: New → In Progress
Changed in knot (Ubuntu Bionic):
status: New → In Progress
tags: added: block-proposed-bionic block-proposed-focal

Hello Dan, or anyone else affected,

Accepted knot into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/knot/2.7.8-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in knot (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Changed in knot (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Brian Murray (brian-murray) wrote :

Hello Dan, or anyone else affected,

Accepted knot into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/knot/2.6.5-3ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Dan Streetman (ddstreet) wrote :

b/f autopkgtests all pass (or are neutral/skipped) now

(i386 autopkgtests still fail on f/g, but that's because of missing deps since i386 was removed as a main arch)

tags: added: verification-done verification-done-bionic verification-done-focal
removed: verification-needed verification-needed-bionic verification-needed-focal
Dan Streetman (ddstreet) on 2020-11-17
Changed in knot (Ubuntu Focal):
assignee: Dan Streetman (ddstreet) → nobody
Changed in knot (Ubuntu Bionic):
assignee: Dan Streetman (ddstreet) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers