Ubuntu

networkmanager does not detect GSM modem status correctly

Reported by nils on 2011-10-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
knetworkmanager
Unknown
Medium
knetworkmanager (Ubuntu)
Undecided
Unassigned

Bug Description

Description From nils 2011-10-03 07:27:59 (-) [reply]

Version: unspecified
OS: Linux

When traveling by high-speed train, the modem connects and disconnects often,
and switches from UMTS to GPRS etc. Often the reconnecting and switching works.

Sometimes the modem is not connected though (light on solid meaning there is a
network but no connection) and the network manager reports that it is still
connected.

Version: haven't tried it with the kubuntu beta, but older versions hat this
problem.

Reproducible: Always

Steps to Reproduce:
Connect the modem, travel by high speed train, wait :)

Actual Results:
KNM reports connection when there isn't one

Expected Results:
KNM recognised dropped connection and reconnects

KNM possibly needs to actively confirm the status from time to time? I assume
that events are lost somewhere when the connection state changes too
frequently.

A manual "Reconnect" option would be good to force the state.

Changed in knetworkmanager:
importance: Unknown → Medium
status: Unknown → New
Changed in knetworkmanager:
status: New → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.