Ubuntu

plasma network manager widget does not connect to UMTS net

Reported by nils on 2011-10-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
knetworkmanager
Fix Released
Medium
knetworkmanager (Ubuntu)
Undecided
Unassigned

Bug Description

Ive filed the bug here: https://bugs.kde.org/show_bug.cgi?id=283204

Heres the info:
after selecting the cell network to connect to, the network manager stops at
the "Waiting for authorization" stage. This happens every time, even though I
give it the PIN (twice, once before it asks if its OK to unlock the device,
once when I try to connect to the network).

WLAN works fine and connects automatically.

Heres the syslog:
Oct 2 21:55:26 padfoot64 modem-manager[1016]: <info> (ttyHS0) opening serial
port...
Oct 2 21:55:26 padfoot64 modem-manager[1016]: <info> Modem
/org/freedesktop/ModemManager/Modems/0: unlock no longer required
Oct 2 21:55:26 padfoot64 modem-manager[1016]: <info> Modem
/org/freedesktop/ModemManager/Modems/0: # unlock retries is 0
Oct 2 21:55:26 padfoot64 modem-manager[1016]: <info> (ttyHS0) closing serial
port...
Oct 2 21:55:26 padfoot64 modem-manager[1016]: <info> (ttyHS0) serial port
closed
Oct 2 21:55:42 padfoot64 modem-manager[1016]: <info> (ttyHS0) opening serial
port...
Oct 2 21:55:42 padfoot64 modem-manager[1016]: <info> Modem
/org/freedesktop/ModemManager/Modems/0: state changed (disabled -> enabling)
Oct 2 21:55:42 padfoot64 NetworkManager[1129]: <info> Activation (hso0)
starting connection 'o2online UMTS 3G pref.'
Oct 2 21:55:42 padfoot64 NetworkManager[1129]: <info> (hso0): device state
change: disconnected -> prepare (reason 'none') [30 40 0]
Oct 2 21:55:42 padfoot64 NetworkManager[1129]: <info> Activation (hso0) Stage
1 of 5 (Device Prepare) scheduled...
Oct 2 21:55:42 padfoot64 NetworkManager[1129]: <info> Activation (hso0) Stage
1 of 5 (Device Prepare) started...
Oct 2 21:55:42 padfoot64 NetworkManager[1129]: <info> (hso0): device state
change: prepare -> need-auth (reason 'none') [40 60 0]
Oct 2 21:55:42 padfoot64 NetworkManager[1129]: <info> Activation (hso0) Stage
1 of 5 (Device Prepare) complete.
Oct 2 21:55:42 padfoot64 modem-manager[1016]: <info> (ttyHS1) opening serial
port...
Oct 2 21:55:43 padfoot64 modem-manager[1016]: <info> Modem
/org/freedesktop/ModemManager/Modems/0: state changed (enabling -> enabled)
Oct 2 21:55:43 padfoot64 NetworkManager[1129]: <info> WWAN now enabled by
management service
Oct 2 21:55:43 padfoot64 modem-manager[1016]: <info> Modem
/org/freedesktop/ModemManager/Modems/0: state changed (enabled -> registered)
Oct 2 21:55:47 padfoot64 NetworkManager[1129]: <info> Activation (hso0) Stage
1 of 5 (Device Prepare) scheduled...
Oct 2 21:55:47 padfoot64 NetworkManager[1129]: <info> Activation (hso0) Stage
1 of 5 (Device Prepare) started...
Oct 2 21:55:47 padfoot64 NetworkManager[1129]: <info> (hso0): device state
change: need-auth -> prepare (reason 'none') [60 40 0]
Oct 2 21:55:47 padfoot64 NetworkManager[1129]: <info> (hso0): device state
change: prepare -> need-auth (reason 'none') [40 60 0]
Oct 2 21:55:47 padfoot64 NetworkManager[1129]: <info> Activation (hso0) Stage
1 of 5 (Device Prepare) complete.
Oct 2 21:57:47 padfoot64 NetworkManager[1129]: <warn> No agents were available
for this request.
Oct 2 21:57:47 padfoot64 NetworkManager[1129]: <info> (hso0): device state
change: need-auth -> failed (reason 'no-secrets') [60 120 7]
Oct 2 21:57:47 padfoot64 NetworkManager[1129]: <info> Marking connection
'o2online UMTS 3G pref.' invalid.
Oct 2 21:57:47 padfoot64 NetworkManager[1129]: <warn> Activation (hso0)
failed.
Oct 2 21:57:47 padfoot64 NetworkManager[1129]: <info> (hso0): device state
change: failed -> disconnected (reason 'none') [120 30 0]
Oct 2 21:57:47 padfoot64 NetworkManager[1129]: <info> (hso0): deactivating
device (reason 'none') [0]
Oct 2 21:57:47 padfoot64 NetworkManager[1129]: <info> Policy set 'nilnet'
(wlan0) as default for IPv4 routing and DNS.
Oct 2 21:57:47 padfoot64 NetworkManager[1129]: <info> Policy set 'nilnet'
(wlan0) as default for IPv4 routing and DNS.
Oct 2 22:00:13 padfoot64 wpa_supplicant[1172]: WPA: Group rekeying completed
with 00:xx:xx:xx:xx:xx [GTK=TKIP]

Reproducible: Always

Steps to Reproduce:
Try to connect to UMTS or GSM network.

Actual Results:
Doesnẗ connect, stops at "Waiting for authorization"

Expected Results:
Should connect to network

system info: latest beta2 kubuntu

nils@padfoot64:~$ uname -a
Linux padfoot64 3.0.0-12-generic #19-Ubuntu SMP Fri Sep 23 21:23:39 UTC 2011
x86_64 x86_64 x86_64 GNU/Linux

ii network-manager 0.9.1.90-0ubuntu2
        network management framework (daemon and userspace tools)
ii network-manager-kde
1:0.9~svngit.nm09.20110610.0c83d8-0ubuntu4 transitional package for
plasma-widget-networkmanagement
ii network-manager-pptp 0.9.0-0ubuntu2
        network management framework (PPTP plugin core)
ii network-manager-pptp-gnome 0.9.0-0ubuntu2
        network management framework (PPTP plugin GNOME GUI)
ii plasma-widget-networkmanagement
0.9~svngit.nm09.20110610.0c83d8-0ubuntu4 Network Management widget for KDE
Plasma workspaces
ii plasma-widget-networkmanagement-dbg
0.9~svngit.nm09.20110610.0c83d8-0ubuntu4 debugging symbols for KDE Network
Management

nils (internationils) wrote :

Fix is committed upstream:

------- Comment #2 From Lamarque V Souza 2011-10-03 01:13:30 -------

Git commit 2b5130205d951d5758049f114cfccc6f05881cdc by Lamarque V. Souza.
Committed on 03/10/2011 at 03:09.
Pushed by lvsouza into branch 'nm09'.

Set default GSM's "password" flag to AgentOwned to prevent the password
from not being saved at all and, consequently, the secrets dialog appearing
at each connection attempt.

BUG: 283204
FIXED-IN: nm09

M +1 -1 libs/ui/gsmwidget.cpp

http://commits.kde.org/networkmanagement/2b5130205d951d5758049f114cfccc6f05881cdc

------- Comment #3 From Lamarque V Souza 2011-10-03 01:14:08 -------

The line "unlock no longer required" in your log indicates that the PIN was
successfully used to unlock your modem. The second time the dialog appear is
not because of PIN but because of the "Password" field, which was not saved
when the connection was created.

nils (internationils) wrote :

At least confirmed, since upstream already fixed it last night.

affects: ubuntu → knetworkmanager (Ubuntu)
Changed in knetworkmanager (Ubuntu):
status: New → Confirmed
Changed in knetworkmanager:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.