Feisty: konqueror & akregator & kmail don't fetch informations from the web

Bug #84258 reported by Thomas Schlesinger on 2007-02-09
4
Affects Status Importance Assigned to Milestone
knetworkmanager (Ubuntu)
Medium
Unassigned

Bug Description

Since yesterday, i have this (somehow network-related?) problems on Feisty (up-to-date):

konqueror:
---------------
konqueror doesn't load websites and gives me an error message, e. g.:
An error occurred while loading http://www.ubuntuforums.org:
Could not connect to host http://www.ubuntuforums.org/.

Firefox doesn't have any problems.
I can open saved html-pages from hard disk with konqueror without any problems.

akregator:
--------------
akregator doesn't fetch feeds anymore (without an error message)

kmail:
-------
kmail doesn't fetch mails anymore without an error message (Thunderbird does)

I think, all these problems are related.

If needed, you can contact me via Chat:
aim: schlesix
jabber: <email address hidden>

Emilio Pozuelo Monfort (pochu) wrote :

Hi Thomas

Can you ping any server?:

Try this in a terminal:
ping google.com

ping ubuntu.com

And put here the output.
Thanks
Emilio

Thomas Schlesinger (schlesix) wrote :

Emilio,

it's not a DNS problem. I can ping servers and I can browse any URL in Firefox. I can use Konversation and Kopete, it seems to be KDE-related.

Mefisto (dariovezzosi) wrote :

I can confirm this bug, same problems

Mefisto (dariovezzosi) wrote :

I also noticed thad Amarok doesn't fetch information from wikipedia

Thomas Schlesinger (schlesix) wrote :

Same here. But Amarok can fetch the song lycrics at least. The weather applet in Kontact doesn't work, too.

Thomas Schlesinger (schlesix) wrote :

Updating podcasts in Amarok doesn't work, too.

Mefisto (dariovezzosi) wrote :

It's a very annoying bug.
I don't know, but maybe is a bug in kdelibs4c2a !?!?

Thomas Schlesinger (schlesix) wrote :

I've found out, that I can send Mails with kmail (smtp), but not receive them (pop3).

Thomas Schlesinger (schlesix) wrote :

I've updated my 2nd PC from Edgy to Feisty. The problem does not exist on this machine, so it's not a general Feisty problem.

Mefisto (dariovezzosi) wrote :

D'Oh i don't want to reinstall everything :(

Thomas Schlesinger (schlesix) wrote :

I've found out the cause of the problem: it's the knetworkmanager.

When knetworkmanager runs, I can't receive mails an surf with konqueror. I've found it out by accidently reading an article today which mentioned, that kmail "asks" knetworkmanager, if there's a network connection. knetworkmanager doesn't see my WLAN connection, though it works without problems (defined in /etc/network/interfaces). When I close knetworkmanager, everything works well.

Emilio Pozuelo Monfort (pochu) wrote :

Well, then there is nothing to fix in konqueror, akregator, kmail... but in knetworkmanager, so I'm changing the package.

Dennis Nienhüser (earthwings) wrote :

Same problem here after upgrading to feisty. Closing knetworkmanager "solves" the problem.

Edward Holcroft (eholcroft) wrote :

Thanks for solving this annoyance after my feisty upgrade.

Emil Web (msdlk45) wrote :

I can also confirm this bug, but this happens to me if I connect via kppp to the internet. I think that closing the knetworkmanager isn't really a good solution, because in other situations I need this tool again (what a start/stop hype).

Dennis Nienhüser (earthwings) wrote :

Yes, it only happens when manually setting up the interface, not when using knetworkmanager to do it.

Leon Feng (lfeng1013) wrote :

Same problem. Network is manually set up. Disabling cache in Konqueror solved the problem, with KNetworkManager still running. Closing KNetworkManager while enabling cache solved the problem, too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers