Ubuntu

VPN connections configure dialog doesn't work on knetworkmanager

Reported by Dusan Zatkovsky on 2006-12-04
This bug report is a duplicate of:  Bug #151867: vpn pptp on Kubuntu is not available. Edit Remove
14
Affects Status Importance Assigned to Milestone
knetworkmanager (Ubuntu)
Undecided
Unassigned
network-manager-pptp (Ubuntu)
High
Craig Box

Bug Description

Binary package hint: knetworkmanager

Click on tray icon / vpn connection / configure vpn do nothing, no configuration dialog was opened.

I have fresh installation of kubuntu edgy i386 with these additional packages:
knetworkmanager + network-manager + network-manager-kde + network-manager-pptp.

Dave Perdue (itsdaveperdue) wrote :

I have the same problem running the same versions as above. I'm trying to find updated versions of all the debs, but building from source yields crashing apps.

David Johnson (dj-david-web) wrote :

I'm seeing exactly the same problem on a fresh Edgy install on x86_64. I have the same packages installed as the reporter.

Changed in knetworkmanager:
status: Unconfirmed → Confirmed
Martin Edwards (mmcmcmc) wrote :

Install the "network-manager-gnome" package. Solved the issue for me.

Dusan Zatkovsky (msk-spam) wrote :

Thank you very much. But i thing, it should be better to make a dependency on that package for knetworkmanager package.

Dave Perdue (itsdaveperdue) wrote :

Installing network-manager-gnome works for me as well, but doesn't ultimately resolve the dependency issue. When I install the network-manager-pptp it puts an item in my kde menu named "VPN Connection Manager (PPP Generic)" that points to nm-vpn-properties that is provided by the network-manager-gnome package.

Changed in knetworkmanager:
importance: Undecided → High
Craig Box (craig.box) wrote :

The easiest solution would be to make network-manager-pptp depend on network-manager-gnome, as it only provides a frontend for GTK. Any objections? I have no idea how knetworkmanager works.

Michael Gefen (gefenm11) wrote :

I confirm the bug on feisty, installing network-manager-gnome solved the problem

>
> >I confirm the bug on feisty, installing network-manager-gnome solved the
> problem
>

Does that then launch a Gnome application?

Craig Box (craig.box) wrote :

> Does that then launch a Gnome application?

Yes, there is no KDE frontend.

I confirm the problem in Feisty updated as of today. Installing that gnome package kind of solves the problem.

Well maybe the "Configure VPN" should either depend on Gnome-Network-Manager
(and have that installed by default), or remove that menu item from the
Feisty network right-click menu? Right now it seems useless and therefor
broken...

Just curious, how is/willl the Portland Project helping to make these Gnome
and KDE apps integrate better?
> Yes, there is no KDE frontend
Will Portland be making this a non-issue, or not really?

I can also confirm the problem on Feisty. Installing network-manager-gnome solved the issue.

Jeff Trull (jetrull) wrote :

I installed network-manager-gnome and it did *not* solve my issue - I now have a nice applet that appears to help me configure my VPN, but any networks I add through the "Create VPN Connection" wizard never stick - I complete the configuration steps, review the results, hit "finish" and there's nothing listed, and no error indicating why the previously defined connection is gone.

network-manager, network-manager-gnome, and network-manager-pptp are all installed and up to date.

~/.xsession-errors shows some strange errors while I'm using this applet, e.g.:

/bin/sh: /usr/bin/esd: not found
and
** (nm-vpn-properties:5889): CRITICAL **: vpnui_opt_connect_signals: assertion `opt->widget!=NULL' failed
and
(nm-vpn-properties:5889): Gtk-CRITICAL **: gtk_widget_set_sensitive: assertion `GTK_IS_WIDGET (widget)' failed

Craig Box (craig.box) wrote :

A fixed version, with better dependencies, is available for testing: http://craig.dubculture.co.nz/blog/2007/05/13/new-networkmanager-pptp-package-fixes-amd64-crashes/

Jeff, please see if this fixes your problem.

Changed in knetworkmanager:
assignee: nobody → craig-dubculture
Jeff Trull (jetrull) wrote :

Hi Craig,

Unfortunately there is no visible change in the behavior of the vpn configuration wizard with the new package.

It looks like my problem is the same as bug 89120. I've added a comment there as well. Thanks for investigating.

Regards,
Jeff Trull
PS: I was not experiencing any dependency issues.

lefty.crupps (eljefedelito) wrote :

Why cannot the Kvpnc be used as the VPN frontend?

Craig Box (craig.box) wrote :

Because I have never tested it. If it works, that's great, I don't see any reason why it shouldn't, but I don't run KDE and rely on other peoples input to test.

I have been using kvpnc for quite a while and works just great. I believe it
has a dcop interface knetworkmanager could use with very little effort...

On 14/05/07, Craig Box <email address hidden> wrote:
>
> Because I have never tested it. If it works, that's great, I don't see
> any reason why it shouldn't, but I don't run KDE and rely on other
> peoples input to test.
>
> --
> VPN connections configure dialog doesn't work
> https://bugs.launchpad.net/bugs/74351
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Luis Pabón

Unfortunately the default settings for Kvpnc doesn't seem to want to connect to a Linksys RV042 firewall which uses Microsoft's PPTP technology, at least with my current tests. I have spoken on IRC with a developer and s/he is looking into it...

Craig Box (craig.box) wrote :

New version uploaded today depends on network-manager-gnome. Any wishlist bugs about knetworkmanager should be raised as separate issues against the 'knetworkmanager' package.

Changed in network-manager-pptp:
status: Confirmed → Fix Released
Jonathan Jesse (jjesse) wrote :

this still is a problem in Kubuntu 8.10 with the latest version of knetworkmanager

Jonathan

Devon (cptnobvious999) wrote :

I also confirm this as still an issue with network-manager-kde 0.7svn864988-0ubuntu1.8.10.3

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions