MSI Wind U100 with RALINK RT2860 wireless adapter will not connect to WPA or WPA2 encrypted networks

Bug #575402 reported by LSL on 2010-05-04
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
knetworkmanager (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Like summary says it is a model U100 MSI Wind netbook with the RALINK RT2860 chip in it, and while in Karmic it could connect to WPA/WPA2 encrypted networks with no issue the kernel version used in Lucid seems to now have this regression.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-21-generic 2.6.32-21.32
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC1200 Analog [ALC1200 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC1200 Analog [ALC1200 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: kerren 1138 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xffe00000 irq 16'
   Mixer name : 'Realtek ALC1200'
   Components : 'HDA:10ec0888,14620110,00100101'
   Controls : 18
   Simple ctrls : 11
Date: Tue May 4 13:48:26 2010
HibernationDevice: RESUME=UUID=0535d8a5-4065-4711-b643-d4bb0a06a146
InstallationMedia: Ubuntu-Netbook-Remix 9.10 "Karmic Koala" - Release i386 (20091028.4)
MachineType: MICRO-STAR INTERNATIONAL CO., LTD U-100
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=UUID=1ce4a8be-3469-4d3b-8bbb-62e7b925e3aa ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
RfKill:

SourcePackage: linux
StagingDrivers: rt2860sta
Title: [STAGING]
dmi.bios.date: 12/03/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.3
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: U-100
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.board.version: Ver.001
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.chassis.version: Ver.001
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.3:bd12/03/2008:svnMICRO-STARINTERNATIONALCO.,LTD:pnU-100:pvrVer.001:rvnMICRO-STARINTERNATIONALCO.,LTD:rnU-100:rvrVer.001:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvrVer.001:
dmi.product.name: U-100
dmi.product.version: Ver.001
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO., LTD

LSL (spesialstyrker) wrote :
Jeremy Foshee (jeremyfoshee) wrote :

Hi Michael,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
LSL (spesialstyrker) wrote :

No problem dude I will get back to you in a few days; it is midterms for me so I am swamped otherwise I would just try it out tonight.

Hajo (h-meyer) wrote :

Probably a duplicate of #545443, which is not a duplicate of #496093.

I have the same problem, but cannot create a bug report (website times out). Here are the details:

I have just upgraded from Kubuntu 9.10 (Karmic) to Kubuntu 10.04 (Lucid). I did the upgrade online using KpackageKit and it completed without any problems.

After the upgrade I could not connect using wifi with WPA2 encryption which was working before the upgrade.

KNetworkManager keeps putting up a dialogue box "Secrets for xxxx" displaying the password for the wireless access point. Clicking OK I then get the status "Configuring inteface" but it does not connect. Eventually the dialogue box "Secrets for xxxx" reappears.

I installed the b43-fwcuttter - 1:012build1 (i386) package using KpackageKit and was able to connect via wifi once, but not again. This also resulted in KDE crashing several times and dropping out to a command prompt login. The KDE crash has stopped after I removed the fwcutter package.

I have entered the KDE wallet password correctly. Using iwconfig in Kubuntu the device is listed as RT2860. Using "lspci | grep Network" the adapter shows as: Network Controller: Ralink RT2860.

One one other occasion I was able to briefly connect with wifi, but then the connection was dropped and the dialogue box "Secrets for SSID - KNetworkManager" reappeared, clicking OK I then get the "Configuring interface" status from the system tray widget and "Activating" on the System Tray popup, but it does not connect.

Note that the connection worked without any problems under Kubutu 9.10.

The WAP is a Linksys WAP610N Wireless-N Access Point

kajhaul (kaj-haulrich) wrote :

Same problem here. Medion Akoya (MSI-Wind clone?) with Ralink RT2860STA. Upgrade from Ubuntu 9.10 to 10.04 broke wireless (Bad Password - which it is not). Same with a fresh install. Tried all i386 versions (Ubuntu + Netbook remix, Kubuntu + Netbook Remix) with no succes. Tried both network-manager and wicd - same result: "Bad Password"). Reinstalled 9.10 versions and everything is OK again (typing this on 9.10).

AmateurDev (guitrguy595) wrote :

I think it might be the Ralink drivers. I have 2 systems running Ubuntu 10.04, my desktop and laptop. My laptop has an Intel Wireless chipset, while my desktop has a Ralink chipset. My laptop works perfectly, but my desktop cannot connect whatsoever. I have tried using Network Manager and wicd, but neither have worked. I'll try ndiswrapper to see if that works. Should I post any of my system information? What would be helpful?

Linux Mint 8 (based on Ubuntu 9.04) connects successfully via wifi so it does not have this bug.

Here is a manual fix for this bug - by recompiling kernel Ralink drivers

http://www.ctbarker.info/2010/05/ubuntu-1004-wireless-chipsets-and-wpa.html

Johnathon (kirrus) wrote :

I think that this is a duplicate of bug #496093 (https://bugs.launchpad.net/ubuntu/lucid/+source/linux/+bug/496093)

Can someone confirm / deny? I didn't want to just mark it as a duplicate without a second opinion.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers