knetworkmnager doesn't connect to wpa2-psk secured wlan while nm-applet connects without problems

Bug #489437 reported by Pauli on 2009-11-28
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
knetworkmanager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: knetworkmanager

I have my home wlan secured with wpa2-psk. It works without problems when using nm-applet and knetworkmanager from Jaunty.

But now I tried kde in Karmic and it is not anymore possible to connect to wlan with knetworkmanager if it is secured with wpa2-psk. Without security network works without problems.

I had key stored globally because this is multi-user laptop. Then I tested if storing key in wallet would help. But no help from wallet.

Work around for me is to use nm-applet in kde too.

Pauli (paniemin) wrote :

Dmesg includes first testing with knetworkmanager and switching to nm-applet and unsecured networks.

PeteV (pete-verschueren) wrote :

I'm having the same problem with NM in Kubuntu Karmic since an update.
My solution was to restart the Knetworkmanager service it then segfault crashed, after that it just worked right again and connected to my wpa2-psk network without a problem. I have to do this everytime I reboot now.

PeteV (pete-verschueren) wrote :

Fixed ? I set the N.M nm-system-settings.conf

managed=true

it was unmanaged before.
now this time I didn't have to restart the service at
boot. strange!?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers