Ubuntu

the DSLl tab of knetworkmanager is uabled to use while pppoeconf can work

Reported by Cheng-Chia Tseng on 2009-04-26
This bug report is a duplicate of:  Bug #339882: Implement PPPoE support. Edit Remove
2
Affects Status Importance Assigned to Milestone
knetworkmanager (Ubuntu)
Undecided
Unassigned

Bug Description

When I first boot into Kubuntu, the right-down notification area told me that "Auto eth0 failed..." and disappeared soon.

As I right clicked the icon of NetworkManagement plasma and tried to manage connections on my computer for my DSL connection, I found that the DSL tab was unabled to switch to. Thus, I used pppoeconf to set up my DSL connection and worked well. (Please see the attachment for understanding the situation better.)

However, the configuration I set up with pppoeconf still cannot be managed by NetworkManagemet plasma.

I was wondering if there is something wrong with knetwrokmanager? If not, can the develop team merge the feature of pppoeconf into knetworkmanager? Thanks a lot.

******
Information of ifconfig:
eth0 Link encap:Ethernet HWaddr 00:21:85:11:45:28
          inet6 addr: fe80::221:85ff:fe11:4528/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:59793 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33954 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:85882213 (85.8 MB) TX bytes:3359806 (3.3 MB)
          Interrupt:251 Base address:0xa000

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:280 errors:0 dropped:0 overruns:0 frame:0
          TX packets:280 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:19768 (19.7 KB) TX bytes:19768 (19.7 KB)

ppp0 Link encap:Point-to-Point Protocol
          inet addr:61.227.140.183 P-t-P:220.129.160.254 Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
          RX packets:26611 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16098 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:36621239 (36.6 MB) TX bytes:1450804 (1.4 MB)

Information of plog:
(I use poff -a then pon dsl-provider before plog)

Apr 26 14:11:19 desktop pppd[5246]: Using interface ppp1
Apr 26 14:11:19 desktop pppd[5246]: Connect: ppp1 <--> eth0
Apr 26 14:11:19 desktop pppd[5246]: PAP authentication succeeded
Apr 26 14:11:19 desktop pppd[5246]: peer from calling number 00:90:1A:41:F2:FD authorized
Apr 26 14:11:19 desktop pppd[5246]: not replacing existing default route through ppp0
Apr 26 14:11:19 desktop pppd[5246]: Cannot determine ethernet address for proxy ARP
Apr 26 14:11:19 desktop pppd[5246]: local IP address 61.227.137.218
Apr 26 14:11:19 desktop pppd[5246]: remote IP address 220.129.160.254
Apr 26 14:11:19 desktop pppd[5246]: primary DNS address 168.95.192.1
Apr 26 14:11:19 desktop pppd[5246]: secondary DNS address 168.95.1.1

Cheng-Chia Tseng (zerng07) wrote :
description: updated
tags: added: dsl knetworkmanager pppoe
description: updated
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers