Automatically reconnect to known wireless networks with hidden SSID

Bug #286168 reported by Christiansen on 2008-10-20
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
knetworkmanager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager-kde

KnetworkManager/network-manager-kde does not automatically reconnect to ALREADY KNOWN hidden wireless network (AP with hidden SSID). When the computer comes back from hibernation or the computer has been rebooted, the user has to go to the KNetworkManager applet in the systemtray and manually connect to the known wireless network.
Opposite when the SSID is NOT hidden this happens automatically when the wireless network i within reach of the computer (or the wireless adapter).
Connecting automatically to wireless networks with hidden SSID works in Kubuntu 7.10 and 8.04 using KNetworkManager (under KDE 3.5.x) up to version 0.2.2 (in Hardy).

Magnus S (magnuss) wrote :

(this bug is probably a duplicate of bug#295796)

Magnus S (magnuss) wrote :

(this is probably _not_ a duplicate of bug#295796)

Russell Ault (russell-ault) wrote :

I'm having exactly the same problem. Went to suspend, and came back with no network connection. Reconnected again by typing in the SSID under "Connect to Other Wireless Network" and setting the security settings, although I typed in garbage for the WPA password and the KDE Wallet still retrieved the right password (which is a very good thing, since I had *just* shredded the piece of paper I had written the password on). Anyway, I'll try waiting next time, see if giving it five minutes makes a difference, but either way this is a tad annoying (especially with a long password)...

-Russ

Magnus S (magnuss) on 2008-12-27
Changed in knetworkmanager:
status: New → Confirmed
Buck Evan (bukzor) wrote :

I do believe this is same as bug#295796.
Some people are just more patient than others. ( 'never' is anything greater than 30 seconds.)

Jonathan Thomas (echidnaman) wrote :

Thank you for taking the time to report this bug and helping to make Kubuntu better. The KDE3 version of KNetworkManager has been discontinued by its original authors. This unfortunately means that there will be no more bugfix releases, and updates in general will be limited to those fixing security flaws.

While we cannot fix your bug, the good news is that the applet has been totally rewritten for KDE4 in the upcoming Kubuntu 9.10 release. There is a good chance that this bug is no longer an issue with the new applet. If you find any similar or new issues with the applet included in Kubuntu 9.10, we would politely ask you to file them as new bugs against the "plasma-widget-networkmanagement" package.

Thanks in advance for your cooperation and understanding.

Changed in knetworkmanager (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers