knetworkmanager: error while loading shared libraries: libnetworkstatus.so.0: cannot open shared object file: No such file or directory

Bug #112134 reported by Bryan Donlan on 2007-05-03
28
Affects Status Importance Assigned to Milestone
knetworkmanager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: knetworkmanager

When starting knetworkmanager:
bd@shion:~$ knetworkmanager
knetworkmanager: error while loading shared libraries: libnetworkstatus.so.0: cannot open shared object file: No such file or directory
bd@shion:~$ dpkg -S libnetworkstatus.so.
dpkg: *libnetworkstatus.so.* not found.
bd@shion:~$ dpkg -l knetworkmanager
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-======================================-======================================-============================================================================================
ii knetworkmanager 0.1-0ubuntu12 User friendly KDE frontend for NetworkManager

It appears that knetworkmanager's shlibs-depends are not being generated properly, and/or one of its dependencies changed its soname without changing its package name.

Luka Renko (lure) wrote :

Interesting... :-(

Can you try to install "networkstatus" package? Does this fixes the problem for you?

Changed in knetworkmanager:
status: Unconfirmed → Needs Info
Bryan Donlan (bdonlan) wrote :

bd@shion:~$ sudo apt-get install networkstatus
Password:
Reading package lists... Done
Building dependency tree
Reading state information... Done
networkstatus is already the newest version.
networkstatus set to manual installed.

bd@shion:~$ apt-cache policy networkstatus
networkstatus:
  Installed: 4:3.5.6-2ubuntu2
  Candidate: 4:3.5.6-2ubuntu2
  Version table:
 *** 4:3.5.6-2ubuntu2 0
        500 http://us.archive.ubuntu.com gutsy/main Packages
        100 /var/lib/dpkg/status
     4:3.5.6-0ubuntu6 0
        500 http://us.archive.ubuntu.com feisty/main Packages

Downgrading to feisty fixes it. diffing the file lists gives:
--- networkstatus_contents.feisty 2007-05-03 14:05:47.000000000 -0400
+++ networkstatus_contents.gutsy 2007-05-03 14:04:30.000000000 -0400
@@ -17,6 +17,3 @@
 /usr/lib/kde3
 /usr/lib/kde3/kded_networkstatus.la
 /usr/lib/kde3/kded_networkstatus.so
-/usr/lib/libnetworkstatus.so.0.0.0
-/usr/lib/libconnectionmanager.so.0.0.0
-/usr/lib/libnetworkstatus.so.0

Incidentally, I don't know about ubuntu's policies much, but in debian at least wouldn't libraries of this sort be in a package like libnetworkstatus0, to facilitate future soname changes? With the other kded components in another package of course.

Luka Renko (lure) wrote :

OK, this was probably done by merge of packages from debian.

Confirmed, assigned to Jonathan and lower priority as this is Gutsy.

Changed in knetworkmanager:
assignee: nobody → jr
status: Needs Info → Confirmed

Fixed in the kde 3.5.7 merge, thanks for reporting.

Changed in knetworkmanager:
assignee: jr → hobbsee
status: Confirmed → Fix Released
anagor (anagor) wrote :

Same happens now with hardy.
Getting the same error with the latest updates on hardy, looks like the libnetworkstatus.so.0 got removed from last networkstatus package
network-manager-kde 1:0.2ubuntu1-0ubuntu7
networkstatus 4:3.5.7enterprise20070926-1ubuntu6

Luka Renko (lure) wrote :

Also fixed now for Hardy

4:3.5.7enterprise20070926-1ubuntu8
not fixed here. i'm getting the same error with the above ^ version.

anagor (anagor) wrote :

yep, libnetworkstatus.so.0 still missing in networkstatus package as j wrote
4:3.5.7enterprise20070926-1ubuntu8

Florian (florian-hegler) wrote :

I am using Hardy,KDE4 and I experience likely the same with the new Beta from 20.3.2008.
The error message reads when dealing with the Network Settings: The shared library was not found.Library not found.
Possible reasons: An error occurred during your last KDE upgrade leaving an orphaned control module (I did a clean install)
You have an old third party module lying around (again, this system is fresh and clean).
Hope you can figure something out.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers