KNetworkManager doesn't use supplied WEP key

Bug #102502 reported by Nick Bridgwater on 2007-04-03
10
Affects Status Importance Assigned to Milestone
knetworkmanager
Invalid
Medium
knetworkmanager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: knetworkmanager

On Kubuntu 6.10 with Buffalo WLI-CB-G54A card using Ndiswrapper.

Kubuntu comes up (with a long delay where I suspect it is attempting to connect to the wireless network) and the wireless card's lights are lit but there is no network connection.

I tried this with a test wireless network with no encryption and I connect fine first time - so something to do with WEP.

1) With bare bones /etc/network/interfaces file, I attempt to connect to my wireless n/w using KNetworkManager with the correct WEP key specified. It fails to connect and reprompts for my WEP key ...

2) If, whilst it is doing this I enter "sudo iwlist wlan0 enc" to check my WEP key, I see a strange key of A7D5-CFE7-B0B7-EB11-E518-17FE-B4

3) SO, while KNetworkManager was trying to connect I entered "sudo iwconfig wlan0 key s:<my wep key>" and I connected fine. This works repeatable for me.

Please let me know what extra info I can supply ... I'd like to be able to connect to the network without having to do the above every time.

Update 4th April:
- strange key is not always the same - today it was 6A80-91FF-2462-08C2-2639-7459-52
- having entered the correct key through "sudo iwconfig ..." and successfully connected, "sudo iwlist wlan0 enc" shows my correct WEP key

description: updated
Nick Bridgwater (leamphil) wrote :

Syslog from startup included

Nick Bridgwater (leamphil) wrote :

Three more Syslog fragments:

1) Boot
  - Long pause 3.5 bars into Kubuntu progress
  - Password prompt for signin
  - loading desktop
  - Password prompt for KNetworkManager using KWallet
  - KNM icon cogs turning (& wallet open) - pause for 30+ seconds
  - prompt for WEP password
  - progress at 57% for 30+ seconds (IP Configuration started)
  - reprompt for WEP password
  - progress at 57% for 30+ seconds (IP Configuration started)
  - clicked on cancel

Nick Bridgwater (leamphil) wrote :

2) Clicked on KNetworkManager connect to my AP
  - prompted for WEP
  - 57% progress, 30+ second pause (IP COnfiguration Started)
  - reprompt for WEP
  - cancelled

Nick Bridgwater (leamphil) wrote :

After the above I entered "sudo iwlist wlan0 enc" - there was no WEP key set

3) Attempted to connect to my AP through KNetworkManager (again)
  - prompt for WEP password
  - after entering password above, I entered "sudo iwconfig wlan0 key s:<my WEP key>"
  - KWallet prompted for password
  - Successful connection to my AP
  - "Sudo iwlist wlan0 enc" shows my WEP key set

Sujee Maniyam (sujee) wrote :

can you try with newer versions of Kubuntu (Feisty 7.04 or Gutsy 7.10) and see if the problem is fixed?
Thanks!

Changed in knetworkmanager:
status: New → Incomplete
Nick Bridgwater (leamphil) wrote :

Trying to install Gutsy 7.10 on my old IBM 600X that had the problems above and get error messages:

[ 0.000000] ACPI: BIOS age (1999) fails cutiff (2000), acpi=force is required to enable ACPI
[ 40.274914] invalid compressed format (err=2)
[ 40.278097] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(104,1)

Any suggestions ? ... I've tried the same CD on a newer IBM T22 and get a lot further (logos etc.) but then just stops with blank screen and does nothing ... so I assume the CD is a valid copy.

Nick Bridgwater (leamphil) wrote :

Upgrade to Edgy via Adept (clean load from CD wouldn't boot on my IBM TP 600X though it booted fine on my Dell Dimension desktop, gave err=2 error) as requested.

Problem still exists as above (I have to issue "sudo iwconfig wlan0 key s:<wep key>" whilst the network tries to start in order for my Wifi card to connect, even though KDE Wallet Manager has the correct password and even though I enter the correct password when prompted).

Nick Bridgwater (leamphil) wrote :

Oops mean from Edgy to Feisty !

Launchpad Janitor (janitor) wrote :

[Expired for knetworkmanager (Ubuntu) because there has been no activity for 60 days.]

tags: added: jaunty

This problem is still active with Kubuntu Jaunty (Beta) ((latest update on 07.04.2009)).

Configuration: Dell Inspiron 1545 with Intel 5100 wlan card
Problem: Access to WEP with ASCII string as shared key

I can connect to WEP access point with a hand edited /etc/wpa_supplicant.conf and corresponding /etc/network/interfaces configuration. Thus my problem is not caused by driver or other problems.

Somehow knetworkmanager seems to have problems, telling wpa_supplicant the secret settings. At least the following entries in /var/log/syslog seem to point to this:

Apr 7 11:28:00 computer NetworkManager: <WARN> update_one_setting(): Failed to update connection secrets: 1 802-1x
Apr 7 11:28:00 computer NetworkManager: <WARN> real_connection_secrets_updated(): Ignoring updated secrets for setting 'ipv4'.
Apr 7 11:28:00 computer NetworkManager: <WARN> real_connection_secrets_updated(): Ignoring updated secrets for setting '802-11-wireless'.

Apr 7 11:28:00 computer NetworkManager: nm_setting_802_1x_get_pkcs11_engine_path: assertion `NM_IS_SETTING_802_1X (setting)' failed
Apr 7 11:28:00 computer NetworkManager: nm_setting_802_1x_get_pkcs11_module_path: assertion `NM_IS_SETTING_802_1X (setting)' failed

Apr 7 11:28:02 computer kernel: [ 4697.712097] wlan0: authenticate with AP 00:11:6b:61:ae:b3
Apr 7 11:28:02 computer kernel: [ 4697.912096] wlan0: authentication with AP 00:11:6b:61:ae:b3 timed out

/etc/wpa_supplicant.conf:
================

ctrl_interface=/var/run/wpa_supplicant
ap_scan=1
eapol_version=1

network={
        ssid="<ESSID>"
 scan_ssid=1
 key_mgmt=NONE
 auth_alg=SHARED
 wep_tx_keyidx=0
        wep_key0="<myCode>"
 priority=5
}

==>>
The manual ifup-based approach with /etc/network/interfaces and /etc/wpa_supplicant.conf works just fine. But I want to configure this computer, so that non expert users can connect to WEP network with a nice GUI.

I hope, that the attached information helps to trace the problem.

Kind Regards,
Achim

Still active in Jaunty (Beta) and filled with more log information.

Changed in knetworkmanager (Ubuntu):
status: Invalid → New
Roy Jamison (xteejx) wrote :

Is this a problem in the final release of Jaunty, i.e. fully updated?

Changed in knetworkmanager (Ubuntu):
status: New → Incomplete
katmen (katmen) wrote :

this problem is persistent also in fully upgraded jj and also in kubuntu 9.04, solution is to install a wicd manager,i am using broadcom wifi card in my hp 530,
working workaround in 8.10 was that during its installation when was wired connection available instalation program downloaded wifi card firmware itself and after restart the driver was okay and network manager accepts with no problem 64bit hex wep key open system

Roy Jamison (xteejx) wrote :

Sent upstream to KDE bugtracker, marking Triaged, Medium.

Changed in knetworkmanager (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in knetworkmanager:
status: Unknown → New
Jonathan Thomas (echidnaman) wrote :

Thank you for taking the time to report this bug and helping to make Kubuntu better. The KDE3 version of KNetworkManager has been discontinued by its original authors. This unfortunately means that there will be no more bugfix releases, and updates in general will be limited to those fixing security flaws.

While we cannot fix your bug, the good news is that the applet has been totally rewritten for KDE4 in the upcoming Kubuntu 9.10 release. There is a good chance that this bug is no longer an issue with the new applet. If you find any similar or new issues with the applet included in Kubuntu 9.10, we would politely ask you to file them as new bugs against the "plasma-widget-networkmanagement" package.

Thanks in advance for your cooperation and understanding.

Changed in knetworkmanager (Ubuntu):
status: Triaged → Won't Fix
Changed in knetworkmanager:
status: New → Invalid
Changed in knetworkmanager:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.