kmyfirewall.desktop file not correct

Bug #125170 reported by Mike E. on 2007-07-11
8
Affects Status Importance Assigned to Milestone
kmyfirewall (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: kmyfirewall

The kmyfirewall.desktop file included in the Fiesty repository does not include the correct information to make a working menu entry for the KDE menu. It is missing the following lines:

Name=KMyFirewall
GenericName=Configure Firewall
Exec=kmyfirewall
Terminal=false

Also the Categories line is incorrect:

Categories=Qt;KDE;System;

Should be:

Categories=Application;System;

Related branches

Emmet Hikory (persia) wrote :

Thank you for reporting this. I'm rather certain that the categories entry will need to be further adjusted for Ubuntu 7.10, in line with http://standards.freedesktop.org/menu-spec/latest/apa.html.

Changed in kmyfirewall:
importance: Undecided → Low
status: New → In Progress
Siegfried Gevatter (rainct) wrote :

I think this will do it.

Changed in kmyfirewall:
status: In Progress → Confirmed
Cesare Tirabassi (norsetto) wrote :

I'm unfortunately getting this validation error:

error: value "application/x-kmyfirewall;application/x-kmfrs;application/x-kmfgrs" for string list key "MimeType" in group "Desktop Entry" does not have a semicolon (';') as trailing character

Siegfried Gevatter (rainct) wrote :

I don't get any complain. Do you have the latest version of desktop-file-utils?

Cesare Tirabassi (norsetto) wrote :

Yes, version 0.13 (which complies to the desktop entry specification 1.0).

Siegfried Gevatter (rainct) wrote :

Ah, it's me who hasn't the latest version (I've 0.12)... It's getting time that I switch to Gutsy :P

Is the problem that a semicolon is missing on the end of that line? If yes here is a fixed debdiff (I can't check it with 0.13 since I don't have the dependencies for it).

Scott Kitterman (kitterman) wrote :

Looks good. I did edit the changelog entry slightly. I'm going to have a go at understanding Bug #48076 and see if I can deal with it, but otherwise assuming it tests out good, I'll upload it.

Changed in kmyfirewall:
assignee: nobody → kitterman
status: Confirmed → In Progress
Scott Kitterman (kitterman) wrote :

OK. Still needs work. The patch for the .desktop file fails to apply:

test -d debian/patched || install -d debian/patched
dpatch apply-all
applying patch 01_fix_desktop_file to ./ ... failed.
make: *** [patch-stamp] Error 1
pbuilder: Failed autobuilding of package

Other stuff needing to be done to the package:

  * Add build-dep for dpatch
  * Bump standards version to 3.7.2 (check to see if other changes are required)
  * Change maintainer to MOTU

Unsubscribing UUS. Please resubscribe once you have a revised update available.

Changed in kmyfirewall:
assignee: kitterman → rainct
Siegfried Gevatter (rainct) wrote :
Changed in kmyfirewall:
assignee: rainct → nobody
status: In Progress → Confirmed
Siegfried Gevatter (rainct) wrote :

I'm not sure if it works, perhaps the standards version change is breaking something.

Daniel Holbach (dholbach) wrote :

Builds nicely for me, uploaded.

Mario Di Nicola (warp99) wrote :

The exec command line of the *.desktop file does not include the kdesu command for elevation of privileges since root is needed to access the iptables. On startup kmyfirewall will complain about no root access and no changes cam be saved. Also because of the elevation of privileges issue does kmyfirewall need to have kdesu added as a dependency? I can't answer this question since I don't have enough experience with dependency issues.

Siegfried Gevatter (rainct) wrote :

kmyfirewall (1.0-1ubuntu4) gutsy; urgency=low

  * Fixed the .desktop file (Thanks to Mike E.) (LP: #125170)
  * Changed Maintainer to match DebianMaintainerField spec
  * debian/control: Changed standards version to 3.7.2

 -- Siegfried-Angel Gevatter Pujals (RainCT) <email address hidden> Wed, 18 Jul 2007 20:58:31 +0200

Changed in kmyfirewall:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers