Upgrade to kmod (25-1ubuntu1.1) causes Lenovo x240 laptop to hang on boot

Bug #1802689 reported by Adam Jacobs on 2018-11-11
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kmod (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
linux (Ubuntu)
Undecided
AaronMa
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

After upgrading my Lenovo x240 laptop to kmod (25-1ubuntu1.1), it hangs on boot.

After blacklisting i2c_i801 everything works great again.

I realize that this was a fix for bug 1786574, and that helps some other folks out. I'm not sure what the right fix is but there's got to be something that works for everyone.

Changed in kmod (Ubuntu):
assignee: nobody → AaronMa (mapengyu)

Hello Adam, or anyone else affected,

Accepted kmod into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/kmod/25-1ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in kmod (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Changed in kmod (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Brian Murray (brian-murray) wrote :

Hello Adam, or anyone else affected,

Accepted kmod into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/kmod/24-1ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in kmod (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Adam, or anyone else affected,

Accepted kmod into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/kmod/22-1ubuntu5.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Adam Jacobs (bllfr0g) wrote :

kmod 25-1ubuntu1.2 looks good on cosmic

tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Anthony Wong (anthonywong) wrote :

I am opening a "linux" task for investigating the real root cause of this in kernel.

Changed in linux (Ubuntu):
assignee: nobody → AaronMa (mapengyu)
Changed in kmod (Ubuntu):
assignee: AaronMa (mapengyu) → nobody

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1802689

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu Bionic):
status: New → Incomplete
Changed in linux (Ubuntu Cosmic):
status: New → Incomplete
Changed in linux (Ubuntu Xenial):
status: New → Incomplete
AaronMa (mapengyu) wrote :

Hi Adam:

Could you try 4.19 kernel with i2c_i801 loaded?
http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19/

to see if it is fixed?

Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kmod - 25-1ubuntu2

---------------
kmod (25-1ubuntu2) disco; urgency=medium

  * Add i2c_i801 back to d/modprobe.d/blacklist.conf again due to regressions.
    (LP: #1802689, #1802135)

 -- Michael Hudson-Doyle <email address hidden> Tue, 13 Nov 2018 10:50:02 +1300

Changed in kmod (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers