Ubuntu 16.04.02: depmod: WARNING: <module-path> needs unknown symbol .TOC.

Bug #1696710 reported by bugproxy on 2017-06-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
Medium
Canonical Foundations Team
kmod (Ubuntu)
Medium
Adam Conrad
Trusty
Medium
Juerg Haefliger
Xenial
Medium
Adam Conrad

Bug Description

== Comment: #0 - Douglas Miller <email address hidden> - 2017-01-24 07:59:54 ==
---Problem Description---
depmod does not handle .TOC symbol on powerpc platforms

Contact Information = Douglas Miller <email address hidden>

---uname output---
Linux p8le03 4.4.0-38-generic #57-Ubuntu SMP Tue Sep 6 15:40:06 UTC 2016 ppc64le ppc64le ppc64le GNU/Linux

Machine Type = other

---Debugger---
A debugger is not configured

---Steps to Reproduce---
 Compile kernel, during modules_install target the messages appear. PPC64 modules have a .TOC symbol which is required. It may be the only symbol with a period in the name, and so tools that restrict symbols based on a pattern may neglect to include .TOC.

Userspace tool common name: depmod

The userspace tool has the following bit modes: 64

Userspace rpm: libkmod2:ppc64el

Userspace tool obtained from project website: na

*Additional Instructions for Douglas Miller <email address hidden>:
-Attach ltrace and strace of userspace application.

== Comment: #3 - Douglas Miller <email address hidden> - 2017-01-24 08:12:58 ==
kmod package:

# dpkg --list |grep kmod
ii kmod 22-1ubuntu4 ppc64el tools for managing Linux kernel modules
ii libkmod2:ppc64el 22-1ubuntu4 ppc64el libkmod shared library

== Comment: #7 - Douglas Miller <email address hidden> - 2017-06-07 16:20:38 ==
 I was doing a build of upstream origin/master on Ubuntu 16.04.2 fresh install and still getting these messages. In the "make modules_install" output I see:

...
  DEPMOD 4.12.0-rc4
depmod: WARNING: /lib/modules/4.12.0-rc4/kernel/arch/powerpc/kernel/rtas_flash.ko needs unknown symb
ol .TOC.
...

bugproxy (bugproxy) on 2017-06-08
tags: added: architecture-ppc64le bugnameltc-150912 severity-medium targetmilestone-inin16042
Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → kmod (Ubuntu)
Changed in ubuntu-power-systems:
assignee: nobody → Canonical Server Team (canonical-server)
Manoj Iyer (manjo) on 2017-07-19
Changed in kmod (Ubuntu):
importance: Undecided → Medium
Changed in ubuntu-power-systems:
importance: Undecided → Medium
Changed in ubuntu-power-systems:
assignee: Canonical Server Team (canonical-server) → Canonical Foundations Team (canonical-foundations)
Manoj Iyer (manjo) on 2017-07-24
Changed in kmod (Ubuntu):
assignee: Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage) → Canonical Kernel Team (canonical-kernel-team)
tags: added: triage-a
Adam Conrad (adconrad) wrote :

Ahh yes, and we already had that patch in yakkety and zesty, it was just never backported to xenial.

Changed in kmod (Ubuntu):
assignee: Canonical Kernel Team (canonical-kernel-team) → Adam Conrad (adconrad)
status: New → Invalid
Changed in kmod (Ubuntu Xenial):
assignee: nobody → Adam Conrad (adconrad)
status: New → In Progress
Adam Conrad (adconrad) on 2017-07-25
Changed in kmod (Ubuntu):
status: Invalid → Fix Released

Hello bugproxy, or anyone else affected,

Accepted kmod into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/kmod/22-1ubuntu5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in kmod (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Manoj Iyer (manjo) wrote :

Building Zesty kernel source in Xenial series in launchpad PPA, I am able to reproduce this bug:

many such messages:

depmod: WARNING: /<<PKGBUILDDIR>>/debian/linux-image-4.10.0-29-generic/lib/modules/4.10.0-29-generic/kernel/zfs/splat/splat.ko needs unknown symbol .TOC.
EE: Unresolved module dependencies in base package!
debian/rules.d/2-binary-arch.mk:109: recipe for target 'install-generic' failed
make: *** [install-generic] Error 1
dpkg-buildpackage: error: fakeroot debian/rules binary-arch gave error exit status 2
--------------------------------------------------------------------------------
Build finished at 20170725-1711

Manoj Iyer (manjo) wrote :

Ah! I did not have proposed enabled in my PPA.. Let me re-try with proposed enabled.

Manoj Iyer (manjo) wrote :

With -proposed enabled in the PPA, Zesty source kernel built for Xenial series was successful with no warning like those reported previously.

+------------------------------------------------------------------------------+
| Summary |
+------------------------------------------------------------------------------+

Build Architecture: ppc64el
Build-Space: 2676008
Build-Time: 4980
Distribution: xenial
Host Architecture: ppc64el
Install-Time: 17
Job: linux_4.10.0-29.33~lp1706141+build.2.dsc
Machine Architecture: ppc64el
Package: linux
Package-Time: 5010
Source-Version: 4.10.0-29.33~lp1706141+build.2
Space: 2676008
Status: successful
Version: 4.10.0-29.33~lp1706141+build.2
--------------------------------------------------------------------------------
Finished at 20170725-2034

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
tags: removed: verification-done
tags: added: triage-g
removed: triage-a
Changed in kmod (Ubuntu Xenial):
importance: Undecided → Medium
Manoj Iyer (manjo) on 2017-07-25
Changed in ubuntu-power-systems:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kmod - 22-1ubuntu5

---------------
kmod (22-1ubuntu5) xenial; urgency=medium

  * depmod-ignore-powerpc64-abiv2-toc-symbol.patch: Ignore the TOC symbol
    in depmod on PPC64 as it does not need to be relocated (LP: #1696710)
  * fix-docs-build: Fix build failure with the xenial version of gtk-doc.

 -- Adam Conrad <email address hidden> Tue, 25 Jul 2017 07:41:35 -0600

Changed in kmod (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for kmod has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

tags: added: id-59774a219e9196af44a02a59
Andy Whitcroft (apw) on 2018-04-11
Changed in kmod (Ubuntu Trusty):
importance: Undecided → Medium
assignee: nobody → Juerg Haefliger (juergh)
status: New → In Progress

Hello bugproxy, or anyone else affected,

Accepted kmod into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/kmod/15-0ubuntu7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in kmod (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-trusty
Juerg Haefliger (juergh) wrote :

Verified that the new package fixes the issue.

tags: added: verification-done-trusty
removed: verification-needed-trusty
dino99 (9d9) on 2018-05-03
tags: removed: verification-needed
tags: removed: severity-medium
bugproxy (bugproxy) on 2018-05-03
tags: added: severity-medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kmod - 15-0ubuntu7

---------------
kmod (15-0ubuntu7) trusty; urgency=medium

  * depmod-ignore-powerpc64-abiv2-toc-symbol.patch: Ignore the TOC symbol
    in depmod on PPC64 as it does not need to be relocated (LP: #1696710)

 -- Juerg Haefliger <email address hidden> Fri, 06 Apr 2018 12:52:17 +0200

Changed in kmod (Ubuntu Trusty):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers