ISST-KVM:R2-0:No login prompt displayed on FB console after Ubuntu 14.10 installation

Bug #1378648 reported by bugproxy on 2014-10-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kmod (Ubuntu)
Undecided
Adam Conrad
linux (Ubuntu)
Undecided
Andy Whitcroft

Bug Description

== Comment: #0 - Richard M. Scheller <email address hidden> - 2014-10-06 13:42:47 ==
---Problem Description---
After installing Ubuntu 14.10 (3.16.0-20-generic kernel) using a qemu virtual VGA framebuffer console and rebooting the installed system, there is no login prompt displayed on the fb console. This is a regression from 14.04.1, where the login prompt is displayed on the console.

(Note that this is *not* related to IBM bug#113591/LauchPad bug#1346851, which has been fixed in the latest daily builds.)

The OS installation completes without any errors, then the guest reboots from the installed virtual disk. The guest comes up without any problems (it is possible to ssh into the guest) but no login prompt is displayed on the fb console.

Machine Type = 8247-22L (PowerKVM guest)

---Steps to Reproduce---
 Configure guest with framebuffer console and USB keyboard/mouse and install through that interface.

---uname output---
Linux netg7 3.16.0-20-generic #27-Ubuntu SMP Wed Oct 1 17:24:38 UTC 2014 ppc64le ppc64le ppc64le GNU/Linux

---Debugger---
A debugger is not configured

Install ISO Information: 2014-10-06 daily build (network install)

Install disk info: n/a

Install method: TFTP boot of kernel/initrd from local server, then direct download from ports.ubuntu.com

== Comment: #4 - Richard M. Scheller <email address hidden> - 2014-10-06 14:34:43 ==
I should also point out that there is no login prompt displayed on the virtual serial console (/dev/hvc0) either. Here is a list of the getty processes which are started on reboot:

root@netg7:~# ps -ef|grep getty|grep -v grep
root 869 1 0 12:23 tty4 00:00:00 /sbin/getty -8 38400 tty4
root 871 1 0 12:23 tty5 00:00:00 /sbin/getty -8 38400 tty5
root 874 1 0 12:23 tty2 00:00:00 /sbin/getty -8 38400 tty2
root 875 1 0 12:23 tty3 00:00:00 /sbin/getty -8 38400 tty3
root 881 1 0 12:23 tty6 00:00:00 /sbin/getty -8 38400 tty6
root 1026 1 0 12:23 tty1 00:00:00 /sbin/getty -8 38400 tty1
root@netg7:~#

== Comment: #10 - Richard M. Scheller <email address hidden> - 2014-10-06 17:31:23 ==
OK, I think I'm getting closer to the root cause. I'm pretty sure it's the framebuffer device.

These are the related kernel messages from Ubuntu 14.04.1 (netg9):

root@netg9:~# dmesg|egrep -i 'buffer|offb|vga'
[ 0.099978] vgaarb: device added: PCI:0000:00:05.0,decodes=io+mem,owns=io+mem,locks=none
[ 0.099979] vgaarb: loaded
[ 0.099980] vgaarb: bridge control possible 0000:00:05.0
[ 0.581438] Using unsupported 800x600 vga at 100a0000000, depth=32, pitch=3200
[ 0.583419] Console: switching to colour frame buffer device 100x37
[ 0.584748] fb0: Open Firmware frame buffer device on /pci@800000020000000/vga@5
root@netg9:~#

And here are the related messages from 14.10 (netg7):

root@netg7:~# dmesg|egrep -i 'buffer|offb|vga'
[ 0.136665] vgaarb: device added: PCI:0000:00:05.0,decodes=io+mem,owns=io+mem,locks=none
[ 0.136701] vgaarb: loaded
[ 0.136733] vgaarb: bridge control possible 0000:00:05.0
[ 0.580147] Using unsupported 800x600 vga at 100a0000000, depth=32, pitch=3200
[ 0.583407] Console: switching to colour frame buffer device 100x37
[ 0.585721] fb0: Open Firmware frame buffer device on /pci@800000020000000/vga@5
[ 4.264808] fb: switching to bochsdrmfb from OFfb vga
[ 4.266985] [drm:bochs_hw_init] *ERROR* Cannot request framebuffer
root@netg7:~#

Everything looks pretty much the same on both guests until 14.10 tries to switch to the "bochsdrmfb" device. I'm going to assume that device only works on x86.

On 14.10, the kernel has a new driver that doesn't exist on 14.04:

14.10:
root@netg7:~# grep -i bochs /boot/config-3.16.0-20-generic
CONFIG_DRM_BOCHS=m
root@netg7:~#

14.04.1:
root@netg9:~# grep -i bochs /boot/config-3.13.0-36-generic
root@netg9:~#

== Comment: #11 - Richard M. Scheller <email address hidden> - 2014-10-06 18:28:25 ==
I disabled the bochs framebuffer on 14.10 by adding the following line to /etc/modprobe.d/blacklist.conf:

blacklist bochs-drm

On the next guest reboot, the login prompt appeared on the VGA console as expected and I was able to login interactively through the Kimchi web VNC interface.

So, the problem is definitely the bochs DRM device. I don't know if the appropriate long-term solution is to fix the boch-drm driver or if it should simply be disabled, but one or the other needs to be done for 14.10 and future releases.

Default Comment by Bridge

tags: added: architecture-ppc64le bugnameltc-117220 severity-critical targetmilestone-inin---

Default Comment by Bridge

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1378648/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Breno Leitão (breno-leitao) wrote :

Canonical, is it possible to blacklist bochs-drm in ppc64el to avoid this problem, for now?

Changed in ubuntu:
assignee: nobody → Taco Screen team (taco-screen-team)
status: New → Confirmed
Adam Conrad (adconrad) wrote :

Quoting from a private email about this bug:

So, I don't think any of us here at the kernel sprint (including three
SRU team members and two release team members) read "kernel freeze" as
"no new uploads of the kernel, period", but rather that if uploads
happen, they'll only be to address critical bugs as driven by the
release team, with no other changes.

That said, adding a userspace blacklist is right, regardless, so that
we don't explode on custom compiled kernerls that have that module
enabled, etc. When the bug is fixed upstream, we can revert the hack.

I will, however, also be assigning a kernel task to this to turn off
the module for the first SRU kernel after release.

Adam Conrad (adconrad) on 2014-10-14
affects: ubuntu → kmod (Ubuntu)
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
Changed in kmod (Ubuntu):
assignee: Taco Screen team (taco-screen-team) → Adam Conrad (adconrad)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1378648

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: trusty

------- Comment From <email address hidden> 2014-10-14 12:09 EDT-------
(In reply to comment #19)
> This bug is missing log files that will aid in diagnosing the problem. From
> a terminal window please run:
>
> apport-collect 1378648
>
> and then change the status of the bug to 'Confirmed'.
>
> If, due to the nature of the issue you have encountered, you are unable to
> run this command, please add a comment stating that fact and change the bug
> status to 'Confirmed'.
>
> This change has been made by an automated script, maintained by the Ubuntu
> Kernel Team.

I don't understand the nature of this comment 19.

we cannot get the console and root cause was identified. So, due to the nature of this bug the apport* util cannot be run.

Is a new build available now with the module disabled?

Andy Whitcroft (apw) on 2014-10-14
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Adam Conrad (adconrad) wrote :

You can safely ignore the previous comment, it was made by a "helpful" bot.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kmod - 18-1ubuntu2

---------------
kmod (18-1ubuntu2) utopic; urgency=medium

  * blacklist-framebuffer.conf: blacklist bochs-drm (LP: #1378648)
 -- Adam Conrad <email address hidden> Tue, 14 Oct 2014 05:04:57 -0600

Changed in kmod (Ubuntu):
status: Confirmed → Fix Released
bugproxy (bugproxy) on 2014-10-14
tags: added: targetmilestone-inin1410
removed: targetmilestone-inin---
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.16.0-23.30

---------------
linux (3.16.0-23.30) utopic; urgency=low

  [ Andy Whitcroft ]

  * Release Tracking Bug
    - LP: #1381927
  * [Config] CONFIG_DRM_BOCHS=n
    - LP: #1378648

  [ Paolo Pisati ]

  * [Config] armhf: disable JUMP_LABEL
    - LP: #1378856
 -- Andy Whitcroft <email address hidden> Thu, 16 Oct 2014 10:09:49 +0200

Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers