kmod needs to handle mlx4

Bug #1305874 reported by Chris J Arges on 2014-04-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kmod (Ubuntu)
High
Adam Conrad
Trusty
High
Adam Conrad

Bug Description

This affects 14.04.

When booting the installer with a mellanox card that requires the mlx4_en driver, it does not get loaded due to how the module dependencies are structured. Therefore the installer will not show the mellanox card as a configurable network interface unless the module has been manually loaded.

Chris J Arges (arges) on 2014-04-10
Changed in kmod (Ubuntu):
status: New → In Progress
Adam Conrad (adconrad) on 2014-04-10
Changed in kmod (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kmod - 15-0ubuntu6

---------------
kmod (15-0ubuntu6) trusty; urgency=medium

  * debian/rules: Install mlx4.conf in the udeb as well (LP: #1305874)
  * debian/kmod.upstart: Process all the modules-load.d (LP: #1302767)
 -- Adam Conrad <email address hidden> Tue, 08 Apr 2014 13:40:16 -0600

Changed in kmod (Ubuntu Trusty):
status: In Progress → Fix Released

I've just tested again the newest installer image from
http://cdimage.ubuntu.com/ubuntu-server/daily/pending/trusty-server-amd64.iso
And it still does not detects mlx4 NICs automatically.
After I drop to shell, modprobe the mlx4_en manually and back to the installer it
detects the NICs as supposed to be in the first place.

Adam Conrad (adconrad) wrote :

You were a bit too quick to test, Eyal. The new kmod needed to be included in a new debian-installer build, and then that in a new ISO. Today's ISOs should have the fix.

Eyal Perry (eyalpe) wrote :

Thanks Adam,
I've verified the fix - issue resolved.

Best Regards,
Eyal.

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Adam Conrad
Sent: Saturday, April 12, 2014 7:46 PM
To: Eyal Perry
Subject: [Bug 1305874] Re: kmod needs to handle mlx4

You were a bit too quick to test, Eyal. The new kmod needed to be
included in a new debian-installer build, and then that in a new ISO.
Today's ISOs should have the fix.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1305874

Title:
  kmod needs to handle mlx4

Status in “kmod” package in Ubuntu:
  Fix Released
Status in “kmod” source package in Trusty:
  Fix Released

Bug description:
  This affects 14.04.

  When booting the installer with a mellanox card that requires the
  mlx4_en driver, it does not get loaded due to how the module
  dependencies are structured. Therefore the installer will not show the
  mellanox card as a configurable network interface unless the module
  has been manually loaded.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kmod/+bug/1305874/+subscriptions

Eyal Perry (eyalpe) wrote :

Hi Adam/Chris, unfortunately this bug is still effective in the released version:
http://releases.ubuntu.com/trusty/ubuntu-14.04-server-amd64.iso

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers