Klavaro is not completely translated even when the .po is completely translated

Bug #953753 reported by Javier López on 2012-03-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
klavaro (Ubuntu)
Undecided
Unassigned
Oneiric
Medium
Unassigned

Bug Description

[Problem]
klavaro not completely translatable due to strings marked fuzzy.

[Impact]
Interface looks mixed for all users who use its system in Spanish, back porting the patch will allow them to use it all in their first language.

[Development Fix]
Bug was caused because some strings were marked as fuzzy ones, the version fixed was klavaro 1.9.3. The patch updates the spanish translation .po.

[Stable Fix]
Patch applies to the 1.9.2 package in oneiric with no changes needed:

Trying patch debian/patches/03_fix_mixed_spanish_english_strings.patch at level 1 ... success.

[Text Case]
In Oneiric:
# apt-get install klavaro language-pack-es
# LC_ALL=es_MX.utf-8 klavaro
# apt-get purge klavaro

[Regression Potential]
None, it's just a translation update.

[Original Report]
Release of Ubuntu: Ubuntu precise (12.04)
Package Version: klavaro_1.9.3, I guess it was syn from debian
Expected Results: Get the whole interface translated
Actual Results: The whole interface is NOT translated

Oi, bom dia / Hi there,

Some parts of klavaro aren't translated even when the .po file is completely translated, I do want to use Klavaro in Spanish:

Steps

In a new Ubuntu installation (precise)

# apt-get install klavaro language-pack-es
# LC_ALL=es_MX.utf-8 klavaro
# apt-get purge klavaro

I link 3 screenshots where I show the parts who aren't translated, I've reviewed the es.po file and it's completely translated so I dunno why the actual program is not. I tried the latest klavaro 1.9.4:

# wget http://downloads.sourceforge.net/project/klavaro/klavaro-1.9.4.tar.bz2
# tar jxvf klavaro-1.9.4.tar.bz2
# apt-get install pkg-config libgtk2.0-dev imagemagick libcurl4-gnutls-dev libgtkdatabox-dev
# ./configure && make && make install && cd src
# LC_ALL=es_MX.utf-8 ./klavaro

with the same result

Screenshots
[1] http://www.mononeurona.org/img/imgusers/chilicuil_2439.png
[2] http://www.mononeurona.org/img/imgusers/chilicuil_2440.png
[3] http://www.mononeurona.org/img/imgusers/chilicuil_2441.png

Related branches

Javier López (javier-lopez) wrote :
tags: added: bitesize
tags: added: precise
Javier López (javier-lopez) wrote :

The mixed interface spanish/english was fixed, it was because of fuzzy strings in the es.po file, I've send this patch also to the translation klavaro system, hopefully it'll integrated in upstream, from there to Debian and then Ubuntu, however I'm afraid it will not be done as fast to get in precise on time, that's why I suggest integrating it in the current Ubuntu version, if accepted I'll request an SRU for oneiric

Martin Pitt (pitti) wrote :

Hello Francisco,

thank you for this! Can you please also mail this patch to upstream? (Felipe E. F. de Castro <fefcas (a) gmail (p) com > as per http://klavaro.sourceforge.net/en/contrib.html)

Javier López (javier-lopez) wrote :

Of course, I've already send it to the <translation project> who manage the klavaro translation, mmm, not sure if I should send it to Felipe directly.., mmm, I will send it and see what happens xD, I hope he doesnt bite too hard =)

Done, I've just forward it
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package klavaro - 1.9.3-1ubuntu1

---------------
klavaro (1.9.3-1ubuntu1) precise; urgency=low

  * debian/patches/03_fix_mixed_spanish_english_strings.patch: fixes mixed
    interface (LP: #953753)
 -- <email address hidden> (Javier P.L.) Tue, 13 Mar 2012 03:34:26 -0600

Changed in klavaro (Ubuntu):
status: New → Fix Released
Javier López (javier-lopez) wrote :

SRU patch

description: updated
Bryce Harrington (bryce) on 2012-03-22
description: updated
Bryce Harrington (bryce) on 2012-03-22
description: updated
Bryce Harrington (bryce) on 2012-03-22
Changed in klavaro (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → Medium
Bryce Harrington (bryce) on 2012-03-22
description: updated
Bryce Harrington (bryce) on 2012-03-23
Changed in klavaro (Ubuntu Oneiric):
status: Triaged → Fix Committed
Bryce Harrington (bryce) wrote :

Thanks, sponsored the upload for oneiric.

Hello Javier, or anyone else affected,

Accepted klavaro into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Javier López (javier-lopez) wrote :

Hi Martin

I've test the proposed version:

ii klavaro 1.9.2-1ubuntu0.1 Flexible touch typing tutor

And it works as expected =)
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Adolfo Jayme (fitojb) on 2012-03-23
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package klavaro - 1.9.2-1ubuntu0.1

---------------
klavaro (1.9.2-1ubuntu0.1) oneiric-proposed; urgency=low

  * Add 03_fix_mixed_spanish_english_strings.patch: Updates the spanish
    translation, replacing some fuzzy strings with actual translations.
    (LP: #953753)
 -- Bryce Harrington <email address hidden> Thu, 22 Mar 2012 16:39:29 -0700

Changed in klavaro (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments