lottanzb crashed with argument must be a GObject subclass in _type_register()

Bug #713843 reported by Rob Sharp on 2011-02-05
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Fix Released
kiwi (Ubuntu)
lottanzb (Ubuntu)

Bug Description

Binary package hint: lottanzb

I executed a downloaded file from Chromium, which launched lottanzb. Lottanzb then crashes. This happens every time I try to execute the nzb.

The problem is that the Python module 'kiwi', which 'lottanzb' depends upon, is broken. It can be seen by running 'from kiwi.utils import gsignal' in a Python shell and observing the same traceback as the one attached to this bug report.

It seems likely that any software that depends on kiwi in the Natty repositories is broken because of this bug.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: lottanzb 0.5.4-2
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
Architecture: i386
Date: Sun Feb 6 10:00:36 2011
ExecutablePath: /usr/bin/lottanzb
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/lottanzb /home/username/Downloads/tvshow-720p-dimension.nzb
PythonArgs: ['/usr/bin/lottanzb', '/home/username/Downloads/tvshow-720p-dimension.nzb']
 lottanzb 0.5.4-2
 hellanzb 0.13-6.1
SourcePackage: lottanzb
Title: lottanzb crashed with argument must be a GObject subclass in _type_register()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers www-data

Rob Sharp (qnm) wrote :
description: updated
description: updated
Rob Sharp (qnm) on 2011-02-07
visibility: private → public
tags: removed: need-duplicate-check
Severin Heiniger (severinh) wrote :

I can confirm this issue on Natty. The crash occurs when LottaNZB tries to import a module of the Kiwi framework. The bug doesn't lie within LottaNZB, but in Kiwi, as it also occurs when one tries to execute "from kiwi.utils import gsignal" in a Python shell. As LottaNZB 0.5 heavily depends on Kiwi, the bug must be fixed in Kiwi in order for LottaNZB 0.5 to work again.

Please note that LottaNZB 0.6 is nearly ready for release, and a PPA is available: http://www.lottanzb.org/2010/07/lottanzb-0-6-daily-builds-available/

Changed in lottanzb (Ubuntu):
status: New → Triaged
importance: Undecided → High
Severin Heiniger (severinh) wrote :

By the way, thanks alot for taking the time to report this bug. As the developer of LottaNZB, I wouldn't have noticed the problem as I've been running LottaNZB 0.6 on all of my machines for quite some time. It seems like the decision to move away from Kiwi in LottaNZB 0.6 wasn't a bad one.

description: updated
description: updated
Changed in kiwi (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Severin Heiniger (severinh) wrote :

Reported upstream.

On Ubuntu 11.04 with the latest updates applied, trying to import 'kiwi.utils' fails with the traceback:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "kiwi/utils.py", line 78, in <module>
    class _GobjectClassInittableObject(object):
  File "kiwi/utils.py", line 75, in __init__
    metabase.__init__(self, name, bases, namespace)
  File "/usr/lib/pymodules/python2.7/gobject/__init__.py", line 60, in __init__
  File "/usr/lib/pymodules/python2.7/gobject/__init__.py", line 114, in _type_register
    type_register(cls, namespace.get('__gtype_name__'))
TypeError: Error when calling the metaclass bases
    argument must be a GObject subclass

It can be reproduced with both the packaged version 1.9.22 and the one from the website 1.9.26. Compared to Ubuntu 10.10, where Python 2.6 is used by default, Python 2.7 is used by default on Ubuntu 11.04. The version 2.27.0+git20110131-0ubuntu6 of python-gobject is used.

It would be great to know if this problem can be fixed in Kiwi, or whether there's a problem in the GObject bindings. Unfortunately, this bug causes software to break in Ubuntu 11.04 that depends on Kiwi, like LottaNZB.

Rob Sharp (qnm) wrote :

Hey Severin,

Thanks for the response. I've since upgraded to the daily build ppa, and everything is working well.

 - Rob

tags: removed: running-unity
Changed in kiwi:
importance: Unknown → Critical
status: Unknown → Confirmed
Severin Heiniger (severinh) wrote :

LottaNZB 0.6 has been released a few days ago and I just requested an upload to Debian. After the upload will have been completed, it will be possible to request a sync so that the bug can be fixed in Natty.

Changed in lottanzb (Ubuntu):
status: Triaged → Fix Released
Changed in flumotion:
status: Unknown → New
Changed in flumotion:
status: New → Fix Released

This has been solved already.

Changed in kiwi:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.