kipina crashes on launch

Bug #95842 reported by Hyper on 2007-03-25
16
Affects Status Importance Assigned to Milestone
kipina (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kipina

Fiesty Fawn, Herd 5, on AMD64 3200 with 2Gb RAM, Nvidia driver enabled.

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
Date: Sun Mar 25 00:48:49 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/kipina
Package: kipina 0.1.1-3
PackageArchitecture: amd64
ProcCmdline: kipina
ProcCwd: /home/greg
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: kipina
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Uname: Linux HTPC 2.6.20-12-generic #2 SMP Wed Mar 21 19:34:23 UTC 2007 x86_64 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video

Hyper (greg-morley) wrote :
Ryan Osial (osialr+ubuntu-dev) wrote :

I have the same problem in 6.06 x86_64

I compiled the source, ran valgrind, and found a bug in a 2d array alloc. It assumes that sizeof(guint) is the same as sizeof(guint*). I think pointers are 8 bytes in x86_64 instead of 4 bytes in i386.

Patch attached.

StacktraceTop:update (cv=0x7342c0) at kpcalendarview.c:1602
kp_calendar_view_set_view_type (view=0x7342c0, type=KP_VIEW_MODEL_TYPE_MONTH) at kpcalendarview.c:679
kp_view_model_set_view_type (model=0x7342c0, type=KP_VIEW_MODEL_TYPE_MONTH) at kpviewmodel.c:99
kp_view_model_set_view_type (model=0x6792e0, type=KP_VIEW_MODEL_TYPE_MONTH) at kpviewmodel.c:99

LimCore (limcore) wrote :

fails to start also here.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 47551931204976 (LWP 17105)]
0x0000000000412fb7 in ?? ()
(gdb) bt
#0 0x0000000000412fb7 in ?? ()
#1 0x0000000000413bf3 in ?? ()
#2 0x000000000041525d in ?? ()
#3 0x000000000042093d in ?? ()
#4 0x000000000042093d in ?? ()
#5 0x000000000040cc27 in ?? ()
#6 0x00002b3f89878eb0 in g_type_create_instance () from /usr/lib/libgobject-2.0.so.0
#7 0x00002b3f8986022d in ?? () from /usr/lib/libgobject-2.0.so.0
#8 0x00002b3f8985e664 in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#9 0x00002b3f8985f0ac in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#10 0x00002b3f8985f2e1 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#11 0x000000000040add1 in ?? ()
#12 0x000000000040a163 in ?? ()
#13 0x00002b3f8a702b44 in __libc_start_main () from /lib/libc.so.6
#14 0x000000000040a049 in ?? ()
#15 0x00007fff2401f758 in ?? ()
#16 0x0000000000000000 in ?? ()
(gdb) q

Changed in kipina:
status: New → Confirmed
LimCore (limcore) wrote :

The author responded to my email,
0.1 version of kipina is broken and not supported,
versions 0.2.x are on http://sourceforge.net/projects/kipina/ and they work

Is anyone maintaining Kipina in Ubuntu? Can we use the 0.2 versions?

Efrain Valles (effie-jayx) wrote :

I changed the tag. since it has no patch for me to try out. I am working on the upgrade.

Changed in kipina:
assignee: nobody → effie-jayx
Changed in kipina:
assignee: effie-jayx → nobody
Efrain Valles (effie-jayx) wrote :

I have requested a upgrade for this package here
https://bugs.edge.launchpad.net/ubuntu/+source/kipina/+bug/190992

Richard Johnson (nixternal) wrote :

Fix released as update was uploaded to the repos. See bug #190992. Thanks!

Changed in kipina:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers