kile don't insert the symbols on the left panel after a click

Bug #772631 reported by salviano on 2011-04-28
252
This bug affects 49 people
Affects Status Importance Assigned to Milestone
kile (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: kile

The kile version is:
kile:
  Instalado: 1:2.1.0~svn1112278beta4-2ubuntu2
  Candidato: 1:2.1.0~svn1112278beta4-2ubuntu2
  Tabela de versão:
 *** 1:2.1.0~svn1112278beta4-2ubuntu2 0
        500 http://sft.if.usp.br/ubuntu/ natty/universe amd64 Packages
        100 /var/lib/dpkg/status

kile don't insert the symbols on teh left panel after a click. All menu of kile was blocked, I can't acess it
I'am using Ubuntu 11.04 64-bits
My machine is a Dell inspiron core i5

Related branches

David Schinkel (schinkel-d) wrote :

it affects my machine to - I've Ubuntu 10.04 running on a Dell Studio 15

My versions are:

Qt: 4.6.2
KDE Development Platform: 4.4.5 (KDE 4.4.5)
Kile: 2.0.85

SFelke (stephanfelke) wrote :

i have a dell xps 15 as well

SFelke (stephanfelke) wrote :

when you mouse-over over a symbol the "preview-box" only displays "Command:" for each symbol

gerard67 (mathieu-petit) wrote :

Same behaviour for me.

Schmidt (h3ll) wrote :

tried the beta5 (self-compiled) and is even not working there

Philip Muškovac (yofel) wrote :

Confirmed that it's broken in beta4, but at least in the debian beta5 package clicking on a right arrow inserts '\textrightarrow' so this works again. The preview tooltips work again too.

Changed in kile (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Schmidt (h3ll) wrote :

same here. working with the debian package.

Strange thing: https://answers.launchpad.net/ubuntu/+source/kile/+question/152747 was working with the self compiled but not with the .deb package

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kile - 1:2.1.0~svn2010122beta5-1ubuntu1

---------------
kile (1:2.1.0~svn2010122beta5-1ubuntu1) oneiric; urgency=low

  * Merge from debian unstable. (LP: #778505, #777728, #776190, #772631)
    Remaining changes:
    - Drop from Depends: texlive-base-bin
    - Add to Recommends: texlive
    - Demote to Suggests:
      + lilypond
      + texlive-xetex
      + asymptote
      + context
      + dblatex
      + latex2html
      + tex4ht
    - Drop from Recommends:
      + okular | evince | gv
      + kbibtex | pybliographer | gbib | jabref
      + konqueror | firefox
      + dvipdfmx
      + texlive-metapost
    - Don't suggest kile-i18n anymore.

kile (1:2.1.0~svn2010122beta5-1) unstable; urgency=low

  * New upstream release 2.1 beta 5 - git commit
    f58bf5ccbe9b6e382e22b27e6cd12ee16f0ac5a5.
  * Remove patches:
    - 00_root_document_not_detected_kde_bug_233667.diff - stolen upstream.
    - 01_install_doc.diff - not needed anymore.
    - 03_mime_install_dir.diff - merged upstream.
  * Recommend www-browser instead of custom browser list. (Closes: #581498)
 -- Philip MuAkovac <email address hidden> Fri, 06 May 2011 14:54:31 +0200

Changed in kile (Ubuntu):
status: Triaged → Fix Released
Schmidt (h3ll) wrote :

when i install this package on natty it's fixing the autocomplete but not the adding of a symbal out of the symbol toolbox

Is this going to land in natty?

Alexander Poddubny (poddubny) wrote :

I run Ubuntu 11.04 Natty.

Symbol toolbox works with Debian beta 5 package kile_2.1.0~svn2010122beta5-1_i386.deb,
but not works with Oneiric beta 5 kile_2.1.0~svn2010122beta5-1ubuntu1_i386.deb and also not works with self-compiled beta 5. On the other hand, autocompletion (see bug Bug #777728) works with Oneiric beta 5 and not works with Debian beta 5.

Does anybody observe the same behaviour?

SFelke (stephanfelke) wrote :

Problem isn't solved for me - I installed the latest package from source.
now, when I mouse-over a symbol the tex-code and package are beeing shown in the little pop-up toolbox (e.g. Command: \vee) but still nothing happens, when i click on the symbol...

Rohan Garg (rohangarg) on 2011-05-09
summary: - kile don't insert the symbols on teh left panel after a click
+ kile don't insert the symbols on the left panel after a click
Schmidt (h3ll) wrote :

on natty with the following package the autocompletion and the symbol insert is working fine.
https://launchpad.net/~ubuntu-backports-testers/+archive/ppa/+sourcepub/1718390/+listing-archive-extra

Alexander (roth-a) wrote :

no that version
kile_2.1.0~svn2010122beta5-1ubuntu1~natty1~ppa1_amd64.deb
doesn't correct the bug. Still I can't insert a symbol.

And I can't even see the command to insert the symbol manually:
http://image-upload.de/image/W1jS3S/cdd545e7e3.png

Philip Muškovac (yofel) wrote :

Reopening, I *had* this working at some point with the beta5, I'm not sure why I can reproduce that it's broken now again.

Changed in kile (Ubuntu):
status: Fix Released → Triaged
SFelke (stephanfelke) on 2011-05-12
Changed in kile (Ubuntu):
status: Triaged → Confirmed
themroc (rauchweihe) wrote :

Same here with the new version from backports or from Oneiric Ocelot 1:2.1.0~svn2010122beta5-1ubuntu1 :
https://launchpad.net/ubuntu/+source/kile

The new version 1:2.1.0~svn2010122beta5-1ubuntu1 solves the autocompletion problem ( https://bugs.launchpad.net/ubuntu/+source/kile/+bug/777728 ) , but the symbols side tab problem is still not working.

But I have found a version with solves both problems. The packages can be downloaded from here:
https://launchpad.net/~ubuntu-backports-testers/+archive/ppa/+sourcepub/1718390/+listing-archive-extra

Narayanan N (narayana) wrote :

I had to install the version from maverick to get it back to normal.

themroc (rauchweihe) wrote :

@Narayanan N: Have you try the version with I have liked below?
This version works for me (and other) in natty.

Chong Luo (luochong) wrote :

@themroc

Thanks for posting the link to the 2.1-b5 version, which fixes the symbol insertion problem. However, it has another bug. Namely, it crashes if we have it automatically re-open last file.

themroc (rauchweihe) wrote :

@Chong Luo

The "automatically re-open last file or files" work for me with this version. So probably this problem caused by an other thin?

Alexander (roth-a) wrote :

The insert problem still is there with kile_2.1.0%7Esvn2010122beta5-1ubuntu1%7Enatty1%7Eppa1_amd64.deb.

san (sanmohan24) wrote :

I am using kile 1:2.1.0~svn1112278beta4-2ubuntu2 and the bug is still present

Particle (particle) wrote :

I can also confirm this issue:
Version 2.0.85 Using KDE Development Platform 4.6.2 (4.6.2)

serggt1 (serggt1) wrote :

#13 works for me

max (maxozilla) wrote :

I was experiencing the same problem. #13 also fixed it for me.

Anthony (anthonyblond) wrote :

I was experiencing same problem with Ubuntu 11.04. #13 solved the problem. Was able to add the ppa to my system and next update successfully fixed problem.

Filipo Rviz (filipo747) wrote :

#13 also works for my.

acer aspire 4750
ubuntu 11.04

dmiranda (dmiranda) wrote :

#13 also works for me
ubuntu oneiric

Justin Young (mathman316) wrote :

#13 works for me as well (ubuntu natty).
Odd, though: using the PPA through synaptic, beta5 still didn't fix autocompletion bug. But when I manually installed the .deb, everything worked fine.

themroc (rauchweihe) wrote :

The problem with the symbols is still present in kile 2.1.0 Kubuntu oneric 11.10 amd64.

Del (delonly) wrote :

Indeed, the symbols don't work in the current Kile package for amd64 11.10, haven't tested 32-bit. However, the problem is solved upstream, I just compiled Kile from git, and it works like a charm. It is nice if we can get an updated package in 11.10, this is a critical bug for Kile.

Del (delonly) wrote :

Just did some more checking, it seems the problem is Kile not finding it's KDE directories. Opening up a shell, setting the correct environment for Kile with:
 export KDEDIRS=/usr/local
then staring kile from the commandline with
 kile
then kile works without the bug. I checked this with make install from git, and it does indeed need to explicitly be pointed to the correct directory even then.

Stanislav (stas-kazmin) wrote :

This bug still exist in the stable version of kile 2.1 from 2011-06-10.

Installed from this PPA: https://launchpad.net/~kile/+archive/stable/+build/2561801

I have allready tried the #13 and it does not work for me.

I have Ubuntu 11.04 64 bit

I can see the names of the symbols but I can not insert them with a click.

Would be great, if this bug will be fixed in the stable version.

Thanks.

PS: Maybe I can help with some additional information, so let me know.

Stanislav (stas-kazmin) wrote :

Hello, this bug still exists in the stable version 2.1 from 2011.06.10

I have installed kile from this PPA:
https://launchpad.net/~kile/+archive/stable/+build/2561801

I see the names of the commands of the symbols but can not click on them to insert.

I use ubuntu 11.04 64 bit.

Let me know, if I can give some more information.

#13 didn't worked for me.

Thanks.

Kal Palatov (lambda25) wrote :

#13 fixed auto-complete and symbol insert for me :D Linux mint 11 (Katya) 32bit

Del (delonly) wrote :

OK, finally got to the bottom of this. The package is missing all files except the kile binary. All files supposed to be placed in /usr/local/share are missing, the folders are created though, so the files are probably simply missing from the package.

Secondly, Kile needs the KDEDIRS environment variable to be set, which is not done in the current Kile package (this may be a general Kubuntu bug for all I know). This is done by adding the line:
 KDEDIRS="/usr/local"
to the file /etc/environment

If you want Kile working without adding more repositories to your installation, you can install the missing files by compiling Kile from source and installing. Given that my memory is fine, it goes like this:
sudo apt-get install build-essential kdelibs5-dev libqt4-dev cmake
git clone git://anongit.kde.org/kile
cd kile
mkdir build
cd build
cmake ..
make
sudo make install

Then add the line in /etc/environment and reboot.

Is anybody looking into this package, does it have an ubuntu maintainer?

Fathi Boudra (fboudra) wrote :

Assign to me. comment #38 isn't a correct fix, files shouldn't go into /usr/local.

Changed in kile (Ubuntu):
assignee: nobody → Fathi Boudra (fboudra)
milestone: none → oneiric-updates
Del (delonly) wrote :

Sorry about that, I see Debian is using /usr instead of /usr/local (while /usr/local seems to be the default in cmake projects). Hence I assume setting the environment variable as I suggested above may not be a good idea. Seems I get to learn a bit about the Debian packaging of KDE during this bug hunt :)

On 30 September 2011 09:35, Del <email address hidden> wrote:
> Sorry about that, I see Debian is using /usr instead of /usr/local
> (while /usr/local seems to be the default in cmake projects). Hence I
> assume setting the environment variable as I suggested above may not be
> a good idea. Seems I get to learn a bit about the Debian packaging of
> KDE during this bug hunt :)

No problem. Let's find the root cause and tackle this bug :)

Fathi Boudra (fboudra) wrote :

A rebuild of the package fixed the issue.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kile - 1:2.1.0-1build1

---------------
kile (1:2.1.0-1build1) oneiric; urgency=low

  * No changes rebuild to fix binary package, LP: #772631
 -- Jonathan Riddell <email address hidden> Fri, 30 Sep 2011 10:47:04 +0100

Changed in kile (Ubuntu):
status: Confirmed → Fix Released
Fathi Boudra (fboudra) on 2011-09-30
Changed in kile (Ubuntu):
milestone: oneiric-updates → none
themroc (rauchweihe) wrote :

Sorry, but the Bug is not fix in the package kile - 1:2.1.0-1build1 on Kubutnu 11.10 Oneric 64bit!

I have updated to kile - 1:2.1.0-1build1 and nothing is changed. Kile don't display and insert symbols.

Philip Muškovac (yofel) wrote :

Reopening again as it's still broken for me here too.

Changed in kile (Ubuntu):
status: Fix Released → Confirmed
Philip Muškovac (yofel) wrote :

This is fun, it seems like the package modifies the symbol icons and removes the metadata which kile relies on to get the symbol commands.

Philip Muškovac (yofel) wrote :

Screwup of the archive buildds.

Changed in kile (Ubuntu):
status: Confirmed → Triaged
Fathi Boudra (fboudra) wrote :

for the record, the archive buildds run optipng on the images, export NO_PNG_PKG_MANGLE=1to fix the issue.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kile - 1:2.1.0-1ubuntu1

---------------
kile (1:2.1.0-1ubuntu1) oneiric; urgency=low

  * export NO_PNG_PKG_MANGLE=1 so the image metadata isn't stripped from the
    latex symbol icons in the archive builds as kile depends on it.
    This really fixes LP: #772631
 -- Philip Muskovac <email address hidden> Sat, 01 Oct 2011 01:36:40 +0200

Changed in kile (Ubuntu):
status: Triaged → Fix Released
Nick Sanchirico (lnk2past) wrote :

Ubuntu 11.04, do not know much about the distribution of kile that I have.

Changed in kile (Ubuntu):
assignee: Fathi Boudra (fboudra) → Nick Sanchirico (lnk2past)
assignee: Nick Sanchirico (lnk2past) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers