word wrap faulty: cursor jumps forward on new line

Bug #523883 reported by Dominik Wujastyk on 2010-02-18
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
kde4libs (Ubuntu)
Undecided
Unassigned
kile (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kile

Splash screen: Kile 2.1 beta 3

$ kile --version
Qt: 4.5.2
KDE: 4.3.5 (KDE 4.3.5)
Kile: 2.0.84

Installed version: 1:2.1.0~svn1079982-0ubuntu1~karmic1~ppa1

Running under an up-to-date Ubuntu 9.10,

apt-cache policy kile
kile:
  Installed: 1:2.1.0~svn1079982-0ubuntu1~karmic1~ppa1
  Candidate: 1:2.1.0~svn1079982-0ubuntu1~karmic1~ppa1
  Version table:
 *** 1:2.1.0~svn1079982-0ubuntu1~karmic1~ppa1 0
        500 http://ppa.launchpad.net karmic/main Packages
        100 /var/lib/dpkg/status
     1:2.1.0~svn1014763beta2-1ubuntu1 0
        500 http://archive.ubuntu.com karmic/universe Packages

--- Bug report:

I've got static word wrap on, at column 62. When my typing gets to the end of a line, the cursor often jumps to a position a few characters along in the next line.

For example, with * marking the position of my cursor, when I type "i", the following is the before and after scenario.

Obeyesekere (impact in Sri Lanka), Montgomery (medical pract*),
Taylor, and

Obeyesekere (impact in Sri Lanka), Montgomery (medical
practi),* Taylor, and

So the cursor has jumped two chars forward, and my typing is in a mess.

I can't routinely repeat the error, and I'm not sure about all the features of it. It seems to vary according to the exact layout of the text. But the above example was repeatable.

Dominik Wujastyk

Beto (albert-granados) wrote :

It stills affecting kile 2.1 beta 4 in lucid.

Does the same happen if you use kate with static word wrap?

Changed in kile (Ubuntu):
status: New → Incomplete

Dear Andreas,

I don't have Kate, and I just went to install it and Synaptic has so many
KDE includes that it comes to nearly 300MB. I'm reluctant to go down that
path.

I've moved over to TeXworks for the time being. It's a strange little
beast, but I'm quite liking it. Nothing like Kile, which really feels like
a strong system for long term use.

I'm sorry I can't help more with debugging this problem.

Best wishes, and thank you for the fine work,
Dominik

Dr Dominik Wujastyk
Institut für Südasien-, Tibet- und Buddhismuskunde
Universität Wien
Spitalgasse 2-4, Hof 2, Eingang 2.1
A-1090 Vienna
Austria
--
long term email address: <email address hidden>
PGP key: http://wujastyk.net/pgp.html

On 23 April 2010 00:52, Andreas Wenning <email address hidden> wrote:

> Does the same happen if you use kate with static word wrap?
>
> ** Changed in: kile (Ubuntu)
> Status: New => Incomplete
>
> --
> word wrap faulty: cursor jumps forward on new line
> https://bugs.launchpad.net/bugs/523883
> You received this bug notification because you are a direct subscriber
> of the bug.
>

sonmez (sonmezsahut) wrote :

I am using Kile kile 2.1 beta 4 in Ubuntu 9.10 and the bug still present.
This is really an annoying bug.

Thanks

sonmez (sonmezsahut) wrote :

I checked Kate 3.3.5 and I can reproduce the same bug there too. Here is how to produce the bug both on both kile and kate:

Start with the following document.
"We construct higher-dimensional versions of the famous domains and show that the
Bergman projection operators for these domains regular"

then bring the cursor to in front of the word "show" in the first line. the cursor should be
touching the word "show". Then try to write the following
"let see if we make a mistake"

you will get:
"We construct higher-dimensional versions of the famous domains and let see
ifshow make a mistake that the
Bergman projection operators for these domains regular"

However, if the curser does not touch the word "show" then you get
"We construct higher-dimensional versions of the famous domains and let see
if we make a mistake show that the
Bergman projection operators for these domains regular"

Also, if I redo every step both programs crash at the end.

Thanks,

Thanks for reporting this bug!

This is most likely a bug in the katepart (from kdelibs) then, which both kate and kile uses for the editing window. Your bug seems to be a problem with the KDE program itself, and not with our KDE packages. While we appreciate your issue, it would be better if it was tracked at https://bugs.kde.org, so that the KDE developers can deal with this speedily and have direct communication with you as the reporter for more effective debugging.

Thanks!

Changed in kile (Ubuntu):
status: Incomplete → Invalid
Changed in kde4libs (Ubuntu):
status: New → Invalid
Dominik Wujastyk (wujastyk) wrote :

Thanks, Andreas,

I began the reporting process at KDE's bugzilla, but in fact other people
have already reported this behaviour, and it is marked as "RESOLVED".

Cf.

   - https://bugs.kde.org/show_bug.cgi?id=218494
   - https://bugs.kde.org/show_bug.cgi?id=168534
   - https://bugs.kde.org/show_bug.cgi?id=211124

Best,
Dominik

Dr Dominik Wujastyk
Institut für Südasien-, Tibet- und Buddhismuskunde
Universität Wien
Spitalgasse 2-4, Hof 2, Eingang 2.1
A-1090 Vienna
Austria
--
long term email address: <email address hidden>
PGP key: http://wujastyk.net/pgp.html

On 28 April 2010 08:31, Andreas Wenning <email address hidden> wrote:

> Undecided
>

It looks to be https://bugs.kde.org/show_bug.cgi?id=168534 which is not marked as resolved.

The other two is marked as duplicates of https://bugs.kde.org/show_bug.cgi?id=168534 (the KDE bugzilla will treat finding a duplicate as a resolution, hence they are marked as resolved; you will then need to look at the duplicate bug to determine the real status, in this instance "new").

Dominik Wujastyk (wujastyk) wrote :

Okay, I added my report as a comment to 168534. I cited your
email<https://bugs.kde.org/show_bug.cgi?id=168534#c18>;
hope that's okay.

Best,
Dominik

On 28 April 2010 15:28, Andreas Wenning <email address hidden> wrote:

> It looks to be https://bugs.kde.org/show_bug.cgi?id=168534 which is not
> marked as resolved.
>
> The other two is marked as duplicates of
> https://bugs.kde.org/show_bug.cgi?id=168534 (the KDE bugzilla will treat
> finding a duplicate as a resolution, hence they are marked as resolved;
> you will then need to look at the duplicate bug to determine the real
> status, in this instance "new").
>
> --
> word wrap faulty: cursor jumps forward on new line
> https://bugs.launchpad.net/bugs/523883
> You received this bug notification because you are a direct subscriber
> of the bug.
>

sonmez (sonmezsahut) wrote :

on https://bugs.kde.org/show_bug.cgi?id=168534#c18
it says that this is fixed but I still have this problem.
I would appreciate if someone can let me know how to apply
the patch provided in the link above to my system?

Thanks

On 29 September 2011 03:55, sonmez <email address hidden> wrote:
> on https://bugs.kde.org/show_bug.cgi?id=168534#c18
> it says that this is fixed but I still have this problem.
> I would appreciate if someone can let me know how to apply
> the patch provided in the link above to my system?

Please, could you give more information on your system?
Assuming you're using Ubuntu Lucid with KDE 4.4.5, the patch
cannot be applied as Kate interface has changed.
The bug has been fixed upstream since KDE 4.5.0 and available with
Ubuntu Maverick that include KDE 4.5.1.

Fathi Boudra (fboudra) wrote :

Update bug information to reflect current status: fix-released in maverick-updates.

Rationale: the bug has been fixed upstream since KDE 4.5.0 and available with Ubuntu Maverick that include KDE 4.5.1.

Changed in kde4libs (Ubuntu):
milestone: none → maverick-updates
status: Invalid → Fix Released
sonmez (sonmezsahut) wrote :

Thanks for the update. As you guessed I am using Ubuntu Lucid with KDE 4.4.5.
I guess I will have to update my system.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.