kid3 assert failure: *** stack smashing detected ***: kid3 terminated after opening a mp3 file

Bug #425319 reported by Christian Mangold on 2009-09-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kid3 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: kid3

kid3 is broken. As topic says, it terminates after opening a mp3 file. I tested it with our Ubuntu package and with the one from Debian. Same failure.

ProblemType: Crash
Architecture: i386
AssertionMessage: *** stack smashing detected ***: kid3 terminated
CrashCounter: 1
Date: Sun Sep 6 20:00:08 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/kid3
NonfreeKernelModules: nvidia
Package: kid3 1.2-1ubuntu2
ProcCmdline: /usr/bin/kid3 -caption Kid3 -icon kid3
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
Signal: 6
SourcePackage: kid3
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libc.so.6
 abort () from /lib/tls/i686/cmov/libc.so.6
 ?? () from /lib/tls/i686/cmov/libc.so.6
 __fortify_fail () from /lib/tls/i686/cmov/libc.so.6
Title: kid3 assert failure: *** stack smashing detected ***: kid3 terminated
Uname: Linux 2.6.31-9-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Christian Mangold (neversfelde) wrote :

StacktraceTop:__kernel_vsyscall ()
*__GI_raise (sig=6)
*__GI_abort () at abort.c:92
__libc_message (do_abort=2,
*__GI___fortify_fail (

Changed in kid3 (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Christian Mangold (neversfelde) wrote :

kid3 (1.2-1ubuntu3) karmic; urgency=low

  * Rebuild against new taglib 1.6 (LP: #425319)
    - debian/control: Remove libmp4v2-dev again., breaks the build
    - debian/rules: Change KDE4 cmake flag to disable MP4 support and add
      --without-mp4v2 to configure of kid3-qt build

 -- Christian Mangold <email address hidden> Mon, 28 Sep 2009 22:56:37 +0200

I talked to upstream and he couldn't compile with enabled MP4 support, either. taglib is now also compile MP4 enabled afaik, might be the problem. Anyway kid3 isn't working in it's current state and MP4 support needs to be removed again and a rebuild is necessary.

Changed in kid3 (Ubuntu):
assignee: nobody → Christian Mangold (neversfelde)
visibility: private → public
Changed in kid3 (Ubuntu):
status: New → In Progress
Jonathan Thomas (echidnaman) wrote :

Taking a look now.

Changed in kid3 (Ubuntu):
assignee: Christian Mangold (neversfelde) → Jonathan Thomas (echidnaman)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kid3 - 1.2-1ubuntu3

---------------
kid3 (1.2-1ubuntu3) karmic; urgency=low

  * Rebuild against new taglib 1.6 (LP: #425319)
    - debian/control: Remove libmp4v2-dev again., breaks the build
    - debian/rules: Change KDE4 cmake flag to disable MP4 support and add
      --without-mp4v2 to configure of kid3-qt build

 -- Christian Mangold <email address hidden> Mon, 28 Sep 2009 22:56:37 +0200

Changed in kid3 (Ubuntu):
status: In Progress → Fix Released
Christian Mangold (neversfelde) wrote :

This bug isn't fixed with *ubuntu3. The reason for the problem is bug #444466.

Changed in kid3 (Ubuntu):
status: Fix Released → New
assignee: Jonathan Thomas (echidnaman) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers