Disk selector appears with kickstart

Bug #61576 reported by Andy Delcambre on 2006-09-21
4
Affects Status Importance Assigned to Milestone
kickseed (Ubuntu)
Undecided
Colin Watson

Bug Description

The disk selector appears even with a kickstart file which has partition information in it. Once you say "Erase entire disk <information about the disk>" it continues and uses the partition information from the kickstart.

This is a regression of Bug #38111.

Colin Watson (cjwatson) on 2006-10-03
Changed in kickseed:
assignee: nobody → kamion
Colin Watson (cjwatson) wrote :

Could I have a copy of your Kickstart file (with passwords blanked out if necessary), please?

Changed in kickseed:
status: Unconfirmed → Needs Info
Andy Delcambre (adelcambre) wrote :

Here is the kickstart file, we use %include to get the drivemap in. I am attaching that as well.

Andy Delcambre (adelcambre) wrote :

Here is the drivemap

Colin Watson (cjwatson) wrote :

OK, thanks. There are two problems here. Firstly, we don't handle DOS newlines properly (so you might need to run that through dos2unix); secondly, 'clearpart --all' is broken with modern device names. I'll look at both of these bugs.

Changed in kickseed:
status: Needs Info → Confirmed
Colin Watson (cjwatson) wrote :

This will require a debian-installer rebuild in order to take effect. I expect to be doing one of these in the next few days.

kickseed (0.40) edgy; urgency=low

  * Handle Kickstart files with DOS line endings (see Malone #61576).
  * test-kickseed: Adjust mktemp call to work with busybox.
  * Make 'clearpart --all' write out a partman auto.d script to clear the
    first disk, since /dev/discs/disc0/disc isn't available any more and
    there's no single static alternative (closes: Malone #61576).

 -- Colin Watson <email address hidden> Wed, 4 Oct 2006 20:30:23 +0100

Changed in kickseed:
status: Confirmed → Fix Released
Andy Delcambre (adelcambre) wrote :

Thanks for that, the dos newlines probably appeared when i downloaded the file on my windows box and used wordpad to remove the passwords. (They don't appear when coming from the kickstart server)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers