kde-l10n-si fails to install due to /usr/share/locale/si/LC_MESSAGES/kcmhtmlsearch.mo being in khelpcenter as well

Bug #1460444 reported by Karl-Philipp Richter on 2015-05-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kde-l10n-si (Ubuntu)
High
Unassigned
khelpcenter (Ubuntu)
High
Unassigned

Bug Description

`sudo apt-get install kde-l10n-si` fails with

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following package was automatically installed and is no longer required:
      libreoffice-l10n-de
    Use 'apt-get autoremove' to remove it.
    The following NEW packages will be installed:
      kde-l10n-si
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0 B/545 kB of archives.
    After this operation, 2,899 kB of additional disk space will be used.
    (Reading database ... 1092001 files and directories currently installed.)
    Preparing to unpack .../kde-l10n-si_4%3a4.10.97-0ubuntu1_all.deb ...
    Unpacking kde-l10n-si (4:4.10.97-0ubuntu1) ...
    dpkg: error processing archive /var/cache/apt/archives/kde-l10n-si_4%3a4.10.97-0ubuntu1_all.deb (--unpack):
     trying to overwrite '/usr/share/locale/si/LC_MESSAGES/kcmhtmlsearch.mo', which is also in package khelpcenter 4:5.2.2a-0ubuntu1
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Errors were encountered while processing:
     /var/cache/apt/archives/kde-l10n-si_4%3a4.10.97-0ubuntu1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

Is there seriously no check to assert that all files of non-conflicting packages are disjoint?

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: kde-l10n-si (not installed)
Uname: Linux 4.0.1-040001-generic x86_64
ApportVersion: 2.17.2-0ubuntu1.1
Architecture: amd64
CurrentDesktop: Unity
Date: Sun May 31 18:17:01 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2015-04-02 (58 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Beta amd64 (20150326)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: kde-l10n-si
SystemImageInfo:
 current build number: 0
 device name:
 channel: daily
 last update: Unknown
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
DistroRelease: Ubuntu 15.10
InstallationDate: Installed on 2015-12-12 (4 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
Package: khelpcenter 4:5.4.2-0ubuntu1
PackageArchitecture: amd64
Tags: wily
Uname: Linux 4.3.0-040300-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
---
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
DistroRelease: Ubuntu 15.10
InstallationDate: Installed on 2015-12-12 (36 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
Package: khelpcenter 4:5.4.2-0ubuntu1
PackageArchitecture: amd64
Tags: wily
Uname: Linux 4.3.3-040303-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm bumblebee cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

description: updated
Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

I run into the same conflict when I attempt to install both these packages at once on Ubuntu Wily.

Looking at open bugs for khelpcenter I found bug 1430593, so this might be similar conflicts for all kde-l10n-* packages. I wasn't really sure wheter to mark this a duplicate or not though.

Changed in kde-l10n-si (Ubuntu):
status: New → Confirmed
tags: added: wily
Changed in khelpcenter (Ubuntu):
status: New → Confirmed
Changed in kde-l10n-si (Ubuntu):
importance: Undecided → High
Changed in khelpcenter (Ubuntu):
importance: Undecided → High

I created upstream bug report https://bugs.kde.org/show_bug.cgi?id=353829.

The upstream bug report doesn't make sense (I closed it as resolved/invalid) since this is a pure Ubuntu packaging issue.

apport information

tags: added: apport-collected
description: updated

apport information

apport information

Now there's a new failure because `/usr/share/locale/si/LC_MESSAGES/kcmcolors.mo` is managed by both `kde-l10n-si` and `plasma-desktop-data`, reported as https://bugs.launchpad.net/ubuntu/+source/kde-l10n-si/+bug/1535275. Maybe this is fixed or not.

description: updated

apport information

apport information

apport information

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.